x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problems in Export-import animated character FBX rigged by Advanced Skeleton in Maya 2014 to UE4

hello everyone,

i'm new to UE4, currently having export-import problems from Maya 2014 to UE4:

in Maya, the character geometry isn't a single mesh geo, but consists of lots of geo fragments like this hierarchy:

  • Geo_Mesh_group

  • geo_group01

  • geo01a

  • geo01b

  • geo02

  • geo03

  • geo04

  • geo_group02

  • 80 geos

  • geo05

  • geo06

for rigging, I used Advanced Skeleton autorig plugin. it automatically created hierarchy as follows:

  • Group

  • Main

  • FitSkeleton

  • MotionSystem (FK + IK joints, controllers)

  • DeformationSystem (default bind joints + additional facial bind joints + accessory joints)

when i finished rigging and skinning and tried to export the fbx, there were Maya warning and error messages as follows:

  • Exporting T-Pose FBX ('Animation' unchecked):

    Warning: Complex animation baked (1) 537 attributes had complex animation. Complex animation was exported as baked curves. (112770 evaluations done)

then I ignored it and continued importing the FBX from UE4, which gave me warning messages:

  • when importing Skeletal Mesh (the T-pose FBX):

    Multiple roots are found in the bone hierarchy. We only support single root bone. Multiple roots found Import failed.

  • when importing Animation FBX:

    Imported bone transform is different fromoriginal. Please check Output Log to see detail of error.

  • the final results:

  1. the char is lying, not standing (it seems like Y-up and Z-up axis switched). I had tried to change to Z-up axis in Maya, then rotated the lying character to standing, but it didn't make the character stand

  2. head geo is missing, but hair geo, which is a separate fragment, isnt

so how do I fix these issues? your suggestion is appreciated with thanks.

Product Version: Not Selected
Tags:
more ▼

asked Sep 18 '14 at 11:24 AM in Using UE4

avatar image

nubitol
1 1 1 2

avatar image Lovecraft_K ♦♦ STAFF Sep 25 '14 at 07:02 PM

Hey nubitol -

Is it possible to get a test MB scene file or the FBX for your character? We do not have that particular plug-in to create a test asset from.

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey nubitol -

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Eric Ketchum

more ▼

answered Sep 30 '14 at 01:44 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 735

avatar image borbs727 Mar 14 '16 at 09:33 PM

I'm running into this issue. Looks like its constraint related. AdvSkel has a lot of blend nodes and such going straight into the bound skeleton that you're supposed to use for exporting.

The file is a few mb too big, so here's a link: https://onedrive.live.com/redir?resid=E655C32B5E1AF7A8!789316&authkey=!AGriejOwjAkWuDg⁢hint=file%2cmb

avatar image Lovecraft_K ♦♦ STAFF Mar 16 '16 at 02:57 PM

Hi borbs727 -

Importing the Generated FBX from your Maya, imports into 4.10.4 with no errors for me. Here are my import settings:

alt text

Let me know what you Maya FBX export settings are as well if you are still having the issue importing the fbx.

Thank You -

Eric Ketchum

importsettings.jpg (48.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question