Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Visual Studio 2013 failed to load solution file.

Branch: Binary build via Unreal Launcher.

Build Version: 4.4.2, and 4.4.3.

Detailed description of the issue: Ever since I updated to version 4.4.2 (and even 4.4.3), I have been unable to load a visual studio solution that was generated by UE4.

Screenshots: Here's a screenshot of what Visual Studio looks like when it fails to load it. http://puu.sh/bE8fU/f001f403f9.png And here's the error message that is provided: http://pastebin.com/ytEYH7Pv

Repro Steps: 1. Open up the Unreal Launcher 2. Open up UE4. 3. Start or load a project. (Note steps 1-3 is optional if you already have a solution file generated). 4. Open up the visual studio 2013 solution in whichever way you want. On my machine, it fails to load.

This did not occur in 4.4.1, and does not occur in 4.4.1 as my other machine still has it installed and it works great. And yes, this machine also worked great in 4.4.1. If there's a way to reverse a couple updates to 4.4.1 via the launcher, I'm all for it.

System Specs: This isn't a performance issue obviously, but here are the system specs anyway. http://puu.sh/bE8IK/395d74d86e.png http://puu.sh/bE8K6/ecc7f832ae.png

Product Version: Not Selected
more ▼

asked Sep 18 '14 at 04:20 PM in Bug Reports

avatar image

45 2 3 7

avatar image Tim C ♦♦ STAFF Sep 18 '14 at 07:09 PM

Hi Philip,

I am having some trouble reproducing this issue. What version of Visual Studio 2013 are you using?

Does this also happen if you install 4.3.1 on this computer through the Launcher and create a code project?

avatar image Shadowriver Sep 18 '14 at 07:17 PM

Did you tried to regenerate VS files?

avatar image Artemis_ Sep 18 '14 at 08:26 PM

Yes, many times.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It appears I wrote this post a little to quickly as I realize I skipped out on a few details. I'm using Visual Studio 2013 Ultimate, and here's a screenshot of what precisely comes up when I create a code project in 4.4.2 / 4.4.3 http://puu.sh/bErMG/2cb40c4589.png Following that is the image shown above (if you click OK) http://puu.sh/bE8fU/f001f403f9.png

I'll do some testing in version 4.3.1 and I'll get back to you. (Though I'm not entirely sure how to install a previous version, so it may take some time). I also didn't expect such a quick response, so for that, thank you.

I'm not sure if it'll help with debugging, but I initially installed 4.4.1 on this machine and then I updated to 4.4.2, which is where the issues began. I waited for another update but the issues persisted with 4.4.3 so that's what prompted this bug report.

EDIT: Installing 4.3.1 now.

EDIT: That's...odd. It's giving me the exact same results with 4.3.1 as I do with 4.4.2 / 4.3.3. I guess it's time to do some reinstalling unless someone has an idea that might fix the problem.

EDIT: I reinstalled everything (VS2013 Ultimate first, then UE4 version 4.4.3) and it seems to be working fine now. Though I still have no idea why updating UE4 to 4.4.2 caused these problems in the first place.

more ▼

answered Sep 18 '14 at 08:26 PM

avatar image

45 2 3 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question