Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Landscape problems

Has anyone found a fix for this yet? or an answer to why this is still happening. https://www.youtube.com/watch?v=1JZTbZT8ffk&feature=youtu.be

I have had this happen since day one and we are now on 4.1 and I am still having this problem. This is not my video but it shows my problem exactly. I have fully given up on the landscape feature and have had to use mesh planes or sculpting a mesh in other applications to have a ground to walk on. This is very irritating, I don't mind using mesh but I loved using the landscape feature to prototype with and figure out my level.

Any answer or response that may enlighten me on what is going on or if this will ever be fixed would be great. Thanks!

Product Version: Not Selected
more ▼

asked Sep 19 '14 at 01:30 PM in Using UE4

avatar image

1 1 4 2

avatar image Adam Davis STAFF Sep 19 '14 at 09:10 PM

Hi Bmikes,

How many textures are you using on one landscape segment? In the video it looks like he has reached the maximum number of textures (13) allowed on any given segment of landscape. This is an issue we are currently assessing but if a user has more than that on one segment of landscape it will default to the gray texture until materials are removed.

avatar image MichaelBMichaels Sep 21 '14 at 04:25 PM

I managed to set it up with the weightblend instead of the Heightblend and it works fine for me this way. For some reason using heightblend with up to 3 different textures will cause the problem shown above. Using the weightblend I have 6 different textures and it works fine.

avatar image Adam Davis STAFF Sep 22 '14 at 03:37 PM

with the heightblend, are you using multiple normals as well as textures?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey D3F3N357R40R,

Take a look at this post where I answered a similar question. You are basically hitting the texture sample limit for landscapes, and need to use the 'Shared:Wrap' feature to exceed this limitation set by the Shader Model you are using.


Let me know if you have additional questions.


Andrew Hurley

more ▼

answered Dec 16 '16 at 07:12 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Bmikes,

We have not heard from you in quite some time. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please post with the requested information. Thank you!

more ▼

answered Sep 29 '14 at 08:54 PM

avatar image D3F3N357R40R Dec 16 '16 at 06:52 AM

I would like to see this issue reopened because I'm having the same problem. Here's my landscape material. It has 4 materials but I can only connect normals, albedo and 3/4 of the roughness maps. Right now I just have the last RMA packed map unplugged and I have a constant in it's place. As soon as I plug in that last roughness map I get the same result as the posted video, tiles painted with the 4th mat change to the world grid mat and never update. I've tried switching between height and weight blending but that didn't help either.alt text

lm example.png (91.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question