x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Comparing two equal transform return me false 90% of time true 10% of time

What sort of magic is this? I thought it was my tired eyes (i posted help for my comparetransform function in bluescript scripting) but it seem that in debug information my both transform are equal and my function return me they are not

here is an example:

Function CompareTransform: alt text

Debug information: alt text

[1]: http://cdn.alltheragefaces.com/img/faces/large/rage-mega-rage-l.png

Product Version: Not Selected
Tags:
more ▼

asked Sep 19 '14 at 02:38 PM in Bug Reports

avatar image

skeleton60
615 38 55 84

avatar image newbprofi Sep 19 '14 at 03:16 PM

Epic magic ). I am also not sure that they are equal from your example.

avatar image Adam Davis STAFF Sep 19 '14 at 03:42 PM

Hi skeleton60,

Can you show me what values are being plugged into your transforms? Thank you!

avatar image skeleton60 Sep 19 '14 at 05:14 PM

here is an example of plugged value that return me false 90% of time, and sometime true o_o

alt text

result of print screen:

alt text

avatar image Adam Davis STAFF Sep 19 '14 at 05:57 PM

Hi skeleton60,

I haven't been able to reproduce this on my end. What values are you feeding into your transform array? Additionally, what version of the editor are you using?

avatar image skeleton60 Sep 19 '14 at 06:10 PM

in my transform array i put transform value of this actor received from the server

i use the 4.4.3 update from the launcher

in my opinion the "set actor transform" dont really set the actor to the exact transform i give it, but sometime it does

because my function return me sometime true _

is that possible that set actor transform can set the actor with an error of 0.000001 somewhere?

avatar image Adam Davis STAFF Sep 19 '14 at 06:28 PM

Try comparing the length of the locations and see if that fixes the error. Note: What I am trying to see is if the error is tied to the location, rotation, or if something else may be causing the problem.

avatar image skeleton60 Sep 19 '14 at 06:50 PM

with the comparing length of location between t1 and t2 it return me the same result (many time false, sometime true)

sometime the rotation dont match like here (not always the Y axis):

alt text

btw sometime rotation match perfectly but i got false, so the location vector seem to not match too but cant see it with printstring, but i can watch it with debug break

avatar image skeleton60 Sep 19 '14 at 07:09 PM

I can simply reproduce this bug with a blank project:

-Create blank blueprint project

-open level blueprint

-do like this blueprint

-be sure to set the static mesh chair to movable

alt text

Look result when launching game: it return many time false :(

(comments are locked)
10|2000 characters needed characters left

7 answers: sort voted first

Hi Skeleton60,

I was able to reproduce this on my end and can confirm that it is specifically reproduced when checking between the locations on the transform, the rotation works as intended. I have entered a bug report, TTP#346988 to be assessed by the development staff. Thank you!

more ▼

answered Sep 19 '14 at 08:00 PM

(comments are locked)
10|2000 characters needed characters left

Thanks for your time i was going mad, is there a way to follow your bug report ?

and are you sure about rotation ? because in my real project i had some strange result like this one

alt text

the rotation dont match on YAW and ROLL

and the blueprint was this:

alt text

how can the yaw and roll be different in this case even i force the actor transform to be the same as my transform in array?

more ▼

answered Sep 19 '14 at 08:09 PM

avatar image

skeleton60
615 38 55 84

avatar image Adam Davis STAFF Sep 19 '14 at 08:12 PM

Hi skeleton60,

I don't believe these two issues are directly related. Please make a second post about the rotation bug so we can track it. What I did to check and see if the bool returned true was to plug the == rotation directly into the print string of the blueprint repro you provided above. This returned true every time.

(comments are locked)
10|2000 characters needed characters left

about the blueprint reproduction did you use the same value as me in the transform? 1.123456

when i do this (with only rotation test) i have false return too

with location test only i get false too ofc

more ▼

answered Sep 19 '14 at 08:24 PM

avatar image

skeleton60
615 38 55 84

(comments are locked)
10|2000 characters needed characters left

if you mean this test

alt text

it return me false

more ▼

answered Sep 19 '14 at 08:26 PM

avatar image

skeleton60
615 38 55 84

(comments are locked)
10|2000 characters needed characters left

if you set 0 0 0 on rotation then it return true

if you set 0 0.2 0 on rotation then it return false

if you set 0 0.1 0 on rotation it return true

more ▼

answered Sep 19 '14 at 08:33 PM

avatar image

skeleton60
615 38 55 84

(comments are locked)
10|2000 characters needed characters left

i am sure there many random value that will return different boolean on comparaison

the problem seem to be on the set actor transform function ?

more ▼

answered Sep 19 '14 at 08:34 PM

avatar image

skeleton60
615 38 55 84

(comments are locked)
10|2000 characters needed characters left

alt text

here is to reproduce a FALSE return with rotation compare

more ▼

answered Sep 19 '14 at 09:09 PM

avatar image

skeleton60
615 38 55 84

avatar image Adam Davis STAFF Sep 22 '14 at 03:28 PM

Hi skeleton60,

I will add this information to the report. Thank you!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question