x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Building from source: 'An internal error has occurred in the compiler.'

Trying to compile Development Editor - Win64 (Preview Build 2289630) in VS2013. Build fails with multiple internal compiler errors.

Compilation output attached

Product Version: Not Selected
Tags:
ue4compfail.txt (71.7 kB)
more ▼

asked Sep 20 '14 at 01:04 PM in Installation & Setup

avatar image

TheFear
61 5 9 12

avatar image Tim C ♦♦ STAFF Sep 21 '14 at 06:19 PM

Hi TheFear,

What version of Visual Studio 2013 are you using? If you have the Express version, are you using Express for Windows Desktop?

avatar image TheFear Sep 24 '14 at 11:36 AM

Hi Tim,

Thanks for the reply, I'm using Visual Studio 2013 Ultimate.

avatar image TheFear Oct 04 '14 at 01:41 AM

Still having this issue. Editor and Project build fine on other PCs, just not 1 in particular (ironically the most stable and powerful of the machines).

I have attached the most recent output if it helps.

Things I have tried: - Clearing my workspace and getting a 'fresh' latest from source control - Reinstalling VS2013 - Checking for read-only files

Am I missing any other logical steps?

buildfailure.txt (4.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Sorry for not getting back to you sooner. If you could, please check to make sure you have the latest service packs for Visual Studio installed.

I have not been able to reproduce this issue yet. This issue has popped up once or twice in the past, and at least one user was able to resolve the issue by re-installing Windows. I would prefer to find a solution that does not involve taking that step, though.

more ▼

answered Oct 06 '14 at 05:49 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I encountered this same error and managed to fix this in my case. Adding my experience here for it may help future searchers.

I was compiling a game project against UE built from source (4.22) with the UE source code included in the solution. The compilation failed on engine code lines within certain FORCEINLINE functions. The error was always "fatal error C1001: An internal error has occurred in the compiler." The same code base compiled fine on a different machine using the same Visual Studio version, vc compiler version, WinSDK version, etc. What fixed it for me was clearing Visual Studio folders of local app data, so deleting

  • C:\Users\\AppData\Local\Microsoft\VisualStudio

  • C:\Users\\AppData\Local\UnrealEngine

  • C:\Users\\AppData\Roaming\Microsoft\VisualStudio

  • C:\Users\\AppData\Roaming\UnrealEngine

You'll lose your Visual Studio preferences and need to re-enter your Visual Studio license, but VS Community being free that shouldn't be an issue.

more ▼

answered Apr 11 '19 at 12:48 PM

avatar image

Zhi Kang Shao
496 9 10 30

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question