x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Camera DOP not affecting Particles

Camera Depth Of Field not affecting on Particles. Particles near my camera must be blurred right? They just dont care about Depth of field lol. Is this bug or what? or should i check something?

Product Version: Not Selected
Tags:
more ▼

asked Sep 20 '14 at 07:03 PM in Rendering

avatar image

Gandosh
38 12 11 13

avatar image Markmad Feb 13 '18 at 02:04 PM

Hey Guys, just upgrading this post...

You should go into your particle`s materials, Translucency/ uncheck Render After DOF

alt text

dof-upgrade.png (271.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Gandosh -

Go into your Particle's Material and disable the "Enable Separate Translucency" in the Material Attributes, apply and they should now respond to DoF

Thank You

Eric Ketchum

more ▼

answered Sep 22 '14 at 08:10 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 735

avatar image Gandosh Sep 23 '14 at 07:29 AM

Oh thank you! It worked. But there is a problem. alt text

capture.jpg (39.4 kB)
avatar image Lovecraft_K ♦♦ STAFF Sep 23 '14 at 01:25 PM

Hey Gandosh -

Hmmmm. This looks like your particle emitter is in the focused area of your DoF settings and then travels into your DoF unfocused areas. You may want to setup a near camera fade effect in the material of the particle system. There is a great wiki tutorial on how to set that up, here, https://wiki.unrealengine.com/Visual_Effects:_Lesson_03_A:_Near_Camera_Fading

Let me know if you are still having problems after trying these fixes -

Eric Ketchum

avatar image Gandosh Dec 08 '14 at 10:54 AM

Hello Eric! i've been very busy last couple of months. So im here again facing this problem haha. I tried your near camera fade effect. But there is nothing changed. alt text

capture.png (2.0 MB)
avatar image Lovecraft_K ♦♦ STAFF Dec 08 '14 at 02:27 PM

Hey Gandosh -

The red highlighted area looks like a Bokeh Lens Flare, go into your Post Process Settings and adjust the intensity or size downward until your get the look you are after. I'm personally not a fan of lens flare I think its often over used, and I would remove it entirely from your scene.

Thank You

Eric Ketchum

avatar image Gandosh Dec 08 '14 at 04:42 PM

there is no lens flare. I don't know how to describe this. That red area is blurred. This was not supposed to blurred. depth is clipped by that tree :P. Beyond that tree the other blurred objects blurring this particle. my god how can i explain so efficiently xD

avatar image Lovecraft_K ♦♦ STAFF Dec 08 '14 at 06:47 PM

Hey Gandosh -

The hexagon I am seeing unless you have used it in your particle system is the default bokeh lens flare effect in the engine. I would look at the material you are using in your particle system and disable use separate translucency. What does the scene render like afterwards?

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey guys, just upgrading the answer of this post... go into your pareticle´s material/ translucency/ uncheck Render after DOF.

Regards!

alt text

dof-upgrade.png (271.7 kB)
more ▼

answered Feb 13 '18 at 02:12 PM

avatar image

Markmad
11 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question