x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Bug] Not all default sections showing

My project is from the launcher, originally a Blueprint project which I have added some C++ classes.

If I run the Editor from Visual Studio, my class, a AI controller has the section and variable in it. But, If I run the Editor from the Launcher, the same BP extending that C++ controller class does not have the section or variable. This is the variable.

     UPROPERTY(EditDefaultsOnly, Category = JumpAnims)
     UAnimMontage* Jump1;
Product Version: Not Selected
Tags:
more ▼

asked Sep 21 '14 at 04:38 AM in Using UE4

avatar image

mikepurvis
2.5k 102 67 262

avatar image Doug E ♦♦ STAFF Sep 22 '14 at 08:19 PM

Hey mikepurvis-

What version of the engine are you running? Does this only happen if the parent class is something other than AIController?

avatar image mikepurvis Sep 22 '14 at 10:15 PM

4.4.3

I will check to see if it is doing the same in other classes.

avatar image mikepurvis Sep 23 '14 at 12:53 AM

I put the variable in a C++ AnimINstance. It works fine if I run the Editor from Visual Studio. If I open the Editor from the Launcher, double clicking the BP extending off that AnimInstance won't open, it says it's corrupt. But, If I close the Editor, then run it from Visual Studio I can open up the same BP with no problem.

avatar image Doug E ♦♦ STAFF Sep 23 '14 at 02:32 PM

Just to confirm, you create a class based on AnimInstance and add only the two lines listed in your original post then compile the project and reopen the editor. Then create an animation blueprint, is that correct? Please let me know if my steps are wrong and what I need to do to follow your setup.

Also, what solution configuration solution platform are you building your project on from Visual Studios?

avatar image mikepurvis Sep 23 '14 at 02:43 PM

So far it has been class based on AIController. I add variable in C++ as above. If I build and run from the Editor BP's based off those classes show the variable. I set and save it. Then, if I close and run the Editor from the Launcher the variables are not in those saved BP's. If I then close and run from Visual Studio and open the BP's from the Editor the variable is present and set correctly.

With the BP based on the AnimInstance I was unable to open the BP if just run from the launcher with a corrupted BP message. Closing, then running the Editor from Visual Studio then that same BP would open with no problem.

I believe its the Debug Editor which I have been running.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The answer to this is. Build to Development Editor. Then the variables are present. What is strange is that it was only partially not working, I think I had at one time built for all the configurations, and so the development binaries had the class, but did not have the updated version with the BP exposed variables yet.

more ▼

answered Sep 24 '14 at 01:44 AM

avatar image

mikepurvis
2.5k 102 67 262

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question