x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Bug?] Ambient Cubemap Reflection

So here is small issue I have with Ambient cubemap. Enabled: alt text

Disabled: alt text

And this happens regardless of my roughness value. I would assume that with roughness set to 1, the cubemap will be so blurred that it cannot be recognized.

I also uploaded my material file to FTP (iniside folder) "M_Skin_Victoria". It's missing textures but it shouldn't be problem I think. I also uploaded CubeMap. CubeMap was captured using SceneCaptureCube

Product Version: Not Selected
Tags:
more ▼

asked Mar 11 '14 at 04:55 AM in Rendering

avatar image

ue4-archive ♦♦ STAFF
49.9k 3662 1988 9113

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

The ambient cubemap works by using the lower mip maps for material with a higher roughness value. Make sure your cubemap has the right content (you can look at the mips in the texture proprties). I assume you apply the ambientcubemap through a postprocessvolume - doing it in the material should only be done in some specal cases e.g. translucency. Maybe there is some issue in the workflow to generate the AmbientCubemap. You should be able to capture a cubemap and export to .hdr and import as longitude latitude texture to use as ambientcubemap. A more direct way should also work. I like the model.

more ▼

answered Mar 11 '14 at 04:55 AM

avatar image

ue4-archive ♦♦ STAFF
49.9k 3662 1988 9113

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 04:55 AM

Yes the issue was indeed that by default captured map doesn't have MipMaps (After right-click on CubeRenderTarget and choosing Create Static Texture).

Fortunetly it can be fixed inside editor by setting mipmap generation setting to Blur (I used Blur5). After that it works fine. Although generating mipmaps for 2k cubemap can take quite a bit of time to say at least.

In anycase sorry for late comment on this!

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 04:55 AM

Hi Lukasz,

Have you considered using Box Reflection Captures for this purpose instead? I think they maybe better suited to your case as they're specifically created to produce correct lighting for rough surfaces in these circumstances as well as having full mip chains.

(there's a possibility that scene capture actors may be able to build mip chains in the future too.)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Lukasz,

I reviewed your post, but I am unsure exactly what your question is. Could you please clarify what effect you are attempting to do or are unable to get the material to do?

Thank you,

Alexander

more ▼

answered Mar 11 '14 at 04:55 AM

avatar image

ue4-archive ♦♦ STAFF
49.9k 3662 1988 9113

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 04:55 AM

As you can see on first image ambient cubemap is rendered on body. That happen when ambient cubemap is enabled in post process. On second image when ambient cubemap intensity is set to zero, the cubemap is not rendered.

My problem is, that despite very high roughness value, the cubemap is rendered very sharply almost like a mirror reflection.
I still want to use cubmap to light my environment, but I also would like that if this cubemap would take Roughness value into consideration. In other words I want it to be blurred on surfaces with high roughness and smooth on low.

IDK if that is supported right now, but it would be cool if it worked the way I described.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 04:55 AM

Hey Lukasz,

Unfortunately we are unable to reproduce this issue. I have tested this with a materials specialist in Beta4 and an internal build, but we are not seeing the level of reflection you are when we set roughness up. Could you please give me more details to your scene? Have you altered the PP Cubemap's strength or settings? What graphics card are you using? Any additional information about your level could help.

Thank you,

Alexander

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 04:55 AM

Hey Thanks for taking care in this issue. I uploaded test map with model, textures, materials and cubemap. I haven't changed anything on the map, except setting up dynamic shadow distance in DirectionalLight (Stationary) and adding second post process volume.

CubeMap was not altered, I just captured it using SceneCaptureCube actor. Just to be clear. The issue seems to not be present if I use stock cubemaps or the ones I have created externally.

File Name: AmbientCubemapIssue.zip

My setup: Windows 8.1 Radeon 7850 (with newest beta drivers). Intel Core i5 750 12GB Ram.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question