x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My NavMesh needs to get rebuild after I reload a map.

Hello everyone I'm having a pretty anoing issue with saving a navmesh which is allready build. For example; I'm rebuilding navigation mesh on my pretty huge world map and it takes about 60 minutes I disable update navigation automatically so it does not rebuild whole nav mesh everytime I restart my editor. Then I'm spawning my AI pawn which is following me as it should and there is no problem so far, but when I save the map and restart the editor my navMesh does not work properly and my AI is not moving at all. I have to rebuild the whole mesh and wait for about an hour to get desired pawn following me. Is there any solution for this, so the editor does not need to rebuild navigation mesh every time I reload the map?

Product Version: Not Selected
Tags:
more ▼

asked Sep 22 '14 at 04:59 PM in Bug Reports

avatar image

Hal_bregg
16 1 3 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Hal_bregg,

This is a known issue, reported here:

https://answers.unrealengine.com/questions/83075/nav-mesh-problemsdisappearing.html

and logged internally as TTP# 343863. I've added your notes to the bug report for our developers. Thanks for the report!

more ▼

answered Sep 22 '14 at 09:52 PM

avatar image Hal_bregg Sep 23 '14 at 09:07 AM

Hi Ben, Thanks for help.

avatar image Haswell Oct 29 '14 at 06:25 PM

Same problem here, even with 4.5.1. Any updates to the internal ticket yet?

avatar image Ben Halliday STAFF Oct 29 '14 at 06:36 PM

Not yet, the issue is still being looked into.

avatar image AntonioModer Nov 28 '14 at 08:33 PM

Hello, Ben Halliday.

Maybe in 4.6.0?

This issue stop my game development, i'm wasting my time !!! :(

Can you please show link to this issue, it on github?

I'm very-very-very waiting this fix!

avatar image Ben Halliday STAFF Nov 28 '14 at 09:06 PM

Hi Antonio,

It looks like this has been fixed internally, though the fix still needs testing. It won't make it into 4.6 at this point, but will likely appear in 4.7.

avatar image AntonioModer Nov 28 '14 at 09:24 PM

Thank you very-very much for quick answer !!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question