x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Packaging sound visualization problem

The editor works fine getting spectrum data from soundwave. I test it by getting one of the element in spectrum array data and it prints out correctly running on editor. After done packaging file, open up the application, the value return 0. So I guess the problem is at the sound visualization plugin part, the build is successful with no any error tho. Please help thx =]

alt text

Product Version: Not Selected
Tags:
bp_as.png (152.9 kB)
more ▼

asked Sep 23 '14 at 08:18 AM in Blueprint Scripting

avatar image

YoshiroTee
20 13 16 18

avatar image YoshiroTee Sep 27 '14 at 04:31 PM

Anyone? Recently I've also tried making this movie in matinee but it seems like getting the same problem. I create a bool to start the music by setting the value to true at Event begin play in level blueprint. However when I play the movie in matinee (AVI format), there's no sound played (AudioComponent in AudioSpectrum BP) and the value I trace return 0. Testing on Editor "Play" and "Simulate" work perfectly though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

If you look at the source code (SoundVisualizationStatics.cpp), you see that this option is only supported in the editor. I am looking into this myself. Also see this thread:

https://forums.unrealengine.com/showthread.php?30332-Sound-Visualisation-Plugin

 #if WITH_EDITORONLY_DATA
     [...]
 #else
     UE_LOG(LogSoundVisualization, Warning, TEXT("Get Amplitude does not work for cooked builds yet."));
 #endif
more ▼

answered Nov 16 '14 at 03:41 PM

avatar image

isgoed
283 10 15 101

avatar image isgoed Feb 10 '15 at 06:32 PM

The thing is that the editor loads the sound as raw wav files, while a deployed game uses some kind of compressed format (ogg?), so only in the editor can the wav file be extracted. I have made code that uses Windows Media Foundation to load files and do Fourier transforms on.

avatar image YoshiroTee Feb 12 '15 at 01:33 PM

So do you mean the compressed sound format is not supported for this plugin? If so maybe there's some compression settings can be changed on build.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question