Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error Failed import: SkeletalMeshComponent, ArrowComponent, CharacterMovementComponent

Hello! I have a blueprint of type Character named BP_Monster, and other two blueprints that are child of BP_Monster: BP_Spawn and BP_Zombie.

BP_Monster has the character components: CapsuleComponent, CharacterMovement, ArrowComponent, and the SkeletalMeshComponent. All these component are inherited correctly by the two children, until yesterday. I started getting the following error messages in the Message Log:

 Error Failed import: SkeletalMeshComponent /Game/Blueprints/Monsters/BP_Monster.Default__BP_Monster_C:CharacterMesh0  in /Game/Blueprints/Spawn/BP_Spawn
 Error Failed import: ArrowComponent /Game/Blueprints/Monsters/BP_Monster.Default__BP_Monster_C:Arrow  in /Game/Blueprints/Zombie/BP_zombie
 Error Failed import: CharacterMovementComponent /Game/Blueprints/Monsters/BP_Monster.Default__BP_Monster_C:CharMoveComp  in /Game/Blueprints/Zombie/BP_zombie
 Error Failed import: SkeletalMeshComponent /Game/Blueprints/Monsters/BP_Monster.Default__BP_Monster_C:CharacterMesh0  in /Game/Blueprints/Zombie/BP_zombie
 Error Failed import: ArrowComponent /Game/Blueprints/Monsters/BP_Monster.Default__BP_Monster_C:Arrow  in /Game/Blueprints/Spawn/BP_Spawn
 Error Failed import: CharacterMovementComponent /Game/Blueprints/Monsters/BP_Monster.Default__BP_Monster_C:CharMoveComp  in /Game/Blueprints/Spawn/BP_Spawn

Anyone have any idea of what could be causing these errors and how to fix them? Thanks.

Product Version: Not Selected
more ▼

asked Sep 23 '14 at 09:04 PM in Bug Reports

avatar image

707 33 107 127

avatar image Ben Halliday STAFF Sep 24 '14 at 07:12 PM

Hey Ghar,

Are your BP_Spawn and BP_Zombie blueprints referenced by other BPs? Are they referenced by the Level Blueprint?

avatar image Ghar Sep 24 '14 at 08:12 PM

BP_Zombie is referenced by 1 other blueprint.

And BP_Spawn is referenced by 2 blueprints, one of them is actually the Level Blueprint. But the level blueprint graph is empty, no events, no variables, nothing. I think it had some logic that was removed some time ago.

So I don't know where the reference is coming from.

avatar image Ghar Sep 24 '14 at 08:39 PM

Ok so, I have a blueprint named BP_ZombieSpawner that can spawn BP_Spawn or BP_Zombie instances during gameplay, and had one placed in the level.

I removed it and now BP_Zombie and BP_Spawn are only referenced by this blueprint, BP_ZombieSpawned. but the error still occurs.

avatar image Ben Halliday STAFF Sep 24 '14 at 09:05 PM

The reason I ask is because another issue I'm looking over had the same thing happen:


They were able to get rid of the error by removing references to the blueprints in the Level Blueprint. I'm wondering if the Level Blueprint reference to these blueprints is causing an issue. Can you try removing those references to see if the errors disappear, and then replace the references and see if they come back? That would help us narrow down what's happening here. Thanks!

avatar image Ghar Sep 24 '14 at 09:33 PM

Oh ! I removed the references and the errors disappear.

In BP_MonsterSpawner I have a Class variable that is set in the construction script

alt text

And it also has a default value of BP_Spawn:

alt text

I replaced them back and the errors are back though.

avatar image Ben Halliday STAFF Sep 26 '14 at 08:11 PM

Which references did you remove to get the errors to go away?

If you move the Class variable declaration from the Construction Script to an Event Begin Play on the Event Graph, do you still get the same errors?

avatar image Ghar Sep 26 '14 at 09:04 PM

Sorry I changed the blueprint form yesterday, but I'm still getting the same error though. Instead of setters I have a select node, not in the construction script but in a function that it's called from the tick event

alt text

Just like before, if I set both class variable to None in the select node, the error does not appear anymore.

I noticed the error appear also in another map that has no reference to BP_Monster, BP_Spawner or BP_MonsterSpawner. It's my Main Menu map that has an empty scene. It only shows the main menu using UMG when the game starts.

It appears in both of these maps and only when the editor starts (they have to be set as the startup map). If I open them from any map after the editor starts there is no error.

avatar image Ben Halliday STAFF Oct 06 '14 at 10:29 PM

Hey Ghar,

Have you updated to 4.5 Preview yet? If not, would you mind creating a copy of this new project in 4.5 Preview and see if the errors persist? There have been some updates involving cyclic dependencies and it may help in your project.

avatar image Ghar Oct 07 '14 at 12:14 AM

Hey Ben, I just created the copy in 4.5 and the errors persist.

avatar image Toby Lael May 08 '15 at 11:19 PM

We just had the same issue with UE 4.7.3. Our workaround:

  1. Open level's blueprint event graph

  2. Remove the Event Tick links, so that all the code is detached and disabled.

  3. Save the level

  4. Exit editor and reload level

  5. Reattach links to Event Tick

  6. Save the level

  7. Exit editor and reload level

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first


A temporary workaround could be to change literal values (of class type) into regular member variables. Create 2 member variables of 'Pawn' class type (for BP_Zombie and BP_Spawn) and set their default values.

Let me know, if it helps.


more ▼

answered Sep 29 '14 at 08:36 AM

avatar image Ghar Oct 07 '14 at 12:15 AM

Hello kaziu, sadly it didn't make a difference :(

avatar image Ben Halliday STAFF Dec 11 '14 at 06:42 PM

Hi Ghar,

Sorry this one slipped under my radar somehow! Which version of the engine are you currently using? Does this error still occur? If so, would you mind uploading the project folder somewhere and sending me a link? I apologize for the delay, somehow I was no longer assigned so I didn't see this issue in my list, but I want to make sure we get this working for you if you need it. Let me know!

avatar image Ghar Dec 11 '14 at 06:53 PM

Hi Ben,

I don't have this problem anymore. I remade the blueprints a while back and it disappeared.Thank you anyway!

avatar image Ben Halliday STAFF Dec 11 '14 at 06:54 PM

Glad to hear it! Let us know if it pops back up again.

avatar image Haskellf Oct 09 '15 at 07:55 PM

This is still persistent in UE4.9. I just created a new project with first person controller, mobile scalable and no content and receive the following error:

Error /Game/FirstPersonBP/Maps/FirstPersonExampleMap : Failed import for SkeletalMeshComponent /Game/FirstPersonBP/Blueprints/FirstPersonCharacter.FirstPersonCharacter_C:SkeletalMesh_GEN_VARIABLE

avatar image Ben Halliday STAFF Oct 12 '15 at 06:00 PM

Hi Haskellf,

This is a separate issue that we have with the First Person template in 4.9, which is already reported in our system (UE-20152). It shouldn't affect your project at all.

avatar image kaziu STAFF Oct 14 '14 at 06:18 PM

Hey Ghar,

Would you mind writing repro steps (an instruction how to reproduce the problem step by step, so we could debug it locally)?


(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question