x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Character isn't moving

Okay, so this issue must be something very simple such as a forgotten checkmark or something, but I'm kinda stuck.

I tried to recreate the Blueprint Top Down project and got my character, gamemode and controller blueprint. First of all, when I put a playerstart in my level, it ignores my player character and the camera just sits there in the middle of the playerstart... If I remove the player start and I run the game, I can see my top down character but movement isn't doing anything. When looking at the blueprints however I can see that it activates and works correctly when I press my left mouse button. So somewhere between the Controller blueprint and the Character blueprint it just doesn't connect.

So I double checked the Gamemode blueprint, and what I saw there was that I'm missing a tab called 'Input', where 'Block input' is unchecked. Could this be why mine isn't working? And if so, how do I get that tab in my GameMode defaults?

I'm sorry for this question, hope that I'm clear enough...

Product Version: Not Selected
Tags:
more ▼

asked Sep 24 '14 at 10:07 AM in Using UE4

avatar image

Serellyn
247 27 28 39

avatar image Ben Halliday STAFF Sep 24 '14 at 01:34 PM

Hey Serellyn,

Did you set your World Settings to use your custom gamemode?

avatar image Serellyn Sep 24 '14 at 05:28 PM

Thank you for replying Ben. Yeah I've set the custom gamemode. Well atleast if World Settings is the same as Project Settings -> Maps & modes. I've added a screenshot :)alt text

example issue.jpg (257.9 kB)
avatar image Matthew Rumble Jun 10 '17 at 05:23 AM

I finally got my 3rd person girl character to work and walk but when I played in the editor, there was a clone of my character and only the second one worked but the camera was stuck behind the original character. After deleting the first character, I was able to move the second/clone but the camera is stuck infront of the girl and I cannot move backward, only foward. I am thinking I need to adjust the spring arm but that is for the orginal character I got rid of in the level to control the second. Anyone can help me?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey Serellyn,

You'll also need to set which Game Mode is being used in the World Settings. You can open the World Settings tab from the main toolbar or by going to Windows > World Settings. Then you'll need to find the Game Mode section and expand that, which will look like this:

alt text

Switch the GameMode Override to your GameMode.

You can read more about setting your GameMode in World Settings here:

https://docs.unrealengine.com/latest/INT/Engine/Animation/CharacterSetupOverview/index.html#gamemodesetup

Hope that helps!

worldsettings.png (60.2 kB)
more ▼

answered Sep 24 '14 at 06:09 PM

avatar image Serellyn Sep 24 '14 at 08:15 PM

Hey Ben, thanks! I forgot that one so I fixed it, but it's still not working. Still no movement and still the same problem when I try to use a PlayerStart. The camera just goes to playerstart instead of the character.

avatar image Ben Halliday STAFF Sep 24 '14 at 08:34 PM

Hm, then there may be something with how your Character Blueprint is set up. Can you show an image of what your Components tab looks like? It's possible your camera isn't set away from your mesh properly. Another thing to check is whether your PlayerStart says BADsize on it... if so, it's intersecting with your floor which may cause this.

I also see that you don't have a Nav Mesh in your Scene Outliner. If you're using the same click-to-move setup as the Top Down template, you won't be able to move the character without one.

Otherwise, I may need to take a look at the project to see what's causing the issue. Just to be clear, if you start a new project from the Top Down Blueprint template, that works fine? You can zip and attach the project folder if it's small enough, or you can put it up somewhere for me to download if you'd like.

avatar image Serellyn Sep 24 '14 at 08:42 PM

Your are great and fast with your responses! The not moving issue was indeed solved my the Nav Mesh, I did not know that so thank you :) However, I can't get the PlayerStart to work. So I would love for you to check that out for me... You've been a great help so far :) The project can be downloaded here: serellyn.net/ProjectDyslexia.zip

avatar image Ben Halliday STAFF Sep 24 '14 at 08:53 PM

Okay, in your MyPlayerCharacter BP, go to the Components tab and select the Camera1 component. Scroll down to the Camera Settings and in the Details panel disable Use Controller View Rotation. For a standard Top Down camera, you don't want to inherit the rotation of the controller for either the Spring Arm or the Camera. That should do it!

avatar image Serellyn Sep 24 '14 at 08:56 PM

You sir, are my hero of the week. I'd give you a medal if I had one =D Thanks a million and sorry for my noob-ish questions. Have a nice day! Or night :) No, have a nice week!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

GameStateBase instead of GameState <- that was my fix. It took over an hour of comparing every element of game mode and every parrent type.

more ▼

answered Jan 29 '17 at 01:37 AM

avatar image

AngeIV
26 2 6

avatar image Kinos141 Jun 30 '17 at 06:23 PM

This was the fix for my issue.

avatar image Zerstoren Jan 03 '19 at 03:11 PM

Yes this was the right fix also for my issue

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

My issue (after many hours of banging my head against the forums) was that the Character -> Mesh -> Animation class was incorrect, and my character wouldn't move until the class was resolved to something that was animated.

more ▼

answered Mar 14 '17 at 01:38 AM

avatar image

OogaJiggaWooga
11 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question