x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

RunUAT.bat ERROR: [Blueprint Project]

Hey,

I've seen alot of similar posts talking about VS (Visual Studio) projects and how to correct the problem using that software, but seen as this is a blueprint only project I am struggling to get it to cook or package.

I have changed my "GlobalGameMode" as mentioned before, I tried running RunUAT on its own but it produces red text and instantly crashes so im not sure where the issue lies.

Here is a copy of my log when I tried cooking, Another for when i tried Packaging.

They are contained in this .rar for some reason I couldn't upload a .txt as an attachment : http://puu.sh/bMidC/b1771d327d.rar

I have also attached a picture of the RunUAT.bat depicting the errors it produces: http://puu.sh/bMih1/68de83900b.png

Product Version: Not Selected
Tags:
more ▼

asked Sep 24 '14 at 06:59 PM in Packaging & Deployment

avatar image

Nemecys
85 10 18 219

avatar image Nemecys Sep 25 '14 at 05:43 PM

Here is some Logs from the project being stripped down to its potential errors, which seem to reside in the Meshes, Textures, Blueprints, Materials folder otherwise without them the project can cook without fail even though the map contains no assets and Fails to Load.

http://puu.sh/bNvyE/784c93fe1a.rar

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I have fixed the Issue I will post my long list of trial and error here soon.


HOW TO FIX

This fix will only work for blueprint only games as this was the kind of Project i was making when the issue occurred

  • Begin by creating a new BLANK project

  • Test that your UE4 build is Valid by Cooking and Packaging this project IF this works then you can continue, if not considering RE-INSTALLING UE4


This part is the trickiest if the issue lies in a file/folder/Blueprint but if your lucky its just a weird project issue

  • Begin by copying one folder of your Project at a time to the NEW BLANK PROJECT

  • I began with Maps

  • Cook the BLANK PROJECT and Package

  • IF this works then continue with the next folder, if not consider a closer examination of Folder/File in question ( in this case maps)

  • Continue this process until you have all Files back in their proper place.

  • Your project should now cook and package succesfully


IF THIS DID NOT WORK THERE IS ONE LAST FIX

  • Begin by taking your current Map and copying ONLY THIS MAP to the new blank project

  • This will leave you with Example_Map and Your_Map in the new BLANK PROJECT

  • From here delete/Backup Example_Map and RESAVE your CURRENT map as Example_Map

  • This should allow it to work with the default Project Settings of this new BLANK PROJECT


IF THIS STILL FAILS

  • Consider cooking all folders par your Blueprint ones

  • Import each Blueprint ONE BY ONE and COOK and COMPILE

THIS WILL CORRUPT YOUR BLUEPRINTS SO HAVE A BACKUP

  • After they are all back in and the project Cooks/Packages then replace them with their UNCORRUPT versions from your PREVIOUS PROJECT

  • They should now cook and package without an issue


Best of Luck

more ▼

answered Sep 25 '14 at 08:46 PM

avatar image

Nemecys
85 10 18 219

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question