x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

During Play in editor (PIE), is there a shortcut to simulate ESC without stopping the game?

A lot of games use keyboard 'ESC' for pause menus, backing out of UI etc. Currently in the ShooterGame sample, you can only send an Escape to the game in Standalone mode. In Play In Editor (PIE) mode the editor responds to the keypress by stopping the game.

It would be great if we could simulate Escape presses in Play In Editor (PIE) mode, for example by pressing Shift+ESC or another key binding to avoid stopping the game session.

Product Version: Not Selected
Tags:
more ▼

asked Sep 26 '14 at 01:28 AM in Using UE4

avatar image

sds-michael
156 9 15 23

avatar image birdfreeyahoo Sep 26 '14 at 01:42 AM

Under Editor Settings->Keyboard settings under Play World, try override the Stop command.

avatar image sds-michael Sep 26 '14 at 04:42 AM

Thanks for the quick reply! I just tried this but it still seems to use Escape as well as the new binding to stop the game. I've got source access so I'll dig in and find out why it's still using Escape. Cheers!

avatar image ruohki Nov 15 '14 at 02:22 AM

if you bound ESC in the input settings just bind another key to the same mapping and remove that key when you cook your content

avatar image MSE_Taliesin Feb 13 '15 at 11:37 PM

I could use an answer to this too. Trying to test functionality related to Escape key handling and it's not quite working in Standalone but there's no way for me to debug it in "New Editor Window" mode like I'd normally do. Setting a new binding in Editor Settings -> Keyboard -> Play World doesn't make a difference; Escape still closes.

avatar image RickTorr2494 May 15 '15 at 10:29 AM

Try pressing f8. While in play

avatar image zompi2 Sep 16 '15 at 05:38 PM

Wow, I'm really digging out an old question. But I found this solution:

In DefaultEngine.ini in the project you can add:

 [/Script/Engine.PlayerInput]
 -DebugExecBindings=(Key=Escape,Command="CloseEditorViewport")

This should unbind the Escape button from closing the game in the editor.

avatar image sds-michael Sep 17 '15 at 12:24 AM

Awesome - that makes testing in-game pause menus a lot easier in the editor. Thanks a lot.

avatar image NashMuhandes Sep 27 '15 at 08:48 PM

Does not work in UE 4.9.1.

avatar image zompi2 Oct 03 '15 at 05:23 PM

Oh. It seems they changed a place. Now you have to put those lines into the DefaultInput.ini, not Engine.

avatar image ndeakin Oct 24 '15 at 01:01 AM

I can't beleive this took a year to be answered, but thank you for being our savior!

avatar image MJ_01 Nov 21 '15 at 06:18 PM

Bump. Can we get answer for this? The posted solution no longer works.

avatar image lackthereof0 Feb 01 '16 at 03:52 AM

I just tested the solution below which works in 4.10.1. Add the following lines to the bottom of DefaultEngine.ini in your project's Config folder, then restart the editor.

 [/Script/Engine.PlayerInput]
 -DebugExecBindings=(Key=Escape,Command="CloseEditorViewport")
avatar image j4k4x Sep 20 '16 at 10:13 AM

there's actually a simpler answer now, for future readers: http://imgur.com/a/4ycde

avatar image NicholaScott Oct 28 '16 at 09:48 PM

Thanks works great :D

avatar image FaustyWalk Sep 02 '17 at 04:03 PM

Thanks ! Works in 4.16.3 (both dev & shipping)

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Technically the previous answer was correct, the location is wrong:

  1. Open DefaultInput.ini

  2. At the top, locate the section: [/Script/Engine.PlayerInput]

  3. Add the following line under all the "+DebugExecBindings" (There should be around four):

-DebugExecBindings=(Key=Escape,Command="CloseEditorViewport")

*Notice that the other four bindings have a "+" sign, while this "-" unbinds the original Esc key setting

more ▼

answered Feb 01 '16 at 08:57 PM

avatar image LEIT Mar 27 '16 at 10:34 PM

It took me a little while to get this right. The location is in the UE4 main directory, not your project folder.

avatar image Steve Hardister ♦♦ STAFF Mar 29 '16 at 02:12 PM

Hi LEIT,

Checking into this I'm not sure what location you're referring to as the Defaultinput.ini in the UE4 Main Directory still only resides in template project folders. So, for instance, if you modify the DefaultInput.ini for the Vehicle Template (for UE 4.11), then every 4.11 project you start with that template will have that functionality. However, if you modify your project's DefaultInput.ini it will override the inputs from the UE4 main directory.

On the other hand, if you do not modify the DefaultInput.ini in the Main Directory then you can choose to add this functionality on a project to project basis. (Location: [YourProject]>Config>DefaultInput.ini.

A couple of notes: You do not have to add the script in the specific location I mentioned before, you can simply add the script to the bottom. Also, DefaultInput.ini does not exist in the Shooter Game example's project folder, so this may be adding to the confusion.

-Let me know if you do not find this to be the case and/or provide the location in the UE4 main directory you are referring to in your comment if different from this explanation.

Thanks,

Steve H.

avatar image LEIT Apr 26 '16 at 01:57 AM

Hi Steve H, Default input and Player input were in two different places. The main directory is where I found the Player input. That was the part that I found confusing. I hope this helps. :)

avatar image Michael Asquith Jul 10 '16 at 09:23 AM

In 4.12 I found the general bindings (Script/Engine.PlayerInput) in:

C:\Program Files (x86)\Epic Games\4.12\Engine\Config\BaseInput.ini

There I was able to comment out (put a ";" in front of line) the bindings that I didn't want, in my case the F1-F5 keys.

This engine sometimes. Honestly.

avatar image Taurian Sep 16 '16 at 04:31 PM

Does this still work in 4.13? It's not appearing to have any effect.

avatar image Steve Hardister ♦♦ STAFF Sep 16 '16 at 08:56 PM

This works in UE4.13 but the location is different. Use the path above:

C:\Program Files (x86)\Epic Games\4.12\Engine\Config\BaseInput.ini

-and add the line here:

PlayerInput

Save and Close; Don't forget to restart the Launcher/Engine.

playerinput.png (39.9 kB)
avatar image Don.Eubanks Oct 10 '16 at 09:24 PM

I don't think the solution you posted will work in 4.13. This DebugExecBind has been removed in favor of an entry in the FPlayWorldCommands class: UI_COMMAND( StopPlaySession, "Stop", "Stop simulation", EUserInterfaceActionType::Button, FInputChord(EKeys::Escape) );

To disable or re-bind this you need to open up the Editor Preferences and click "Keyboard Shortcuts" and navigate to the "PIE/SIE" category. The command you're looking for is "Stop".

avatar image Steve Hardister ♦♦ STAFF Oct 11 '16 at 05:06 PM

I stand corrected. I missed the answer posted by j4k4x above. I've tested this and can confirm assigning "Stop" to something other than "Escape" releases the escape button for debugging purposes. Thanks for pointing this out.

avatar image Rumbleball Feb 16 '17 at 01:44 PM

"To disable or re-bind this you need to open up the Editor Preferences and click "Keyboard Shortcuts" and navigate to the "PIE/SIE" category. The command you're looking for is "Stop". "

Not working in 4.14. Key overwritten, editor restarted. Still quitting PIE when hitting escape.

EDIT: Seems to work only on maps created after the binding was changed

(comments are locked)
10|2000 characters needed characters left

This works as of 4.19 but possibly earlier:

  1. Open the Editor Preferences window (Toolbar -> Edit -> Editor Preferences)

  2. From the list on the left, select the Keyboard and Shortcuts

  3. In the search bar at the top, type Stop

  4. In the results, find the Play World (PIE/SIE) heading and the option Stop - Stop Simulation

  5. Change the Stop - Stop Simulation option to a key which doesn't interfere with your in-game controls.

more ▼

answered Jun 22 '18 at 04:08 PM

avatar image

Dexgecko
40 6 9

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question