x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Dedicated server is always simulating skeletal physics on the PhysX level, no matter how bEnablePhysicsOnDedicatedServer is set

Version: 4.4.3-0+UE4

By default, physics simulation of a SkeletalMeshComponent is disabled on a dedicated server, so as to save resources. It can be enabled by setting USkeletalMeshComponent::bEnablePhysicsOnDedicatedServer=true (see https://answers.unrealengine.com/questions/104567/ for some issues). However, PhysX is internally simulating the skeleton no matter how this flag is set: bEnablePhysicsOnDedicatedServer has no effect on PhysX level.

This can be seen by connecting the engine to the PhysX Visual Debugger (PVD) and looking at the PhysX's internal scene with bEnablePhysicsOnDedicatedServer left at it's initial default value (false):

UE: the skeleton stays still

PhysX: the skeleton stays still, but accumulates gravitational velocity (thus, PhysX must be simulating it. it doesn't move due to UE constantly overwriting the transformations of the skeleton's PhysX bodies.)

If physics simulation is enabled at a later point (skel->bEnablePhysicsOnDedicatedServer=true; skel->SetSimulatePhysics(true)), then the skeleton will immediately start falling at a high speed, due to the accumulated velocity.

(I did not take a look whether the accumulated velocity is visible also on the UE level; I stumbled on this by accident while tracking a different issue in PVD.)

@oricohen: You seem to be working on this topic and might want to take a look at this?

Product Version: Not Selected
Tags:
more ▼

asked Sep 26 '14 at 01:39 PM in Bug Reports

avatar image

hiili
205 15 25 37

avatar image Jonathan Dorman STAFF Nov 05 '14 at 05:01 PM

Hey hiili,

I'm looking into this issue right now (and some of the others you've reported). Do you know if this happens in any later version than 4.4.3?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Jonathan,

I just tried this out in 4.5.0 and it seems that this issue has been fixed! :) With server physics off, a representation of the ragdoll is still created on the PhysX level (by design?), but the ragdoll does not anymore accumulate gravitational velocity. Also, it is now shown as blue in PVD (meaning disabled, I guess?) until I enable server physics (skel->bEnablePhysicsOnDedicatedServer=true; skel->SetSimulatePhysics(true);), at which point it turns green and starts to gradually fall with no incorrectly accumulated initial velocity.

I re-checked this in 4.4.3, although with a slightly different setup. The ragdoll is green in PVD all the time (and accumulates gravitational velocity) even when server physics are off.

Just out of curiosity, please share if you know anything about which change might have fixed this? Thanks! :)

more ▼

answered Nov 07 '14 at 11:43 AM

avatar image

hiili
205 15 25 37

avatar image Jonathan Dorman STAFF Nov 07 '14 at 03:31 PM

I don't know which change fixed this issue - there were a LOT of changes in 4.5!

I'm looking into your other unanswered issues, as well - does this solve any of those?

avatar image hiili Nov 10 '14 at 02:22 PM

I don't think so, as they are not directly related. :/ I know that at least the off-by-90' issue is still present in 4.5.

avatar image Jonathan Dorman STAFF Nov 10 '14 at 02:50 PM

Okay, I'll keep looking into those.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question