Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Multiple roots error using bones linked to CAT rig?

Something weird has been happening to me. A couple of days ago, I used the base human CAT preset, aligned them to where they should be on the model, and linked the individual bones to the parts of the CAT set up, so when I moved the CAT parts, the bones would move with it.

At first, this worked wonderfully well, exporting into UE4 seamlessly, the skeletal mesh worked, the animations worked, etc etc. Then I accidentally deleted the CAT rigged source files, I still have the one with just the bones skinned to the model. So I tried to rebuild the CAT rig, and this is where the weird part comes in, I rebuilt it all and it worked in 3ds Max, however when I imported it into UE4, it gave me a multiple roots error.

I've spent the last couple of days trying to find the source of this error, in vain sadly. I've changed my way of setting CAT up, my export settings, my import settings, I've tried deleting and adding different bones and such, but it always comes with that darned multiple roots error, and I fear if I don't find a solution, my head will be void of all hair soon.

I've been running around on a lot of different websites, and been googling like a madman, and I have yet to find a proper solution that worked for me. So, can anyone please help me?

3ds Max hierarchy

FBX export settings

Export and import

Product Version: Not Selected
more ▼

asked Sep 30 '14 at 04:57 PM in Using UE4

avatar image

21 1 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Oh, nevermind, I had some objects in 3ds max that weren't supposed to be there. It works now.

more ▼

answered Sep 30 '14 at 08:21 PM

avatar image

21 1 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question