x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Closed] GitHub linking isn't working

Hey guys,

I have tried everything and cannot seem to get GitHub to let me get to the Source repository. I get the same message others have gotten:

This organization has no public repositories.

I do have an active account, I did pay the $19, I entered my github username in proper case and it keeps putting it to lower on my account page so I even attempted to change my github username to all lower, clear my username, and re-enter it. I created a new github and tried that, I created a basic repository on my page to see if any activity would trigger it, changed my github username on my account back to my real github, logged in and out of both sites, and used all browsers repeating the steps.

Went through the videos and the tutorials on the site.

It just isn't linking them.

Anyone have any ideas? Is it not an instant thing after I purchase?

Product Version: Not Selected
Tags:
more ▼

asked Oct 01 '14 at 02:08 AM in Installation & Setup

avatar image

Catatonick
6 1 2 5

avatar image Jonathan Dorman STAFF Oct 01 '14 at 01:38 PM

Hey Catatonick,

So, let me just make sure we're on the same page here.

I followed this tutorial to get GitHub set up myself: https://wiki.unrealengine.com/GitHub_Setup

You did the relevant steps, including updating your Unreal account to add your GitHub account.

alt text

And when you got to this step:

alt text

alt text

You don't see anything under Epic Games - or rather, it says 'This organization has no public repositories.'

Is that correct?

avatar image Catatonick Oct 01 '14 at 02:29 PM

That is correct. I just did it again and have the same results. Nothing. I tried quite a few times and got the same result even with another github account I created fresh for this purpose.

I just tried to clear it out, save, log out of both, log in to my unreal account, set it, then log into github. There is no organizations section. alt text

unreal1.jpg (7.0 kB)
unreal2.jpg (11.8 kB)
unreal3.jpg (22.9 kB)
avatar image Jonathan Dorman STAFF Oct 01 '14 at 05:38 PM

Did you ever get an email confirming that you'd connected your Unreal account with your GitHub account?

avatar image Catatonick Oct 01 '14 at 06:14 PM

I was earlier but when I just changed it I did not. It doesn't appear to be sending anything to me at the moment. This was one of the emails from earlier:

Hi Nicholas,

You have successfully added a github association to your unrealengine.com account. If you did not make this request, please contact us immediately.

avatar image Catatonick Oct 01 '14 at 06:33 PM

ok it just now came through in my email. It says I have successfully added my github association but it did not work. I still don't have any organizations listed.

avatar image Jonathan Dorman STAFF Oct 01 '14 at 06:34 PM

You should be getting a second email after the first one. The second email should say something like [GitHub] __ has invited you to join the Epic Games organization. If you didn't get that email (even in your Spam folder), then it means there's a problem we need to investigate further.

avatar image Catatonick Oct 01 '14 at 06:38 PM

I have only gotten the email that said I added or removed a github association. I haven't gotten anything from github or from epic concerning an invitation of any sort.

avatar image Jonathan Dorman STAFF Oct 01 '14 at 06:38 PM

Gotcha. I'll keep looking into it.

avatar image Catatonick Oct 01 '14 at 06:39 PM

Thank you.

avatar image Doug E ♦♦ STAFF Oct 01 '14 at 06:42 PM

Hey Catatonick-

There is something else I'd like you to check when you have the chance. Go to this link: https://github.com/EpicGames and check if you see a green button near the top right saying "Join"?

avatar image Catatonick Oct 01 '14 at 06:49 PM

alt text

eg.jpg (70.1 kB)
avatar image Diriel Oct 01 '14 at 06:46 PM

Although I don't have anything to add onto this, I'll just throw my name into the hat. I've also followed the Wiki setup steps and I'm not getting an invite either. I gave it a night (figuring it may be manual,) but I woke up today and still no dice. Just like Catatonick, I got the email from Epic confirming I had linked my account, but no email from GitHub. I get the same "This Organization has no public repositories." and there's no join button on the Epic Games GitHub page.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Oct 02 '14 at 12:37 PM by Doug E for the following reason:

The question is answered, right answer was accepted


2 answers: sort voted first

Hey guys-

There was a problem with connecting Unreal and GitHub accounts yesterday and we have tracked the cause and implemented a fix. If anyone experiences this issue in the future please start a new post and we will investigate.

Cheers

Doug Wilson

more ▼

answered Oct 02 '14 at 12:36 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Alright guys, thanks for the information. This issue has been escalated and we'll figure it out ASAP.

more ▼

answered Oct 01 '14 at 07:06 PM

avatar image Catatonick Oct 02 '14 at 02:13 AM

Fixed for me. Thanks.

avatar image Diriel Oct 02 '14 at 02:36 AM

Yep, same. I got my GitHub invite about an hour ago. Add another thanks from me. =P

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question