x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Rebuild Landscape Collision?

Hi there,

I'm working on a map with a landscape in it. There are high cliffs on the sides of the map (the map is sort of a valley). I needed to add a path so I flattened part of one of the cliffs.

The problem is that while the terrain looks like it's been flattened, the collision behaves as if the cliff is still there. is there away to rebuild the collision? I've exported the heightmap to a file and it looks as if the area is flattened. It's definitely the Landscape because if I disable the collision, I can fly through the opening (our game doesn't have gravity).

Any idea how I can fix this?

Thanks in advance.

Product Version: Not Selected
Tags:
more ▼

asked Oct 01 '14 at 05:37 PM in Using UE4

avatar image

vellocet
36 5 8 14

avatar image Adam Davis STAFF Oct 02 '14 at 05:07 PM

Hi vellocet,

Are you attempting to dynamically alter landscapes or is it not responding just in the editor? Does it still block after you build the level again?

avatar image vellocet Oct 02 '14 at 06:33 PM

It's not responding in the editor.

We created a landscape and then tried to alter it in the editor by flattening a section. It seems that, while visually, the terrain has been lowered, the collision has not been altered.

We copied everything into a new empty level, rebuilt everything and it seemed to fix the problem.

avatar image vellocet Oct 02 '14 at 06:40 PM

Also, we had tried the Build button to rebuild everything after flattening the section in the original level, but that didn't make any difference. After copying to a new empty level there was no collision from the landscape at first until we hit the build button, then it created the collision properly so we could make it through the new path.

avatar image Adam Davis STAFF Oct 02 '14 at 07:00 PM

That is very curious, which version of the editor are you currently using?

avatar image vellocet Oct 02 '14 at 09:59 PM

We're using 4.4.0

avatar image Adam Davis STAFF Oct 03 '14 at 05:19 PM

Hi vellocet,

I attempted to reproduce this on my end but could not. Does this only occur with the one heightmap?

avatar image vellocet Oct 03 '14 at 09:28 PM

It seems to be only with this heightmap.

We've been working on this map since 4.2 and haven't actually changed the topography until recently (4.4.0). It might just be a matter of working between the different versions.

Something else is that we have level streaming set up as well. It might have how something to do with working on multiple maps at the same time?

Although, when we copied everything into a new map and rebuilt everything, it worked properly (also when including it into the streaming level hiearchy).

avatar image Adam Davis STAFF Oct 06 '14 at 05:48 PM

Hi vellocet,

Do you have the landscape streaming multiple times or do you have individual sections in other levels?

avatar image vellocet Oct 06 '14 at 08:50 PM

Hi Adam,

We have separate landscapes for each of the streaming levels. We've tried editing the terrain again after copying the terrain into a new level and we're not seeing the problem anymore.

It might be very hard to pinpoint exactly what's causing it, but it looks like there are a couple of workarounds here that effectively fix the problem if we encounter it again.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi everyone,

I am happy to hear that you have found workarounds for your error. I will mark this as answered for now for tracking purposes. If this problem persists, please comment back with reproduction steps so I can attempt to recreate this on my end. Thank you!

more ▼

answered Oct 06 '14 at 09:13 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have had same issue and we alter the terrain quite a lot.

I have been able to fix it up till now but hte most recent case I am not able to fix it.

Past fixes

  1. resample the terrain

  2. delete and undelete the terrain component

more ▼

answered Oct 06 '14 at 01:18 AM

avatar image

IronTaxi
26 2 7 7

avatar image Adam Davis STAFF Oct 06 '14 at 05:49 PM

hi IronTaxi,

Have you been able to reproduce your error in a clean project with no additional content? Which version of the editor are you currently using? Additionally, are you using a heightmap as vellocet is or is it occurring with terrain tools and no heightmap? Thank you!

avatar image IronTaxi Oct 06 '14 at 06:39 PM

Hi Adam.

Found a very obvious work around that never occurred to me.

  • Duplicate the terrain and delete the old one. It seems the duplication process rebuilds (or effectively builds) the terrain collision and rectifies the issues.

to answer your question.

  1. Have not tried to produce on clean map as it's quite a random occurrence.

  2. Version is most current (sorry at work.. 4.3?

  3. Using Heightmap generated via world machine to generate base map then sculpting manually. (so a combo)

avatar image dimitrov Jun 05 '15 at 08:38 PM

Duplicating and deleting sounds like a good fix, however, I am not able to delete the landscape! I cannot edit it, I cannot move it, I cannot even delete it! (I can edit certain areas of the landscape, but not others) What can I do then...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Duplicate the landscape and delete the old one. And if you can't delete it:

Initially I was not able to delete the landscape (situation explained below). The workaround for this was to select the bad landscape and change a few of its properties. I tried quite a few of them, but I suspect that the important one is among these:

  • Rename the landscape actor

  • Remove material from the landscape

  • Collision Mip Level: 3

  • Collision: NoCollision

If these tree don't do the trick, try more of the settings. After changing the correct thing I was able to delete the landscape actor, and use the duplicated one from then on. (By the way, I noticed that the duplicate had miniature differences with the original, some tiny parts of the ground were shifted vertically or horizontally)

My situation: At some point I was not able to edit my landscape anymore (smooth, sculpt, move the actor, delete the actor). I was able to edit certain parts of the landscape that were far away from the area I was generally working on. The crash log mentioned something about "instanced foliage". I suspect this may have to do with the fact that I edited the collision shapes of one of the trees, minutes before having the crashing landscape problem. (not sure) So in effect every time I tried to edit my landscape, the whole UE4 editor crashed.

more ▼

answered Jun 05 '15 at 09:00 PM

avatar image

dimitrov
88 10 13 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question