x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to set initial color GPU particle parameter from blueprint?

My Setup at a glance: alt text

Not sure if this is a bug or not, but I cant set the initial color of the GPU particle from within a blueprint script. the colors change when i set the constant values in the components tab and when i set the constants in cascade, but if I set it by calling either the set color param or set vector param in blueprint (or both as seen in picture), absolutely no change occurs.

Am I doing anything wrong?

Product Version: Not Selected
Tags:
cascade gpu wtf.png (643.7 kB)
more ▼

asked Oct 02 '14 at 05:34 PM in Blueprint Scripting

avatar image

xdbxdbx
180 15 20 33

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello -

Using Initial Color with GPU Particles is still a known issue as of 4.11 Preview 6. I have included additional information to the bug report, UE-5168.

However there is a workaround:

  1. Set your Initial Color Module to a Constant 1,1,1

  2. Add a Scale Color / Life Module

  3. In the Color Scale Over Life set the Distribution to Vector Particle Parameter

  4. Name your parameter in Parameter Name

  5. Under Param Modes set the 0,1 and 2 all to DPM Direct

  6. If needed, set the Constant RGB values to 1,1,1 (will not affect outcome.)

You should now be able to control the Particle Parameter in your Blueprints. Remember you can also stack the same module more than once, so you can add another Scale Color / Life Module to control overall behavior over the particles life, if required.

I have attached a sample project below showing the setup mentioned above.

Thank You -

Eric Ketchum

Test Project 4.10.4

more ▼

answered Feb 23 '16 at 09:22 PM

avatar image

Lovecraft_K ♦♦ STAFF
37k 701 249 727

avatar image toksn Feb 23 '16 at 11:17 PM

thank you very much. tried to get my particle effects colored for 3days with initialcolor but i can stay sane now thanks to you. it worked

avatar image phisigma Jul 18 '18 at 11:26 AM

Just a small supplement: Don’t use “Initial Color” at all, instead use “Color over life” with parameters for initialization (as described above). And add “Scale Color / Life” after that module to add some non-parameter information if you want (especially distribution curve).

Furthermore, this bug will probably not be fixed (status “won’t fix”, see UE-5168), so you have to use this workaround.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey xdbxdbx -

I have entered this bug in with our engineers for further investigation and I will let you know when we have a solution. The report is listed as UE-5168.

Thank You

Eric Ketchum

more ▼

answered Nov 07 '14 at 03:16 PM

avatar image

Lovecraft_K ♦♦ STAFF
37k 701 249 727

avatar image kamrann Jun 01 '15 at 05:41 PM

This is pretty old and appears to still be unresolved (as of 4.7 at least). I just had 2 hours of confusion before finding this report. Any news?

avatar image SVR33 Jun 01 '15 at 10:03 PM

Funny, I'm having the same issue right now, too. I'm using a Ribbon emitter and have it set up exactly the same as the OP. It's drawn as black regardless of what color I input.

avatar image straycodemonkey Nov 04 '15 at 01:49 PM

Same here to on 4.9.2. I'm trying to use a Distribution Vector Particle Parameter but it's ignoring whatever the parameter is set to.

avatar image Lovecraft_K ♦♦ STAFF Nov 05 '15 at 03:15 PM

Hello Everybody -

When using the Particle Parameter that you will want to set directly from Blueprints, please make sure that your Particle Parameter Mode is set to DIRECT.

ParamMode

Thank You

Eric Ketchum

parammode.jpg (46.8 kB)
avatar image IvanRodriguez Feb 10 '16 at 12:59 PM

That isn't working neither on 4.10

avatar image Lovecraft_K ♦♦ STAFF Feb 10 '16 at 04:46 PM

Hello Ivan -

Are you setting the ParamModes to DPM Direct and making sure that you are setting the value in your Blueprint?

Internally this functionality is working correctly.

Eric Ketchum

avatar image toksn Feb 22 '16 at 10:45 PM

for me it is not working as well.

tried to call GetVectorParameter or GetAnyVectorParameter with my parametername but i get false as a result which leads me to think the parameter is not there at all.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question