x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Corrupt project

My blueprints kept breaking and now the project crashes on loading the project.

DxDiag Log

https://drive.google.com/file/d/0B-fF6EOFJcFFVnpQanpBLUxzZzQ/view?usp=sharing

Product Version: Not Selected
Tags:
dxdiag.txt (46.2 kB)
log.txt (24.2 kB)
more ▼

asked Oct 03 '14 at 02:47 AM in Bug Reports

avatar image

Vesros
17 1 5 9

avatar image Ben Halliday STAFF Oct 03 '14 at 06:01 PM

Thank you for your report. I will begin investigation into this issue as soon as possible. If I am unable to reproduce the problem, or I need more information, I or another staff member will follow up with some additional questions for you. Otherwise, I will post an ‘Answer’ once I have logged the issue in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide:

https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Vesros,

When you say your Blueprints were breaking, what do you mean exactly? Were the nodes disconnecting? Which version of the engine are you using?

It's possible this is related to a cyclical dependencies issue that has been resolved in 4.5. If you haven't already, make a copy of your project in 4.5 Preview and see if it will open.

more ▼

answered Oct 06 '14 at 10:10 PM

avatar image Vesros Oct 07 '14 at 01:49 PM

I was on 4.4.3 and a binary build. in one of the blueprints and the suspected offender the nodes were disconnecting, i tried getting an image of the node disconnect but was unable to. A specific node would be disconnected from the chain but the next execution pin in the chain would still be white like it was plugged in.

I was calling a function where i send the pawn through and immediately cast the pawn to MyCharacter and that is the node that would break. I Changed the set up so i wouldn't have to send the pawn through there and there doesn't seem to be any issues anymore and everything else is exactly the same.

Have not tried with 4.5 and assume i can't using the launcher for updates?

avatar image Ben Halliday STAFF Oct 07 '14 at 03:23 PM

You should be able to get the 4.5 Preview through the Launcher if you have an active subscription. Go to the Library tab in the Launcher, and click the "Engines+" at the top. In the new Engine slot that appears, choose Preview. That should get you the 4.5 Preview. Then Launch in Preview and select your project to open, and it will give you an option to Open a Copy.

avatar image Vesros Oct 07 '14 at 10:55 PM

the project launches perfectly fine on 4.5 and the disconnect issue previously described looks like it should.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question