x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.5 prev] [UMG] Anim in childwidget / cant save

Hi there!

im having some troubles with animating in UMG. My idea is to create a widget blueprint (which is essentially an animated button) and use it in other widget blueprints.

The problem is that UMG does not seem to like animated child-widgets. Every time i try to save the parent widget i get the following message:


Can't save ../../../../../Projects/Test/UnrealProject/MyProject/Content/NewFolder/widgetParent.uasset: Graph is linked to private object(s) in an external package. External Object(s): NewAnimation_11_INST

Try to find the chain of references to that object (may take some time)?


Steps to reproduce:

  • Create a Project

  • Add a widget blueprint (child) In this widget add a new animation with two keyframes.

  • Add another widget blueprint (parent) In this widget, add the child widget (from palette, user created)

If you try to save this widget you get the aforementioned message. Compiling this widget works fine.

Output Log:

Cmd: OBJ SAVEPACKAGE PACKAGE="/Game/NewFolder/widgetParent" FILE="../../../../../Projects/Test/UnrealProject/MyProject/Content/NewFolder/widgetParent.uasset" SILENT=true LogSavePackage:Warning: Referencers of WidgetAnimation /Game/NewFolder/widgetWithAnim.widgetWithAnim_C:NewAnimation_11_INST: LogSavePackage:Warning: WidgetBlueprintGeneratedClass /Game/NewFolder/widgetWithAnim.widgetWithAnim_C (1 refs) LogSavePackage:Warning: 0) None LogSavePackage:Warning: widgetWithAnim_C /Game/NewFolder/widgetParent.widgetParent:WidgetTree_31.widgetWithAnim_C_79 (2 refs) LogSavePackage:Warning: 0) None LogSavePackage:Warning: widgetWithAnim_C /Game/NewFolder/widgetParent.widgetParent_C:WidgetTree_407.widgetWithAnim_C_79 (2 refs) LogSavePackage:Warning: 0) None EditorErrors: New page: Save Output EditorErrors:Warning: Warning Can't save ../../../../../Projects/Test/UnrealProject/MyProject/Content/NewFolder/widgetParent.uasset: Graph is linked to external private object WidgetAnimation /Game/NewFolder/widgetWithAnim.widgetWithAnim_C:NewAnimation_11_INST (unknown property ref)

  • Sebastian

Product Version: Not Selected
Tags:
more ▼

asked Oct 04 '14 at 03:05 PM in Bug Reports

avatar image

byte3
123 5 7 19

avatar image pinosh Oct 05 '14 at 11:53 AM

Having the same issues. Even without touching the animation timeline. The only solution i found so far is to completely delete the child widget (delete the child reference and blueprint), save and recreate it. So annoying.

Edit: Actually in my case, i think, it is happening because i converted my project from 4.4 to 4.5. in 4.4 all widgets had a default animation. I didn't need any animations, so didn't touch the animation timelines, yet i had this error when trying to save. I overcame it by adding a new animation, deleting the default animation (the default animation can't be deleted unless another animation exists), then delete the new animation too. It saved correctly without any animations in the child widget. But i'm afraid when an animation is needed, there is no workaround.

avatar image Adam Davis STAFF Oct 07 '14 at 07:00 PM

Hi byte3,

Can I see a screenshot of the widgets that are causing this error? I have thus far been unable to reproduce this on my end. Thank you!

avatar image pinosh Oct 08 '14 at 09:55 AM

Hi Adam,

Here are some screens showing when it's happening. Capture3.png show Test1_BP widget, very simple with just one button and one blank animation added to it alt text

Capture2.png shows Main_BP widget, containing Test1_BP widget in it. alt text

This shows the error when trying to save Main_BP or the entire project alt text

Edit: UE 4.5 Preview

capture3.png (107.6 kB)
capture2.png (113.9 kB)
capture.png (130.2 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello byte3,

I was able to reproduce the issue on my end. I have submitted a bug report to the development team. TTP# 349082

more ▼

answered Oct 08 '14 at 08:25 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Stefan Lundmark May 24 '15 at 08:17 PM

Have this been resolved? I'm running into the same problem in 4.7.5. I can save, but upon closing the Widget and reopening, the changes haven't been saved. Additionally, if I press "Compile" the changes are immediatly reset.

I have the same setup as the previous posters.

Edit: This was unrelated to the issue described above, or caused by the fact that I had the Auto Key enabled and the current time too far away to notice that the changes happened elsewhere.

avatar image Rudy Q ♦♦ STAFF May 26 '15 at 01:02 PM

Hello Stefan Lundmark,

I am happy to hear that your issue has been resolved. If you issue returns be sure to make a new thread on the Answerhub.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question