x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4.5 preview crashes on startup (OSX Yosemite GM candidate)

I tried out the preview of UE4.5 to make sure the animation bug that affected 4.4 in Yosemite has been resolved in 4.5. However, UE4.5 does not appear to start on Yosemite GM candidate and just crashes. I compiled using Xcode 6.0.1.

Log as below:

 [2014.10.05-01.02.54:528][  0]LogAIModule: Creating AISystem for world NewWorld
 [2014.10.05-01.02.54:591][  0]LogDerivedDataCache: Saved boot cache 0.06s 47MB ../../../Engine/DerivedDataCache/Boot.ddc.
 [2014.10.05-01.02.54:606][  0]LogInit: Texture streaming: Enabled
 [2014.10.05-01.02.54:679][  0]LogMac: === Critical error: ===
 SIGABRT: abort() called
 
 [2014.10.05-01.02.54:680][  0]LogMac: abort Address = 0x8e9e1b73 (filename not found) [in libsystem_c.dylib]
 __cxa_bad_cast Address = 0x8b578a21 (filename not found) [in libc++abi.dylib]
 _ZL26default_unexpected_handlerv Address = 0x8b5a09d1 (filename not found) [in libc++abi.dylib]
 _ZL15_objc_terminatev Address = 0x898bd6c6 (filename not found) [in libobjc.A.dylib]
 _ZSt11__terminatePFvvE Address = 0x8b59e0a1 (filename not found) [in libc++abi.dylib]
 __cxa_rethrow Address = 0x8b59dd48 (filename not found) [in libc++abi.dylib]
 objc_exception_rethrow Address = 0x898bd4e4 (filename not found) [in libobjc.A.dylib]
 -[NSConcreteTask launchWithDictionary:] Address = 0x970286a4 (filename not found) [in Foundation]
 _ZN19FMacPlatformProcess10CreateProcEPKwS1_bbbPjiS1_Pv Address = 0xaee5351  (filename not found) [in UE4Editor-Core.dylib]
 _ZN19FDesktopPlatformMac12OpenLauncherEb7FString Address = 0x11fc80c4 (filename not found) [in UE4Editor-DesktopPlatform.dylib]
 _ZN13UEditorEngine10InitEditorEP11IEngineLoop Address = 0x1058615e (filename not found) [in UE4Editor-UnrealEd.dylib]
 _ZN13UEditorEngine4InitEP11IEngineLoop Address = 0x10589ffc (filename not found) [in UE4Editor-UnrealEd.dylib]
 _ZN15UUnrealEdEngine4InitEP11IEngineLoop Address = 0x10a80a5c (filename not found) [in UE4Editor-UnrealEd.dylib]
 _ZN11FEngineLoop4InitEv Address = 0xad66d76  (filename not found) [in UE4Editor]
 _Z10EditorInitR11IEngineLoop Address = 0x10a7f739 (filename not found) [in UE4Editor-UnrealEd.dylib]
 _Z11GuardedMainPKw Address = 0xad6b355  (filename not found) [in UE4Editor]
 -[UE4AppDelegate runGameThread:] Address = 0xad735e5  (filename not found) [in UE4Editor]
 -[FCocoaGameThread main] Address = 0xae8abf4  (filename not found) [in UE4Editor-Core.dylib]
 __NSThread__main__ Address = 0x96eeab7a (filename not found) [in Foundation]
 _pthread_body Address = 0x97c192fc (filename not found) [in libsystem_pthread.dylib]
 _pthread_body Address = 0x97c19279 (filename not found) [in libsystem_pthread.dylib]
 thread_start Address = 0x97c174b1 (filename not found) [in libsystem_pthread.dylib]

Product Version: Not Selected
Tags:
more ▼

asked Oct 05 '14 at 01:18 AM in Bug Reports

avatar image

Raziel
58 2 5 12

avatar image Raziel Oct 05 '14 at 02:02 AM

Just an update, it appears to launch successfully IF you run the editor straight out of Xcode, but it still crashes if you just run the editor directly from finder after compiling it. Once you try to open a project, it attempts to restart the editor, which again, causes it to crash however.

Not sure what the difference is between launching in and out of Xcode, but it appears to make a difference in this case. FYI, I've tried development and debug builds of 4.5, both seem to have this issue for me.

avatar image Raziel Oct 05 '14 at 04:41 AM

Another update, it appears to be something to do with launching the Unreal Engine Launcher app. I commented out the code that starts the launcher and now it works.

In previous engine versions, you could just rename the launcher to stop the thing from starting up, now if you attempt to start the editor without the launcher being on your system, it crashes on startup.

This is the issue I guess.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thanks for the update! I'll look into fixing this for the final 4.5 release.

The bad news, though, is that the 10.10 GM candidate doesn't fix the Nvidia animation issue. We do have a workaround for that, but it slows things down a bit, so we hope we won't have to apply it and should Apple not fix this on time, find some better workaround... Apple knows about this issue and is working on a fix, but it's uncertain at this point if the fix will be ready for final 10.10 version :(

more ▼

answered Oct 06 '14 at 01:01 PM

avatar image

ZeroEightSix STAFF
2.1k 18 6 36

avatar image Raziel Oct 16 '14 at 07:20 AM

Unfortunately this issue has not been fixed in 4.5 final, so if you don't have the launcher on your system and you build from source, the editor crashes on startup on Mac.

avatar image marksatt-pitbull STAFF Oct 17 '14 at 01:55 PM

Good news, Raziel. We have a fix for the animation issue which will ship in a 4.5 QFE. Not sure about the crash though - I've got a similar issue to look at so I'll get back to you if I fix this.

avatar image Raziel Oct 18 '14 at 01:01 PM

That is extremely good news!

avatar image ZeroEightSix STAFF Oct 20 '14 at 01:57 PM

You can download the patch here: https://s3.amazonaws.com/unrealengine/qfe/QFE-FromCL-2326468-Shelve-2331902_Mac.zip (92 MB). Just unpack the zip file and run the patch installer. It will also be included in UE 4.5.1.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question