x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.5-Preview Graphics Glitches

Branch: Binary & Source/4.5

Build Version: 4.5.0-2316912+++depot+UE4-Releases+4.5

Detailed description of the issue: When you open/convert a 4.4 project to 4.5 (not sure if this is the cause), massive visual glitches can be seen. For example the landscape project has some blueprints that cause massive lags and vertex issues, which you'd normally only see when you are running out of video memory. These also happen when building from source.

Screenshots: 4.5=http://i.imgur.com/48GJ4Pc.jpg 4.4=http://i.imgur.com/hAQlnLP.jpg

Repo Steps: 100% occurs in all 4.4 projects converted to 4.5, did not happen a while ago (repo snapshot on 24.09. at 14:05 doesn't show this behaviour)

  • Open 4.4 project in 4.5 (convert it)

  • Have massive FPS drops to near unuseability due to broken graphics.

System Specs:

  • CPU: AMD FX-6100

  • RAM: 16.0GB DC DDR3 1333Mhz (9-9-9-24)

  • GPU1: NVIDIA GeForce GTX 550 Ti

  • GPU2: ATI Radeon HD5770 (CuCore)

  • OS: Windows 8.1 Pro 64-bit

Attachments: None (happens on assets in the marketplace)

Product Version: Not Selected
Tags:
more ▼

asked Oct 05 '14 at 01:24 AM in Bug Reports

avatar image

Xaymar
188 19 28 113

avatar image Xaymar Oct 05 '14 at 01:26 AM

Something not relevant to this issue, but maybe related: Shader compile time is nearly 20 times as long as it was before. For a simple 1 node material that takes 20 seconds to compile on 4.4, 4.5 takes more than 6 minutes.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Xaymar,

Thank you for catching and reporting this. :)

There is a change with that particular material coming in 4.5 that we've updated for the M_Bird material. There are some parameters that are being fed into the material instance that have been removed.

Once 4.5 is released and if you download the 4.5 version you will not see this issue. If you convert you'll need to go into the Material Instance and check the "Static Switch Parameter > Use Particle Direction > Check the box"

alt text

This will resolve the issue that was being created with the Bird Particle systems.

Thank you!

Tim

markastrue.png (8.7 kB)
more ▼

answered Oct 06 '14 at 07:56 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 878

avatar image Xaymar Oct 06 '14 at 09:10 PM

That fixed the broken vertices/particles. However, fps is still terrible for an unknown reason. 45 fps in 4.4, 9 fps in 4.5-Preview. Not sure what is causing this big difference.

avatar image Tim Hobson ♦♦ STAFF Oct 06 '14 at 09:18 PM

Let's post that as a separate issue to be looked into as these two issue are not related. Then we can start looking into that as well and see what's going on since this issue with the graphical glitch is resolved.

Thank you!

Tim

avatar image Tim Hobson ♦♦ STAFF Oct 06 '14 at 09:38 PM

Thank you! I've assigned myself to it. I'll take a look into that soon.

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question