x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.4.3. Particles in level, but how did they get there?

So I have been scaling my map sizes up to 10-20K tiles lately and some weird visual effects are taking place that I can't explain.

The zoomed in version looks like blinking Christmas lights. Under the effect you can see my text is shaded red, and to the right it is white as normal. alt text

As you can see here, the effect takes on random colors(I have seen Green as well) and primarily exists off to the side of the view. If I scroll around it flashes brighter with more movement. It does not exist on the central portion of the map and seems to spawn on the outskirts of the starting position.
alt text

I found a "ParticleEventManager7" (it often ends in different numbers besides 7) in my Scene Outliner but I have no idea how it got there and it fails to reference anywhere.

I am playing in the Game Preview Standalone. When I exit, the "ParticleEventManager7" dissapears from the Scene Outliner.

This effect does not always happen. I have not added any particles to my project or even open the particle tools.

Anyone have a clue?

Product Version: Not Selected
Tags:
more ▼

asked Oct 08 '14 at 08:36 AM in Bug Reports

avatar image

Zeustiak
1.8k 130 68 110

avatar image Jacky Oct 08 '14 at 02:15 PM

I've seen reports of this kind of behaviour on foliage before so you may want to search for those posts(forum and answerhub) to see what was causing them.

avatar image Adam Davis STAFF Oct 08 '14 at 03:02 PM

Hi Zeustiak,

In your blueprint, do you have any instances in which you add a particle system? Additionally, does this start to only with large amounts of instanced meshes or does it occur any time you start up, even with smaller amounts of data being rendered?

avatar image Zeustiak Oct 09 '14 at 07:31 AM

I haven't touched particles in any shape or form.

I have only seen this on maps with more than 7000 tiles. Edit: Or I suppose 21000 tiles since my world wrap duplicates the maps.... My forest solution is pretty bad as well as it uses 37 trees per forest tile, so that could be hundreds of thousands of tree instances... :p

Pretty much as soon as I started producing larger maps, the weird effects showed up. Didn't change anything visually in that time. Just altered map generation logic.

avatar image Pierdek Oct 09 '14 at 07:34 AM

I believe you got similiar issue to: https://answers.unrealengine.com/questions/62259/weird-random-glow.html

and this config entry is "solution" for these glows.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi Zeustiak

try set

 [Startup]
 r.Cache.LightingCacheDimension = 128

In Engine\Config\ConsoleVariables.ini

Hope it will helps you :)

Regards

Pierdek

more ▼

answered Oct 08 '14 at 04:54 PM

avatar image

Pierdek
2.6k 73 49 131

avatar image Zeustiak Oct 09 '14 at 10:41 AM

I feel like I used to have the ability to turn people's comments into answers.... Your solution seems to be holding up. I will reopen this thread if it comes back, thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Pierdek's solution seems to work:

try set

[Startup] r.Cache.LightingCacheDimension = 128

In Engine\Config\ConsoleVariables.ini

Would still like to know what the core issue is it is known.

more ▼

answered Oct 09 '14 at 10:43 AM

avatar image

Zeustiak
1.8k 130 68 110

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question