x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Cant change light map coordinate index in mesh editor

I have a mesh that have 2 uv channels, I want to bake light to it, but i got this problem about uv overlapping... then I want to change mi "light map coordinate index" to 1 instead of 0, and it doesnt let me do it.... and because of this I cant make a build of my scene for testing, any help is really helpfull!!!

Thanks in advance!

Damian

Product Version: Not Selected
Tags:
more ▼

asked Oct 09 '14 at 03:42 PM in Using UE4

avatar image

Kitekat
56 4 6 5

avatar image ltnfire May 06 '16 at 09:15 AM

I've got the same issue. I just want to add that in my case the broken mesh was generated from BSP volume. Example models from starter content works fine.

avatar image StevieZak Oct 21 '16 at 07:20 PM

Is this still a bug? Sorry, totaly newbie here. Doing an Unreal Engine tutorial from Digital Tutors and literally the first thing you do in the tutorial is this.... and yet the Light Map Coordinates box is no where to be found, yet my imported fbx asset lists it containing 3 channels.

avatar image StevieZak Oct 21 '16 at 07:24 PM

Ignore above. I found it. Very difficult to see advanced options (just a small arrow).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Damian,

This does seem odd. I've not had this problem before.

Can you post a screen shot of your mesh in the mesh viewer with the dropdown of the UV Channels. There should be a channel 0 and a channel 1.

If there is no option for Channel 1 this would explain why it's not allowing you to change the LM index to channel 1.

What version of the engine are you currently using as well?

Thank you!

Tim

more ▼

answered Oct 09 '14 at 06:37 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Kitekat Oct 09 '14 at 07:06 PM

Sure, here is the screen, whenever i try to write "1" it goes back to 0... alt text

index error.jpg (123.2 kB)
avatar image Kitekat Oct 09 '14 at 07:07 PM

Im using 4.4.3 thanks for the response, Tim

avatar image Tim Hobson ♦♦ STAFF Oct 09 '14 at 07:55 PM

Are you able to reproduce this with any other meshes or just this one?

If you're able to re-create with a simple test asset you would mind providing a simple asst that does this?

Is the case the same if you save the asset and re-open the editor as well?

Thank you!

Tim

avatar image Kitekat Oct 09 '14 at 08:19 PM

The problem is in this mesh only, and yes, I tried to save it in the mesh viewer and open it again, also restarting unreal too, and the problem persist. I got it from a pack, how can I send it to you?

avatar image Tim Hobson ♦♦ STAFF Oct 09 '14 at 08:23 PM

I just sent you an email with instructions.

Tim

avatar image Tim Hobson ♦♦ STAFF Oct 09 '14 at 08:54 PM

Thanks for sending the asset. I was able to import it although I didn't get the same issue. When importing I used the default settings and it recognized the lightmap channel and assigned it as such.

So I'm not able to reproduce this on my end, but some things you can try and see what's going on here.

Can you try re-importing the mesh and see if this will fix the issue (if you've not already tried this)?

(This feature will change in 4.5 but for the moment is still there) Go into the mesh viewer and to the menu bar > select Window > Generate New UV > a new tab will pop up under the details panel.

In the new tab change the Creation Mode to "Layout Using 0 Channel" with the "UV channel to save results to:" set to UV Channel 1 then hit apply. See if this will allow you to now select the channel 1 index.

If that doesn't work, can you delete any copies of this mesh from your scene then delete it from the content browser to remove it from the project. Save all and then import the mesh again and see if we can get it to see the lightmap coordinate index.

Beyond this, I would see if this one object will load into a blank project with the correct UVs setup with the UV index for lightmap set to 1.

Let me know if anything here helps.

Thank you!

Tim

avatar image Kitekat Oct 09 '14 at 09:01 PM

Well, yeah, I tried those options, but I'll give it another shot in the other computer. If the problem persist I think I'll just replace the mesh with another. But thanks so much for the response, much appreciated.

Damian

avatar image Tim Hobson ♦♦ STAFF Oct 09 '14 at 09:06 PM

I've sent you another email with the re-exported asset to try. It may be worth a shot. I'd be curious if this happens again to keep looking into it for a possible reproduction of steps. Bugs like this are a little harder to track down unfortunately.

Thanks you,

Tim

avatar image Kitekat Oct 09 '14 at 09:18 PM

That fix totally worked, thanks so much. If this happens again, I will tell. Cheers! Damian

avatar image Tim Hobson ♦♦ STAFF Oct 09 '14 at 09:25 PM

Great! Maybe it just need to be re-exported from Max. Hmm. If it happens again definitely reach out here and let me know. :)

Tim

avatar image Sgt.Wulf May 04 '16 at 06:57 AM

I just encounctered the same issue. Cannot change light map co-ordinate index. My engine version is 4.11.0.

Tried restarting engine. Re-exported from max and maya. Still no luck

avatar image Tim Hobson ♦♦ STAFF May 04 '16 at 03:45 PM

@Sgt.Wulf

You will need to have a Lightmap already setup in order to set the lightmap coordinate index to 1. If you only have a single UV Channel you cannot set it to 1 because it does not exist.

If this does not solve your issue please post a new question here in the bug reports along with detailed steps to recreate the issue so it can be fully investigated on our end.

Thank you!

Tim

avatar image Sgt.Wulf May 04 '16 at 06:39 PM

@tim

I have my lightmap channel setup and it's showing inside the editor too. Yes I will post new thread tomorrow with detail steps.

avatar image Tim Hobson ♦♦ STAFF May 04 '16 at 07:19 PM

thank you! In your post just put an @Tim Hobson and I'll be sure to assign to myself and we can take it from there. :)

avatar image Dibilman Jun 02 '16 at 10:49 AM

@Tim Hobson I have same problem that had Damian, version 4.12

avatar image Tim Hobson ♦♦ STAFF Jun 02 '16 at 11:55 AM

@Dibilman

The steps listed above in my original posts answer should work. If it's an issue please post a new question with all the details and steps to reproduce the issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Guys,

I'm now fighting with this problem still and have done some research. I can't set index 1 or 2 although I can clearly see all of my 3 UVset in the mesh editor. This is happening on a tree model with 4 Lods and 3 UVset. When I imported simple plane with a material and 3 UVsets I was able to set any index. Then I had a look into Epic's Kite demo pack and viola, there's many buggy assets:

  • model SM_Boulder05a has two UVsets, but you can set only index 0

  • model HillTree_02 or River_Birch_Hero has 8 UVsets, but you can set only index 0 and 1

Also in Epic's BlueprintOffice level there's:

  • model SM_Cog_Underground_PipeCap_Top has 5 UVsets, but you can again set only index 0 and 1 .. and I could go on and on..

Is there a rule that UE can use only index 0 or 1 for light map coordinate for assets which have more than two UVsets? BTW. it's happening in 4.12 and 4.11, I haven't test older ones.

Cheers,

Miro

more ▼

answered Jun 04 '16 at 09:51 AM

avatar image

Miroslav Horvath
1 1

avatar image Tim Hobson ♦♦ STAFF Jun 07 '16 at 09:05 PM

I wasn't able to see this initially but when looking at SM_Boulder05a I was able to see what was going on fairly easily.

Each LOD needs to have the lightmap generated for it. You just need to go enable Generate Lightmap UV and hit apply for each LOD. That way the LODs can have the lightmap set for them as well. Without this, the LOD wouldn't have a lightmap other than being able to use UV 0 since that's the only one available to them all.

This isn't a bug though, just maybe not as intuitive a process to know why your UV wasn't being set.

avatar image Todd.Vance Oct 13 '17 at 02:13 PM

The issue appears to be in 17.1.2 as well. I merged several static mesh actors together with the Merge Actors tool, and of course, it created overlapping lightmap UVs. So, I generated a new lightmap in index 2, which I can view easily in the static mesh editor, but when I set the lightmap index to 2, it immediately reverts to 1 again, the auto-generated one from the merge tool that overlaps. I'd say there are two bugs here--in the merge tool and in the static mesh editor.

Edit: I trhought I had a workaround: after generating the lightmap in index 2, set 2 as the source and 1 as the destination and regenerate the lightmap. But when I quit UE4 and restart, index 2 evaporates and index 1 is replaced with the old, overlapping UV.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question