x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Collision response don`t change on mesh component.

Hello i been working on this issue for a week now. And for what ever resson when i try to turn off collision on a Destructable i have in a derived AActor::. It don`t change and it keeps coliding with everything.

I was thinking that it may be due to the fact that its just a chunk of the the destructable mesh. So i whent hunting for the solution in the PhysX/APEX API but was not able to find anything for turning of collision. Turning off collision for the entier mesh whould work fine, but i stile need collision on one a other component (USphereComponent::)

Here what i think should work.

 DestructibleMesh->SetCollisionObjectType(ECollisionChannel::ECC_Destructible);
 DestructibleMesh->SetCollisionResponseToAllChannels(ECollisionResponse::ECR_Overlap);
 DestructibleMesh->SetCollisionEnabled(ECollisionEnabled::NoCollision);

Thanks for any help.

WCode

Product Version: Not Selected
Tags:
more ▼

asked Oct 09 '14 at 11:35 PM in C++ Programming

avatar image

WCode
508 43 44 73

avatar image WCode Oct 12 '14 at 08:40 PM

ANyone know way the component won`t change collision response?

avatar image XLCRHItmanEQ Oct 13 '14 at 08:45 PM

I would like to know about this too, I've noticed there is no answer

avatar image [Epic]Ori Cohen STAFF Oct 14 '14 at 12:29 PM

Changing collision response on a destructible at runtime is not really supported at the moment as it's more complex than the simple rigid body case. We're planning to add this eventually.

For now you should be able to set the collision response in the editor. The collision response will always pick the least blocking response. That is, if A and B collide and A is marked as ignoring B, it will not matter what B has selected.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

The solution we ended up using was a work around realy, and its done with Ridgid Bodys instead of destructable mesh. It gives us the controll we need and it looks almost the same.

I like to add that the sugestion from Rama did work as long as it was changed before the mesh ever got hit/ (partaly destroyd). And in this case it was not exacely what we needed but thanks again Rama and Ori Cohen.

Best Regards

WCode

more ▼

answered Oct 21 '14 at 09:08 PM

avatar image

WCode
508 43 44 73

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

A Solution

If you want to have actors not react to another actor there often needs to be a two way decision to not collide

so you need to specifically say

Destructible (my type is SpecialDestructible)

  • I ignore pawns

Character (my type is ECC_Pawn)

  • I ignore SpecialDestructibles

If you do BOTH ways it should work!

Go to

ProjectSettings->Collision and add a SpecialDestructible Object type

then check your DefaultEngine config file to see what exact channel it was set to

then in code you can set the object type to be your custom channel

I've done this sort of thing many times over and can verify it often does need to be a two way decision to ignore or overlap or block :)

Rama

ps

DefaultEngine Config

will look something like this

 Profiles=(Name="PhysicsActor",CollisionEnabled=QueryAndPhysics,ObjectTypeName="PhysicsBody",CustomResponses=,HelpMessage="Simulating actors",bCanModify=False)


but you can just use Project Settings->Collision to set it up

you might also find the change in Saved/Config/Windows/Engine.ini

more ▼

answered Oct 14 '14 at 07:56 AM

avatar image

Rama
10.6k 446 345 1088

avatar image WCode Oct 14 '14 at 10:08 AM

Awsome i will try that soon as am off work. Thanks Rama :) Edit: Sorry for the delay am having some small problems updating my project to 4.5. I will be back soon when i have tested your sugestion. Thanks again.

avatar image Rama Oct 15 '14 at 03:13 AM

whatever fixes you figure out regarding 4.5 make sure to post in my 4.5 Transitions guide in the C++ section! (once I make it)

avatar image Rama Oct 15 '14 at 03:35 AM

4.5 Transition Guide

please share what you're learning here so we all figure it out faster together!

https://forums.unrealengine.com/showthread.php?49449-4-5-Transition-Guide-Community-Contributions-Welcome!&p=163791#post163791

avatar image WCode Oct 15 '14 at 01:05 PM

Defenatly :)

avatar image WCode Oct 17 '14 at 08:26 PM

Hello so i got it half working now. I Made a new Object Type and it defenetly works. I am stile having isssues i think UBoxComponent and UCapsuleComponent changed in 4.5.

Since now if i have a box / capsule over the destructable thats set to only overlap. The mesh under never recives the Hit event so am guessing i need to mess more with the Costume Object.

PS: Am keeping this unresolved until i have it working.

Cheers!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question