x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ERROR : UBT error : Failed to produce item: UE4Editor-OculusRift.dll

Hi,

I'm getting compile error

ERROR : UBT error : Failed to produce item: C:\Development\UnrealEngine\Engine\Plugins\OculusRift\Binaries\Win64\UE4Editor-OculusRift.dll

when trying to compile the latest 4.5 branch (followed the little description in github for 4.5)

Already redownloaded the branch an the deps. But still the same error.

Thanks Ralph

Product Version: Not Selected
Tags:
more ▼

asked Oct 12 '14 at 10:52 AM in Installation & Setup

avatar image

RalphJaeger
6 2 4 4

avatar image Doug E ♦♦ STAFF Oct 13 '14 at 05:38 PM

Hey RalphJaeger-

Were you using the 4.5 preview (launcher or source) or the latest preview release from GitHub?

avatar image RalphJaeger Oct 13 '14 at 08:31 PM

Source from GitHub 4.5 branch

avatar image Doug E ♦♦ STAFF Oct 14 '14 at 05:19 PM

I tried building the editor in the Development Editor solution configuration with Win64 set as the solution platform and did not see the same error. Which solution configuration and solution platform are you building in?

avatar image Denis Oct 21 '14 at 10:56 PM

I've got the same problem :(

avatar image Shadowriver Oct 21 '14 at 11:06 PM

"ERROR : UBT error : Failed to produce item:"

It's UBT error not compiler error , it means compilation or linking of that dll failed cause of other error which should be also listed in log, try to find it and paste it here, otherwise nobody will know whats wrong, it's too general

avatar image Denis Oct 22 '14 at 12:37 AM

I was getting this error

Error 1 error LNK1181: cannot open input file 'libovr64.lib' and this created an error build oculus rift files. I downloaded the zip version of the engine and put the required files again and I forced to install the emscripten v1.22 (found on https://answers.unrealengine.com/questions/82422/emscripten-sdk-found-but-of-unexpected-version-ple.html) and it worked !

avatar image Shadowriver Oct 22 '14 at 01:03 AM

But he didn't said what his error is yet ;p

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi RalphJaeger,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Oct 27 '14 at 07:28 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question