x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Simple console command Server connect crashes Client?

Hello!

I'm fiddling around with connecting to servers via UI, and for simplicities sake I use only a button wich calls the console command open 127.0.0.1 on the Client, however when I click it, the client crashes and I get this:

Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.5\Engine\Source\Editor\UnrealEd\Private\Editor.cpp] [Line: 6846] World /Game/Maps/UEDPIE_3_BaseGame.BaseGame not cleaned up by garbage collection! (Object is not currently rooted)

KERNELBASE.dll!UnknownFunction (0x000007fefd5d940d) + 0 bytes [UnknownFile:0] UE4Editor-Core.dll!UnknownFunction (0x000007feecbe73f4) + 0 bytes [UnknownFile:0] UE4Editor-Core.dll!UnknownFunction (0x000007feeca799ef) + 0 bytes [UnknownFile:0] UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fee87a2404) + 0 bytes [UnknownFile:0] UE4Editor-Engine.dll!UnknownFunction (0x000007feea9acdba) + 0 bytes [UnknownFile:0] UE4Editor-Engine.dll!UnknownFunction (0x000007feea9c4118) + 0 bytes [UnknownFile:0] UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fee879e4f8) + 0 bytes [UnknownFile:0] UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fee8bff916) + 0 bytes [UnknownFile:0] UE4Editor.exe!FEngineLoop::Tick() (0x000000013fdfa8f4) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launchengineloop.cpp:2129] UE4Editor.exe!GuardedMain() (0x000000013fdef9df) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launch.cpp:133] UE4Editor.exe!GuardedMainWrapper() (0x000000013fdefa4a) + 5 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:125] UE4Editor.exe!WinMain() (0x000000013fdfbf19) + 17 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:201] UE4Editor.exe!__tmainCRTStartup() (0x000000013fdfcdc9) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618] kernel32.dll!UnknownFunction (0x00000000775b59ed) + 0 bytes [UnknownFile:0] ntdll.dll!UnknownFunction (0x00000000776ec541) + 0 bytes [UnknownFile:0] ntdll.dll!UnknownFunction (0x00000000776ec541) + 0 bytes [UnknownFile:0]

The only thing I could think of is it meaning it tries to unload the "login" level fails, and crashes? How else would I go about sending a client to a different map?

It is especially strange since the "Login Level" loads up if i connect by commandline in the executable, then loads the map the server is running and everything is just fine?

Product Version: Not Selected
Tags:
more ▼

asked Oct 13 '14 at 08:30 PM in Using UE4

avatar image

Mopperl
263 9 6 16

avatar image Mopperl Oct 13 '14 at 09:23 PM

Update:

Nevermind the original Issue, it appears I found why it crashes.

What I am trying is this: Client connects to a kind of test setup of a login server. They enter their Login Data, click Login, and the login server executes the load command for the Player.

Without any Login stuff and the load command being issued right after the button is clicked it works, the Player is transfered to the other Server just fine.

If I send the Login Data to the Server, the server verifies it and tries to call the command for the Player it crashes, I tried executing the Console Command as replicated on client, but same result, any Idea why this might be?

avatar image TJ V ♦♦ STAFF Oct 14 '14 at 05:41 PM

Hi Mopperl,

Could you also post your dxdiag, .LOG, and .DMP files. Click the link below for directions on where to find these files.

https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It was just me not realizing the proper way to networking, after some working and researching I fixed it. I will keep in mind to post the additional files next time I encounter a big Issue, thanks.

more ▼

answered Oct 16 '14 at 04:47 PM

avatar image

Mopperl
263 9 6 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question