x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to make changes to Cloned ShooterGame

 Info     ShooterGameServer - D:\Unreal Projects\FE\Source\ShooterGameServer.Target.cs
 Info ERROR: Couldn't find target rules file for target 'FE' in rules assembly 'FE_EditorRecompileModuleRules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
 Info Location: D:\Unreal Projects\FE\Intermediate\Build\BuildRules\FE_EditorRecompileModuleRules.dll
 Info Target rules found:
 Info     UE4Game - D:\UE4\Unreal Engine\4.4\Engine\Source\UE4Game.Target.cs
 Info     ShooterGame - D:\Unreal Projects\FE\Source\ShooterGame.Target.cs
 Info     ShooterGameEditor - D:\Unreal Projects\FE\Source\ShooterGameEditor.Target.cs

I'm not using a compiled version of UE4, my Engine is from the installer. Not sure what the issue is.

Product Version: Not Selected
Tags:
more ▼

asked Oct 13 '14 at 09:01 PM in Using UE4

avatar image

slev23
10 3 8 10

avatar image Doug E ♦♦ STAFF Oct 14 '14 at 06:38 PM

Hey slev23-

There are a few questions I need to ask to have an understanding of what is happening here. Which version of the engine was the project created with and which version are you trying to clone to? Do you receive this error message when trying to clone the project or when trying to open the cloned project? Have you received this error when trying to clone any other projects? Any information you can include to help us understand what's happening when you get this message will be useful in finding the cause of the problem.

Cheers

Doug Wilson

avatar image slev23 Oct 14 '14 at 06:51 PM

I am using the installer version currently (4.4.x) I am able to clone, open, and play the project. The issue occurs only when I attempt to compile the project. The above error displays when I try to use the in editor compilation. I've also tried Building through VS and while that doesn't error, it also doesn't seem to acknowledge any of my code changes.

Edit: essentially the project works fine on its own, it's just if I try to modify it any way it won't budge.

avatar image Doug E ♦♦ STAFF Oct 14 '14 at 07:40 PM

Were you able to make a cloned copy of any other project and add code to that? Have you tried doing this in 4.5 yet?

avatar image slev23 Oct 14 '14 at 11:46 PM

I just did a fresh clone in 4.5 with a new download of the 4.5 version of ShooterGame. The error has persisted.

avatar image slev23 Oct 15 '14 at 01:02 PM

To add more info: I tried doing another clone without renaming the project. That worked great. I think it's a renaming issue with some of the core game classes retaining "ShooterGame." I believe I saw in another post this issue has been addresses in the development branch of the engine.

avatar image slev23 Oct 14 '14 at 07:41 PM

I have no attempted either. I will set up a copy of 4.5 when I am able to and see if the problem persists.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey slev23-

That is correct, there was a problem with changing the name of a ShooterGame project not updating the associated files properly that has been addressed internally. You should see a fix to this in a future update to the engine.

Cheers

Doug Wilson

more ▼

answered Oct 16 '14 at 01:06 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question