x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particle textures are drawing in wrong order. Tried all draw settings :(.

Particle textures are drawing in wrong order. Tried all the options under 'Sort Mode' in within the requirements module in both of this effects:

[link text][1]

Any solution to this?

Thanks

Bruno [1]: https://www.dropbox.com/s/vymysmmgmxop33v/Clipping_Problem.jpg?dl=0

Product Version: Not Selected
Tags:
more ▼

asked Oct 14 '14 at 01:08 AM in Bug Reports

avatar image

Bruno_G
51 14 26 30

avatar image Lovecraft_K ♦♦ STAFF Oct 14 '14 at 03:10 PM

Hey Bruno_G -

I see your problem in the picture, but cannot diagnosis without seeing your particle system setup. Would you mind sharing your particle system and materials for that system so I can help you solve this issue?

Thank You

Eric Ketchum

avatar image Bruno_G Oct 15 '14 at 12:41 AM

Yeah no problem man here you go: https://www.dropbox.com/s/vmx8brse9eogrch/Particle_ClippingProblem.rar?dl=0

The effects are under the Ambient Folder and the materials and Textures are in the folders along the Ambient folder.

Hope you can see whats wrong

Thanks Eric!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey Bruno_G -

This is a simple fix though it might take some explaining as to why it is happening. Translucency Depth Rendering is controlled by object bounds and the origin of those bounds. So for Particles, the Fixed Bounds and the size becomes very important to ensure that the particles render in the correct order. For your particles the heavyflame and the P_SmokeHeavy I adjusted the Fixed Bounds downward from the values you have set to values of Min -250,-250,-10 Max 250, 250, 1250 for both emitters. This way your bounds in the World Space do not overlay and will render based on the origin bounds depth from camera correctly.

Thank You -

Eric Ketchum

more ▼

answered Oct 15 '14 at 02:14 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image Bruno_G Oct 15 '14 at 07:39 PM

Ok cool so where do i go for those options ? sry lost me there :/

avatar image Lovecraft_K ♦♦ STAFF Oct 15 '14 at 08:37 PM

Click on the Black Space outside of your emitter module list and you will bring up Whole Particle System settings in the details area of Cascade and the Fixed Bounds Min and Max settings are located here.

Thank You

Eric Ketchum

avatar image Bruno_G Oct 15 '14 at 10:00 PM

Ok found it, checked the Use fix relative bounding box option and added the values you told me. it did not fix the issue, the white column of smoke still has the problem, that it will display the other heavy flame on top of it even if it is physically in front of it :(

Did you got it to work? like none of them overlapping and showing correctly?

avatar image [Epic]homeRye STAFF Oct 20 '14 at 06:58 PM

Emitters are drawn from the back of the scene to the front, it looks like the translucency sort priority of your front emitter has been set higher than the emitter in the back. Click the emitter actor and make sure they have the same translucency sort priority.

I.e. anything with sort priority of 1, will render in front of priority 0.

avatar image [Epic]homeRye STAFF Oct 20 '14 at 07:00 PM

Or, wait are these effects in the same emitter actor? If so you from what I can tell in the screenshot you should break these out into two separate VFX...I think you have a column of smoke in the distance behind a closer column?

avatar image Bruno_G Oct 21 '14 at 02:19 PM

Its two different separate effects -.-

Where is that sort priority feature?

My problem is, what if i dont drag and drop those effects? what if i pull these when a vehicle in my game is destroyed? where would i tweak that sort priority then?

If you download the rar in the link i gave you'll see its two different effects that if you lay on a map, the flamey one is always gonna render on top of the one with white smoke only.

Tricky stuff :( ...sigh...

Thanks

avatar image Lovecraft_K ♦♦ STAFF Oct 21 '14 at 03:05 PM

Hey Bruno_G -

In the setup of these two effects what is the distance between the emitters in your level? Are they right on top of one another, or some distance apart?

Thank You

Eric Ketchum

avatar image Bruno_G Oct 21 '14 at 05:33 PM

They are not on top of each other they are within a distance and no matter the distance, the flamey one draws on top even if its behind the other one that is just grey smoke. You understand? You can download it and place them in a map and see what I mean.

Thanks, can't afford this to happen for other effects and wanna know how to fix it in general.

avatar image Bruno_G Oct 21 '14 at 05:28 PM

They are not on top of each other they are within a distance and no matter the distance, the flamey one draws on top even if its behind the other one that is just grey smoke. You understand? You can download it and place them in a map and see what I mean.

Thanks, can't afford this to happen for other effects and wanna know how to fix it in general.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Bruno_G -

Here is the results with my bounds settings I mention above. (Excuse the small size of the gif):

alt text

As you can see I get the appropriate overlay when viewed front to back, but as I transition around the two systems one's bounds will tell the other that it takes precedence. You can manual go in to a transparent object and adjust the transparent sorting order, but going into the object's Rendering >> advanced Drop down and Change the value of the Translucency Sort Order. Higher numbers here will render on top of lower numbers. This will set a hard value which will always render as this value has set.

Thank You

Eric Ketchum

more ▼

answered Oct 21 '14 at 06:26 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image Bruno_G Oct 28 '14 at 09:06 PM

Hi Eric :)

Please guide me to those Translucency Sort Order options, i cant find them anywhere. This seems like it could be my solution.

Thanks man!

avatar image Lovecraft_K ♦♦ STAFF Oct 28 '14 at 09:17 PM

Hey Bruno_G -

alt text

There are in the details panel of your particle in the level.

Thank You

Eric Ketchum

transdetails.jpg (66.1 kB)
avatar image 商晨亮 Apr 24 '19 at 07:27 PM

thank you,your answer solve my problem!

avatar image Bruno_G Oct 28 '14 at 09:28 PM

Oh cool ok. But what about effects that i wont place in my map? But rather show when i shoot at surfaces?

I,m having issues now with a cool dirt explosion i made. Basically the shockwave effect i made with GPU particles is showing in front of the other emitters like the flying debris and the dust animations making it look weird. So within different emitters within a particle system, how do i decide which one shows in front of the rest? Specially since the sort mode options within the required module dont seem to work for me :(

avatar image Bruno_G Oct 28 '14 at 09:36 PM

By the way, look at this :(

http://i.imgur.com/69evvam.png

I set its Translucency Sort Order to 3 while the other effect behind it is set to 0

Same problem, also tried those exact fixed bound parameters you sent me, still get the same problem.

Need an easy way to designate which emitter within a particle system will show in front and which one will show behind but the Sort Mode options within the required module wont work at all, tried all of them.

So at the moment i dont have any control on this whatsoever, really need to solve this for the rest of my effects i,m making :(

avatar image Bruno_G Oct 28 '14 at 10:15 PM

Hey Eric,

To make things much easier for you, here is my Ground_Blast effect:

https://www.dropbox.com/s/lud5xeuyzm2xpjl/Ground_Blast.rar?dl=0

Please check it in the editor, youll notice that:

1- The shockwave effect draws on top of the main dusty body of the effect which is wrong.

2- The brown dust base emitter draws on top of all the flying debris even if behind them

So basically i just want to find a way so i can designate each emitter's drawing order. Basically, i wanna make it realistic, depending on the position of the sprites they should render in front or behind each other correctly and not always on top of all of them like in the case of my shock-wave :(.

Please take a look at it i,m sure you'll find a way around this,

Thanks man , cheers!

avatar image Bruno_G Oct 29 '14 at 11:58 AM

Hey Eric :)

Thank you for your response you seemed to fix the problem.

I,m just not sure where to find those options you told me about the sorting order! Sorry bit of a noob here :/

I wanna see if i can fix it or know how to handle it. I've got this cool dirt explosion effect that is having the same problems within its emitters :(, i feel that i cant control it at all within the required module you know what i mean.

Please guide me to those options you told me, the Translucency Sort Order, if that fails i would love to send you my dirt explosion for you to check and diagnose better?

Thanks man :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Bruno_G -

Ok after seeing your latest upload I think I know what the problem may be and a solution for it. In Cascade the particle system's Emitters are always rendered bottom (left) to Top (Right). So in order to get the debris in both places you want it, I would duplicate that emitter and maybe half the number of generated particles and then place one on either side of your clouds. This way they will show up in both places as would happen in a real explosion. By halfing the number emitted from each you are also not adding any additional rendering complexity to your overall effect.

Now, if you have an effect that is made up of two particle systems (each with its own sub-emitters), the translucency ordering I mention above can be helpful if and only if the Fixed Bounds issue does not fix the issue.

Thank You

Eric Ketchum

more ▼

answered Oct 30 '14 at 06:54 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image Bruno_G Oct 30 '14 at 11:14 PM

Ohhhh i see!

So is there any quick and easy way of sort of dragging the emitters left and right? So i wont have to duplicate the whole effect and re export every emitter in the right order?

Thanks Eric!

avatar image Lovecraft_K ♦♦ STAFF Oct 31 '14 at 02:18 PM

You can click on the Main Emitter and use the left and right arrow keys on your keyboard and they will move back and forth.

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question