x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lighting Wrong Gross, But When Not Built, Looking Fine (Complicated Mesh, UV Mapping Impossible)

When adding/altering light the preview looks perfect

https://answers.unrealengine.com/storage/attachments/17901-screenshot%202014-10-14%2021.18.54.png

but when I try building the Lighting everything looks bad.

https://answers.unrealengine.com/storage/attachments/17902-screenshot%202014-10-14%2021.19.37.png

I know I need to alter the UV Map, but at the moment thats not possible and the preview does work obviously.

So how can I make UE4 ignore the bad UV Map and just let use whatever setting it uses to build the preview lighting?

Thank you guys!

Snipe

Product Version: Not Selected
Tags:
more ▼

asked Oct 14 '14 at 10:13 PM in Rendering

avatar image

SnipeOrigin
1 1 1 3

avatar image Jacky Oct 14 '14 at 10:27 PM

The preview lighting isnt "built," meaning it isnt static.The only way to avoid UV mapping for lightmaps is to use dynamic lighting with a movable skylight.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey SnipeOrigin,

As Jacky mentioned, the preview lighting is not built and baked into your level. And the only way to "ignore" your UV Maps are to add a dynamic and moveable skylight. I suggest building your project on medium lighting and adjusting the settings of Shadow Bias as well as Shadow Filter Sharpen to increases the shadow detail of your level. The correct way to fix this however would be to go into your UV lightmaps of the mesh you are focused on to align appropriately to the grid and provided a 2px to 4px buffer so you have no bleeding or tiling of light artifacts. Let me know when you have tried these work around and still are having issues. Be sure to build your lighting also to see what the outcome will be.

Thank you,

Andrew Hurley

more ▼

answered Oct 15 '14 at 02:07 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question