x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I fix smoothing group error when Importing mesh?

Hey guys,

I'm trying to import my Tree-Meshes I did with Blender like in this video

https://www.youtube.com/watch?v=WlRF5S0aHwU

But after import, UE4 tells me this Note " No smoothing group information was found in this FBX scene. Please make sure to enable the "Export Smoothing Groups" option in the FBX Exporter plug-in before exporting the file. "

I cant set up the textures for the Leaves.

Can SM tell me what i did wrong?

Greets!

Product Version: Not Selected
Tags:
more ▼

asked Oct 15 '14 at 03:36 AM in Using UE4

avatar image

GameDesignHero
51 1 3 6

avatar image vrich Jan 22 '16 at 05:30 PM

What if you are using a 3d modeling software without a smoothing group export? I'm an architect who wants to make a walk through of the building I design in sketchup. When I import all the surfaces are hard? Can I adjust what is smooth or not in unreal?

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Just to clear up any confusion for anyone who happens to stumble across this thread with the same issue, here is the fix for Blender:

When exporting the the model from blender in the FBX format, you can select one of the follow three types of smoothing:

  1. **Edge**
  2. **Face**
  3. **Normals**

In the past, only Edge and Face worked (didn't bring up the smoothing error in UE4), but it now seems that any of the three work just fine.

more ▼

answered May 23 '15 at 04:32 AM

avatar image

kingADZ12
31 1 7

avatar image micwanyoike Jul 26 '17 at 10:27 AM

Just to clarify this answer, Choose Geometries then you'll be able to see the different Smoothing Groups(Edge, Face, Normals) By default Normals is selected, so choose Face or Edge

(comments are locked)
10|2000 characters needed characters left

Hi,

You'll need to make sure that you've properly setup smoothing groups for your mesh to avoid this error message.

I don't use Blender personally so I'm not entirely sure how to setup smoothing groups but this tutorial from a Google search should help.

http://blender.stackexchange.com/questions/4806/blenders-smoothing-groups-solution-edge-split-destroys-topology-is-there-a

And to set up the texture for the leaves you'll need to make sure that you've imported the texture > Made a new Material with your material > make sure to use the Opacity Mask to only show the leaves portion of the texture.

Thank you!

Tim

more ▼

answered Oct 15 '14 at 06:07 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 885 96 872

avatar image GameDesignHero Oct 16 '14 at 05:49 AM

Hey Tim,

thanks for your answer .. one question:

Is it really necessary to do smoothing groups?

Becaue in this video, for example, the issue dont come up!

https://www.youtube.com/watch?v=tFTXRVcyFmU

avatar image GameDesignHero Oct 16 '14 at 06:38 AM

Ok I got it!

For all of you who directed to this post... When you want to export your model, you can easily select smoothing to " faces " in the exporter ( in blender ) .

That fixed my problem. :)

edited

(comments are locked)
10|2000 characters needed characters left

Working with blender 2.74, it works with Face enabled.

Export .FBX with Blender 2.74 to UE 4.8.2.

And the "No smoothing group information was found in this FBX scene. Please make sure to enable the "Export Smoothing Groups" option in the FBX Exporter plug-in before exporting the file" issue do not mess you up anymore :)

more ▼

answered Jul 20 '15 at 02:50 PM

avatar image

Vertebrat
1 2

avatar image Designer102 Sep 13 '15 at 08:05 PM

How do you enable the "Export Smoothing Groups" option? I am having trouble figuring out where it is and how to enable it.

avatar image FearingFun Sep 13 '15 at 08:14 PM

If you did what I sometimes do, you might have accidentally scrolled down on the export properties window to the left. alt text

avatar image Designer102 Sep 13 '15 at 08:28 PM

Thanks that cleared up alot! :)

avatar image hinata's cool May 13 '17 at 06:27 PM

I have this same problem but I cant find those options I think its because I have an updated ver 2.76 of blender any idea where it may be now?

avatar image jimd667 Jun 16 '17 at 10:17 PM

For anyone else looking for where it is, check under the Geometrie tab for blender v2.78

alt text

pic.png (12.9 kB)
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question