x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor rendering weird on tanslucent mats

Hey all,

I changed a default mat (M_LayoutMat) to translucent today, and now everything in the editor that's using a mat instance of it seems to be freaking out. Certain parts are not being rendered. It seems the objects behind them are. and it's not even the whole object, most of the time it's cut off.

It does this in play mode as well.

Any ideas? Do I need to set some other properties in the mat editor?

Thanks all!

alt text

Product Version: Not Selected
Tags:
weird.jpg (820.8 kB)
more ▼

asked Oct 15 '14 at 06:45 AM in Rendering

avatar image

AustinK
215 22 19 28

avatar image Lovecraft_K ♦♦ STAFF Oct 15 '14 at 01:22 PM

Hey AustinK -

Looking at your example map, I am going to make the assumption that you are using BSP Brushes (Geometry Brushes). There are some known rendering issues with these brushes. If you try to rebuild geometry in the level (under build lighting) the problem may go way but with the Translucent material there may be additional issues trying to render the Z depth of the scene. Try converting the BSP brush into a Static Mesh and see if the translucent setting on the material rendering correctly.

Thank You

Eric Ketchum

avatar image AustinK Oct 16 '14 at 05:03 AM

Hey Eric. That didn't seem to work. ALL objects are now statics meshed. I re-built the level, and I still have the same issue. I've taken more SS's for you.

The one that looks somewhat normal (except for the back stairs being cut off) is just me moving the camera forward till it popped to normal.

Thanks a bunch!

  • Austin

alt text

effed_up.jpg (910.3 kB)
normal.jpg (864.5 kB)
avatar image Lovecraft_K ♦♦ STAFF Oct 16 '14 at 02:19 PM

Hey AustinK -

Two quick Questions, one, what version of the engine are you using? Two, Can you double check the name of the Material you have changed. I am not seeing it in my Engine content at all.

Thank You

Eric Ketchum

avatar image AustinK Oct 17 '14 at 04:20 AM

Hey Eric,

I'm in 4.4.3 (downloading 4.5 right now), and as for the material, I forgot that I had migrated the materials folder from the ContentExamples project. You should be able to find it there. But, I also create a material that was simply a base color and had a scalar parameter for the opacity as another test. I still encountered the same issue. If things change on 4.5, I'll let you know.

UPDATE: Upgrading to 4.5 didn't work.

avatar image Lovecraft_K ♦♦ STAFF Oct 28 '14 at 01:28 PM

Hey AustinK -

Do you find that the rendering pops in and out based on your camera distance from a particular object?

Thank You

Eric Ketchum

avatar image AustinK Oct 29 '14 at 04:04 AM

Hey Eric,

Yeah, the distance will make them pop (closer is viewable, further and it will disappear. It's not just distance though... but where it seems to be where the camera is looking? I've loaded some screen shots focusing on the blue platform (the one with a block above it and stairs leading up to said platform).

It's pretty weird. I did read that UE4 has trouble with translucent mats so I'm going to just ignore using them for now. I can get plenty of work down without them.

But, if you still have more questions, want more Screenshots, or whatever else, just let me know.

  • Austin

alt text

lookdownposx.jpg (583.4 kB)
lookdownposy.jpg (625.8 kB)
lookdownnegx.jpg (577.9 kB)
lookdownnegy.jpg (580.6 kB)
avatar image Lovecraft_K ♦♦ STAFF Oct 31 '14 at 03:44 PM

Hey AustinK -

I believe that this is a Translucent Sort Issue but I want to test this more specifically so I can give you an appropriate fix for the issue. If you can can you upload a copy of the project for us to test? All you would need to do is zip up the Content and Config sub folders and the uproject file and upload that zip here, and if its too big feel free to link to a dropbox.

Thank You

Eric Kethcum

avatar image jorg1234 Oct 31 '14 at 04:32 PM

Hi! Any news on this issue? I'm trying to work around the same problem..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey AustinK -

After some additional testing, I can confirm that this is a translucent sorting issue. The engine renders translucency using the bounds of an object to determine placement of the translucent objects in the scene. So your floor which your character model is inside of will render behind because it doesn't see the extents and it will pop back up when you move further back to reveal the edges of the bounds.

There is a way to fix this by setting the Translucent Sort Order in the Rendering Details of each mesh. The higher number will render on top of the lower numbers. This is universal though and will override all engine translucency rendering so use with care and caution.

Thank You

Eric Ketchum

more ▼

answered Nov 05 '14 at 04:37 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 736

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question