x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Failed to find object 'Class None.'

Here is the end of the startup log:

 MapCheck: New page: Apartment - 15 Oct 2014 14:26:42
 MapCheck: Info Map check complete: 0 Error(s), 0 Warning(s), took 104.183ms to complete.
 LogFileHelpers: Loading map 'Apartment' took 1.507
 LogCollectionManager: Loaded 0 collections in 0.000753 seconds
 LogCrashTracker: Crashtracker disabled due to settings.
 LogUObjectGlobals:Warning: Failed to find object 'Class None.'
 LogLoad: Full Startup: 17.31 seconds (BP compile: 2.05 seconds)

I have no idea what that 'Class None' is referring to. I checked all the tabs in the Message Log but nothing relevant shows up there. It doesn't depend on the map the editor loads on startup. How could I find out exactly what goes wrong?

Product Version: Not Selected
Tags:
more ▼

asked Oct 15 '14 at 10:38 AM in Using UE4

avatar image

ZoltanE
1.6k 79 94 145

avatar image piinecone Nov 13 '14 at 05:44 PM

@ZoltanE did you happen to sort this out? I'm seeing this warning too.

avatar image ZoltanE Nov 13 '14 at 05:51 PM

No but I noticed that it's present even in a new project without starter content so it is an issue of the engine release. It will probably go away in the next build.

avatar image Todd.Vance Aug 06 '17 at 07:39 PM

ha, I'm getting that in August, 2017 with U Engine 4.16.3!

avatar image Doug E ♦♦ STAFF Nov 13 '14 at 07:54 PM

Hey ZoltanE-

Wat version of the engine are you working in? Also, are you running the engine from the launcher or through source code from GitHub?

avatar image piinecone Nov 13 '14 at 08:38 PM

If it's of any use, I'm using a source build of 4.5.1, SHA ad428a1.

avatar image ZoltanE Nov 13 '14 at 08:47 PM

I'm on 4.5.1-2336687 binary release.

avatar image Doug E ♦♦ STAFF Nov 14 '14 at 06:11 PM

It sounds like a blueprint that is supposed to reference a class or an object of a certain class is not getting set properly somewhere. When exactly does this warning message occur? Are you seeing it when you open the editor or when running Play in editor, etc.?

avatar image piinecone Nov 14 '14 at 06:18 PM

For me, it's when I open the editor. My project is mostly C++ but there are a few blueprints. It might have occurred after I renamed one of them, but I honestly wasn't paying close enough attention to the startup warnings. It doesn't seem to have any adverse effects on my project but I'm happy to supply an archive of my project or try something out to help narrow down the case.

avatar image ZoltanE Nov 16 '14 at 07:58 AM

It shows up as the editor is starting even in a new, empty project without starter content. Both BP and C++ templates seem to be affected.

avatar image GamerErrant Nov 16 '14 at 09:31 PM

I've been getting the same error since 4.5 - it happens even when opening a new blank project.

avatar image keplerspacepilot Aug 12 '18 at 12:42 AM

I'm also getting this issue! I've attempted to fix following advice from this thread, but still the error appears and I think it's stopping the cook from working. It's the only error left in my cook log and I'd love to find the solution.

Any other ideas?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

I was able to resolve this issue in PR #3300 (still needs to be reviewed by Epic). The issue was caused by the engine trying to load a startup tutorial from the project settings that was empty.

Hope that resolves the issue for everyone. Cheers,

more ▼

answered Feb 23 '17 at 05:35 PM

avatar image

project.gheist
1.6k 22 10 49

avatar image huulong May 10 '17 at 04:33 PM

Nice, I have subscribed to the PR and I'll check if the bug is gone in the next version.

avatar image Yakim Jul 05 '17 at 04:18 PM

alt text

avatar image jimd667 Aug 06 '17 at 08:43 PM

ya I still get this all the time as well for as long as I can remember, it's the ol' class none, an old friend indeed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had same warning. For me the following fixed the problem:

  1. Go to ProjectSettings->Engine->Tutorials

  2. In "Startup Tutorial" dropdown select "EditorTutorial" instead of "None".

UE Version 4.16.2

more ▼

answered Jul 11 '17 at 08:29 PM

avatar image

Dant3s_
16 2

avatar image Vertex Soup Jul 18 '17 at 08:33 PM

I can confirm this is valid for UE4.16.2 message is gone. Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey guys-

Thanks for the information for this issue. I was able to locate the warning message in my own project and have submitted it for further investigation (UE-5528).

Cheers

Doug Wilson

more ▼

answered Nov 17 '14 at 04:12 PM

avatar image keyle Aug 31 '15 at 04:09 AM

any updates on this Doug?

avatar image Doug E ♦♦ STAFF Aug 31 '15 at 01:35 PM

Hey keyle-

The referenced bug number is still open for investigation however the warning message reported here does not affect creating / loading / opening a project in any way.

avatar image ivanrosadev Jan 03 '16 at 03:55 PM

Any updates?

avatar image Doug E ♦♦ STAFF Jan 04 '16 at 05:36 PM

Hey IvanRodriguez-

The bug report for this issue is still open in our database and unfortunately there is no way to determine exactly when a fix will go in. Since this is simply a warning message and does not seem to affect creating/loading/opening a project it should be safe to ignore.

avatar image Angel Tsvetkov Jul 28 '16 at 03:02 PM

This BUG still exist in UE 4.12.5. Change category to BUG

avatar image Doug E ♦♦ STAFF Jul 29 '16 at 03:16 PM

Hey AngelTsvetkov-

This issue appears to have been fixed internally as the message was no longer appearing, and it should be included in a future update to the engine. You can track the issue publicly here: https://issues.unrealengine.com/issue/UE-5528

avatar image T0fum4n Aug 18 '16 at 11:06 AM

This also happens when using a First Person default blueprint class with starter content, when you try to make a new C++ class. This is preventing me from being able to create a new character blueprint that is C++.

avatar image Doug E ♦♦ STAFF Aug 18 '16 at 02:08 PM

Hey Tofum4n-

The error message was printed however I was still able to create a character class as well as a blueprint based off of my custom character class. Can you provide the error message you are receiving and exactly what you are doing when the error occurs?

avatar image JonTerp Sep 10 '16 at 01:42 AM

Issue tracker states "No-longer occurs in 4.13" but I'm seeing the warning still in my 4.13 project.

This project was imported from a previous version of the editor.

avatar image Doug E ♦♦ STAFF Sep 12 '16 at 01:47 PM

Hey JonTerp-

We are still investigating this issue to narrow down where it is and is not occurring.

avatar image nischtz Nov 07 '16 at 05:37 PM

I'm seeing this warning in all my projects, and pretty much every .log file users posted here. I might have an idea, though...

When starting the engine, the following lines are logged for me:

[2016.10.10-13.59.21:241][ 0]LogContentBrowser: Native class hierarchy updated for 'SceneOutliner' in 0.0009 seconds. Added 1 classes and 2 folders.

[2016.10.10-13.59.21:297][ 0]LogCrashTracker: Crashtracker disabled due to settings.

[2016.10.10-13.59.21:306][ 0]LogUObjectGlobals:Warning: Failed to find object 'Class None.'

[2016.10.10-13.59.21:371][ 0]LogContentBrowser: Native class hierarchy updated for 'HierarchicalLODOutliner' in 0.0008 seconds. Added 1 classes and 2 folders.

When closing the engine, the modules are unloaded in reverse order:

[2016.10.10-21.07.18:628][824]LogModuleManager: Shutting down and abandoning module HierarchicalLODOutliner (243)

[2016.10.10-21.07.18:628][824]LogModuleManager: Shutting down and abandoning module CrashTracker (242)

[2016.10.10-21.07.18:629][824]LogModuleManager: Shutting down and abandoning module SceneOutliner (241)

Maybe someone who doesn't experience this warning could take a look, if there's a module that is unloaded between HierarchicalLODOutliner and CrashTracker? (sorry, couldn't get the formatting right)

avatar image CitéNoir Nov 16 '16 at 11:56 PM

seeing it too, in 4.13 and now in 4.14

alt text

log.jpg (360.1 kB)
avatar image ALegendsTale Nov 17 '16 at 12:05 AM

They have it scheduled for fix in version 4.15 but for some reason in the developer notes here they state it has already been fixed.

avatar image CitéNoir Nov 17 '16 at 12:13 AM

yeah, read that too in the notes. but thanks for the update on the schedule!

I get a few "failed to find object none.none" as well in there. is this related to the class.none thing? they only appeared after switching from 4.13 to 4.14.

avatar image AG1970 Dec 04 '16 at 07:38 PM

created from clean 4.14 project (first person C++ template) LogUObjectGlobals:Warning: Failed to find object 'Class None.'

avatar image jimd667 Dec 05 '16 at 04:18 PM

Same error on cooking a project in 4.14. It's not a fresh project but it seems like so many other people have this issue I might as well chime in since I could not find the root cause of this in my project.

class none error

classnoneerror.png (55.6 kB)
avatar image mindw0rm Dec 05 '16 at 11:46 PM

I see this warning in 4.14.0 when opening a project without a tutorial in it.

The warning is triggered in StaticLoadObject (in Runtime/CoreUObject/Private/UObject/UObjectGlobals.cpp, lines 872ff), called from a call to LoadClass in FIntroTutorials::MaybeOpenWelcomeTutorial() (in Source/Editor/IntroTutorials/Private/IntroTutorials.cpp, line 329), which is commented with "try project startup tutorial".

The only meaningful parameter given is *GetDefault()->StartupTutorial.ToString(), which returns an empty string -- not surprising, since there is no tutorial.

A fix might be as simple as checking this string for not being empty before calling LoadClass.

Or (since this warning sometimes seems to occur in other circumstances too) maybe LoadClass/LoadObject could even silently return null if the given name is empty? The caller should check for a valid result anyway (which is done here, so no further error occurs). Or change the warning to something like "name must be valid" or "empty object name given to LoadObject"?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I believe this also causes cooking to fail. I can't cook my project with the same message, just as an error. There needs to be a way to figure out WHERE Unreal detects the NONE so we can fix it in our projects!

more ▼

answered Dec 10 '16 at 06:35 AM

avatar image

Wallenstein
627 35 45 76

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I also get this error but in my case it refers to my gamemode, because I intentionally left the default player character to none because I change it at runtime, so maybe you also have an empty slot inside gamemode, I hope this helps...

more ▼

answered Dec 10 '16 at 09:21 AM

avatar image

syq
21 1 3

avatar image Wallenstein Dec 11 '16 at 12:23 AM

Thanks but all my fields in the Project settings are filled out with valid classes. It is something in my C++ files I believe, that's going to be one hell of a workload to figure that out :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question