x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4.5 Crashes at Editor Startup

I've imported my 4.4.3 project to the new 4.5 and for a unkown reason the editor crashed without giving any advice of the error. I've found at the log the following lines.

[2014.10.15-10.47.32:641][  0]LogWindows: === Critical error: ===
Assertion failed: PreviousCDO != nullptr [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.5\Engine\Source\Editor\UnrealEd\Private\Kismet2\BlueprintEditorUtils.cpp] [Line: 1060] 

The log file is link text

Is there any wrong blueprint or something that messed up?

Thanks for the help

Product Version: Not Selected
Tags:
cbgame.zip (3.4 kB)
more ▼

asked Oct 15 '14 at 11:06 AM in Bug Reports

avatar image

rafaeljpc
26 1 3 6

avatar image makai Oct 28 '14 at 02:23 AM
avatar image ryuikuya Oct 28 '14 at 02:53 AM
avatar image Jonathan Dorman STAFF Oct 28 '14 at 05:47 PM

If you're having the same problem as rafaeljpc, then your blueprints are the problem. I would recommend removing your blueprints and trying to rebuild them - if you still have a copy of the project that hasn't been converted to 4.5, you can use the blueprints as a template to recreate them in 4.5.

avatar image Jonathan Dorman STAFF Oct 28 '14 at 05:23 PM

Hello rafaeljpc,

Could you try removing the files in your Content folder (in the project) and see if that allows you to open the project? If so, you could reintroduce the files in the content folder until you find the asset causing the crash.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

Actually I used the oportunity to rewrite all de BPs, maybe is a funcion that I used. I'll try to improve the quality of the BPs of my game.

Thanks

more ▼

answered Oct 28 '14 at 05:29 PM

avatar image

rafaeljpc
26 1 3 6

avatar image Jonathan Dorman STAFF Oct 28 '14 at 05:38 PM

So you found that changing your blueprints fixed the crash?

avatar image rafaeljpc Oct 28 '14 at 05:40 PM

Yes, but I not finished all BPs yet. I'll comment here later if I have some trouble

avatar image paradoc Oct 28 '14 at 10:41 PM

i had this problem as well, and was worried i'd have to re-write everything. instead, in the content directory, in the 4.5 version, i deleted the game mode which seemed to be the root of the issue. i went to the 4.4.3 version and re-mirgrated it to the 4.5 directory. after that, everything seemed to work.

avatar image Jonathan Dorman STAFF Oct 29 '14 at 01:18 PM

Do you know what part of the GameMode could have been the cause?

avatar image paradoc Oct 29 '14 at 01:53 PM

i wasn't able to figure that out unfortunately. any attempt to open a blueprint that referenced it crashed which helped me isolate the issue to that class. breaking all dependencies to the game mode by deleting and re-migrating it fixed the issue, but the drawback was i had to re initialize all references to it. i don't know if this info helps at all, but when i was re-initializing my game mode class, i noticed all references to it reverted to being declared as object class rather than customGameMode class in the variable references to that class. if you want, when i'm back at that machine this evening, i can upload that game mode blueprint from 4.4.3 if you want to run some tests on it.

i started a thread for this prior to finding this thread. here is a link to that info and logs as well:

Crash during conversion

avatar image Jonathan Dorman STAFF Oct 29 '14 at 02:51 PM

This is helpful - thanks.

avatar image makai Oct 30 '14 at 04:29 PM

ok i was wrong most files are corrupted so my project is trash now and the biggest problem how did that happen? i want to avoid this or my work is waste of time

avatar image rafaeljpc Oct 30 '14 at 04:31 PM

Maybe you should rewrite the project. Just downgrade it editing the .uproject on a notepad and changing the version of the engine. And then create a new project on the 4.5. (thats what I'm doing)

avatar image paradoc Oct 30 '14 at 04:50 PM

part of how i fixed the issue on my end was similar to what rafaeljpc mentioned. I created a new project, and migrated the assets in from the old project. then i deleted the blueprints from the windows directory in the new project, ran the project to force break all dependencies, then brought in the blueprints from the old project again. after that process, rather than the engine crashing as usual, i was just getting compilation errors at that point which was easier to go through and fix.

avatar image makai Oct 31 '14 at 11:54 AM

well this doesnt fix it for me!

when i migrate the blueprints to a new project like paradoc mentioned, i keep getting a engine crash on opening those blueprints

when i downgrade and create a copy like rafaeljpc it keeps crashing also..

thanks for anyhelp.. really appreciated

avatar image paradoc Oct 31 '14 at 05:46 PM

false positive on my end :( after closing the project, i came back to the project and while re-opening, experienced the same crash.

however, i did discover something strange. in 4.4.3 when i used the function 'get player controller' from any class, i could use the context sensitive follow up function of 'get HUD' from the returned value in 'get player controller'.

in 4.5.1, when i grab the returned value of 'get player controller', i had to uncheck 'context senstive' to find the 'get HUD' function. this is the part of the process when my editor started crashing. so any actor that used this 'get player controller' function to grab the HUD and re-cast it, which was a lot of my actors, ended up getting corrupted and/or broke.

edit: found a reproducible way to open the project without crashing...first, i have to open an empty level where nothing is referenced rather than change the project settings to a custom level. second, i isolated the one class that i found to be culprit. as long as i open that class before any other, the engine works fine. now in the process of pin-pointing the issue in that class.

avatar image makai Nov 02 '14 at 03:21 PM

in mycase im not able to find the corrupted part as most parts seem to be corrupted.. my project was nearly finished and ready to publish.. now its all gone as i am not able to get my code back... sure i have backups but at much older progress. in visual studio i would have my code 100% in blueprinting i lost everything as my editor keeps crashing no matter which file to migrate..

blueprinting dont seem safe for me..and i don't trust it anymore at this state. i can now really say i would avoid working with blueprints as much as possible if you are going to work on a serious project until those errors are fixed and they are really like a cpp file...

pretty disappointing as i were really really enthusiastic working with it.. and they seemed to be very straight forward for me

avatar image Hyperloop Nov 13 '14 at 08:48 PM

It's understandable that from time to time blueprints and such may get corrupted. I do wish there were more tools at our disposal to figure out which asset(s) are causing the issue so we can remove the offending asset and restore to an earlier version of it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question