x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

No Generate VS Solution choice when right-click .uproject

Hello,

I have searched online and it turns out there are not solution to my problem. I have Visual Studio 2013 Professional installed and the latest 4.5 Unreal engine. But when I right-click the .uproject file there are no choice for me to generate VS solution. I have to run the .uproject to get the VS Solution, but I find that's not convenient.

So anyone has any idea on how to solve the problem?

Thank you very much!

Product Version: Not Selected
Tags:
more ▼

asked Oct 15 '14 at 03:21 PM in Installation & Setup

avatar image

Schiney
11 2 3 4

avatar image Doug E ♦♦ STAFF Oct 15 '14 at 04:42 PM

Hey Schiney-

Was your project originally created with code or was it a blueprint project that you are adding code to?

Cheers

Doug Wilson

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

FYI...I ran into this same problem and I just had to update the file association to use this executable in my Unreal Engine project.

C:\UnrealEngine\UnrealEngine\Engine\Binaries\Win64\UnrealVersionSelector.exe

more ▼

answered Dec 19 '15 at 04:47 AM

avatar image

Ryan Darcey
836 47 42 68

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Run Unreal Version Selector executable found in Engine/Binaries/Win64 and see if that helps.

more ▼

answered Oct 15 '14 at 03:39 PM

avatar image

THREEONEZERO
131 6 7 18

avatar image Schiney Oct 15 '14 at 04:29 PM

I only find the version Selector from Launcher/Engine/Binaries/Win64...I have run it but it says "The current folder does not contain an engine installation"...I have also tried uninstall and reinstall everything,but it still happens...

avatar image hamokshaelzaki Oct 10 '15 at 12:34 PM

Did you solve it ?

avatar image pgilmore Mar 13 '18 at 10:20 PM

I have a similar issue, and I cannot yet solve it. In the past, when my uproject files did not have the unreal right click options, I would just run the engine, it would detect the problem, and it would pop up and ask me if it should fix it. This time, I ran 4.18.3 and 4.17.2, and it neither detected the problem, nor offered to fix it. I'm installing older versions in hopes that one of them still does this. VersionSelector exe doesn't do anything for me, same as Schiney above. I ran it from every location, and it just doesn't work.

avatar image Doug E ♦♦ STAFF Oct 12 '15 at 01:35 PM

Hey hamokshaelzaki-

What is the issue that you're having? If you are trying to create the VS solution files from your .uproject, is the project code based or purely blueprints?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Schiney,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Oct 22 '14 at 08:50 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question