x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Animation Time (Ratio) not available in animation blueprint in 5.0

I'm in the middle of working on a fairly complex animation blueprint. I started it under 4.4, then continued under 4.5 Preview, and everything was going great. I upgraded last night to 4.5 release, and now I no longer have access to the Animation Time (Ratio) node. The ones that were already in the graph are still there and work but I can find no way to add new Animation Time (Ratio) nodes to my transitions in 4.5.

I've refreshed all nodes and deleted intermediate folders.

Any help would be appreciated.

Product Version: Not Selected
Tags:
more ▼

asked Oct 15 '14 at 04:32 PM in Bug Reports

avatar image

Kneebiter
291 15 26 44

avatar image Steve Hardister ♦♦ STAFF Oct 15 '14 at 05:58 PM

Hi jeff_lamarche,

Could you provide a screenshot so I can better assess the issue?

Thanks.

avatar image Steve Hardister ♦♦ STAFF Oct 15 '14 at 06:41 PM

Hi jeff_lamarche,

To be clear, are one of these the nodes you are expecting to see as an option?

alt text

timeratio.png (57.9 kB)
avatar image Kneebiter Oct 16 '14 at 07:28 PM

Weird. My comment from yesterday disappeared. Yes, these are the nodes I can't get. My existing Current Time (ratio) nodes are working fine, but I cannot find a way to add new ones.

avatar image Steve Hardister ♦♦ STAFF Oct 16 '14 at 08:37 PM

Hi jeff-lamarche,

The image I posted was taken from the 4.5 build.

Make sure "Use New Blueprint Menuing System" is Unchecked under Editor Preferences>Experimental. Then as before, try accessing the nodes with "Context Sensitive" checked (then unchecked if not resolved.) alt text

Please let me know if this fixes the problem.

Thanks

experimental.png (107.0 kB)
avatar image Kneebiter Oct 16 '14 at 08:41 PM

That setting was off already. I tried again, both with it on and off, and made sure to refresh nodes in between. In both cases, my transition rules do not seem to have access to current time (ratio).

alt text

avatar image Kneebiter Oct 16 '14 at 08:47 PM

Oddly enough, if I create a new project under 4.5 rather than imported from 4.4/4.5 preview, then I do have access to this node. I guess I can just export my entire project to a new one if I have to. :(

avatar image Steve Hardister ♦♦ STAFF Oct 16 '14 at 09:52 PM

I tried to recreate your issue with a third person animation project from 4.4.3, making a copy, then opening the copy in 4.5 but did not experience the problem. What version did you start from (ie. 4.4.0? vs 4.4.3?) Any additional information you can provide will help determine if this is a bug that needs to be addressed.

avatar image Kneebiter Oct 16 '14 at 10:14 PM

It was started under 4.4 (not sure which point release) from the C++ Third Person Template. It was upgraded through point releases, then upgraded by copy to 5.0 preview. That copy was then upgraded in place to 5.0 release.

There was a compile error moving to 5.0 preview around the use of bUseControllerRotationRoll, so I re-generated Xcode project using the Finder service. That caused problems - making Unreal think the 4.5 upgraded copy was actually a 4.4 project. I launched 4.5 editor from the launcher and upgraded it in place back to 5.0 release by opening it from the 4.5 editor.

Frankly, I'm guessing it's not a situation that's likely to be encountered by many :)

avatar image Steve Hardister ♦♦ STAFF Oct 17 '14 at 01:21 PM

Thank you for the additional information. The only other thought I had (if you haven't thought of this yourself) would be to clone a copy of your 4.4 project, open it in 4.5, delete your character folder that contains the animations in question, then go back to the original unmodified 4.4 project and migrate the folder from there that you deleted in 4.5.

This would prevent you having to export your entire project to a new one, if I understood you correctly. However, this is just a hypothesis based on your latest information. Something to try if you have time or haven't already exported your entire project to a new one.

In any event, let me know if you get this resolved.

Thanks

avatar image Kneebiter Oct 17 '14 at 02:36 PM

I'm in the process of trying a clean pull from source code. We only commit necessary folders, so I'm hoping that will solve it. If not, then I was planning to try migrating the animations from another project as you suggest. I'll let you know what works for me.

Thanks for your help on this.

avatar image Kneebiter Oct 17 '14 at 02:42 PM

Steve - after pulling it down clean from source control, the problem still persists.

Is there any value in giving you access to the repository? It's just a scaffold project I'm using to work on character blueprints, not our actual game project, so it's not gigantic and I'm more than happy to grant access to the repository.

It's a bitbucket repo, so if there's a bitbucket account you'd like me to give access to it if it would help to see the problem.

Just let me know.

Thanks!

avatar image Kneebiter Oct 17 '14 at 03:14 PM

After more investigation, the problem seems to be limited to this animation BP. If I create a new animation BP, I'm able to get the node. If I migrate this Animation_BP to a new project, it still happens.

avatar image Steve Hardister ♦♦ STAFF Oct 17 '14 at 05:07 PM

If you want you can send a zip file of the uasset for the Animation_BP and we'll take a look at.

Steve

avatar image Kneebiter Oct 17 '14 at 05:10 PM

Steve - I'm happy to do that, but can't attach it to a public ticket - it uses purchased Mixamo animations. Is there an e-mail I can send to? Should I export it to a .COPY, or just create a project that has nothing else in it?

avatar image Steve Hardister ♦♦ STAFF Oct 17 '14 at 06:02 PM

I sent you a message *in the forums with my email that you can send the zipped file directly to.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Nov 06 '15 at 02:16 PM by Steve Hardister for the following reason:

The question is answered, right answer was accepted: This was a bug in 4.5, fixed in 4.6. If you experience this in a future release, please start a new post. Thanks.


1 answer: sort voted first

A bug report has been generated for this issue: UE-4438

more ▼

answered Oct 20 '14 at 07:23 PM

avatar image Steve Hardister ♦♦ STAFF Nov 24 '14 at 07:48 PM

This issue has been fixed for a future release of UE4.

avatar image DamirH Apr 15 '15 at 11:40 AM

I am afraid I am experiencing it in 4.7.3. :(

avatar image DamirH Apr 15 '15 at 12:56 PM

Actually I was hasty. My source state had no animations defined yet, that's why this didn't show up.

avatar image assem12 Jun 09 '15 at 09:01 AM

where can i define source state animations?

i got this problem in 4.7.6

help me plzz

avatar image Matt.Williams Jun 10 '15 at 08:32 PM

Hi assem12,

DamirH simply meant that there were no animations set up in the state before the transition. When referring to a transition, there is a source state and a destination state. Source State --> Transtion --> Destination State.

There has to be an animation in the Source State to get a "time remaining" node for that animation in the transition.

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question