x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor rendering problems

The rendering in the editor is broken on my system. All text is rendered incorrectly like some problems with transparency and entire scene is black.

Screenshot: alt text

System Specs:

OS: Xubuntu 14.04 64-bit

CPU: Intel i5 4570

GPU: Intel HD 4600

Unreal Engine version: 4.5.0 compiled from GitHub with a small change to disable compatibility OpenGL profile as adviced in RCL's answer to Editor doesn't launch - Could not create OpenGL 3.2 context because without those changes the editor didn't even launch.

I attached the log but I didn't see anything suspicious there. Tell me whether you need any additional info.

Product Version: Not Selected
Tags:
bug.png (245.7 kB)
ue4.log.zip (7.1 kB)
more ▼

asked Oct 15 '14 at 07:11 PM in Bug Reports

avatar image

Strachu
81 3 4 8

avatar image SalahAdDin Sep 07 '15 at 03:35 PM

I have a similar problem with Ubuntu, but, my problem is that Editor's Viewport showme a black screen, when i do play for reproduce the game, showme all good.

Can anyone help me with this?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After some debugging, I have found what's the cause of the problem.

During rendering of the text the engine calls OpenGL 4 function to set the blending mode, while my driver supports only OpenGL 3.3, thus the call is ignored.

The easiest workaround I have found is to:

  1. Open /Engine/Source/Runtime/OpenGLDrv/Public/OpenGL4.h

  2. Find the line with glBlendFuncSeparatei(Buf, SrcRGB, DstRGB, SrcAlpha, DstAlpha); (currently it's line 27)

  3. Replace it with glBlendFuncSeparate(SrcRGB, DstRGB, SrcAlpha, DstAlpha);

  4. Recompile the editor

After doing these steps, the text looks normal, but there is possibility that this fix has some side effects, but at least the editor is now usable.

As for the problem with black scene...

It does not occur in every scene (in the screenshot from the question is an unmodified vehicle template). It is a problem with some effect (probably using some unsupported instructions - it would be nice if the effect was automatically disabled when unsupported instead of making the entire scene black).

After changing the effects setting to medium at Settings->Engine scalability settings the scene is not black anymore. The problem with black scene occurs at both high and epic settings.

more ▼

answered Oct 16 '14 at 08:29 AM

avatar image

Strachu
81 3 4 8

avatar image Strachu Nov 12 '14 at 02:25 PM

After updating the driver to a new version, above workaround is not required anymore, seems like relevant OpenGL extension for this function has been added to the driver.

The problem with black scene has also been fixed with new version of graphics driver.

avatar image RCL STAFF Nov 12 '14 at 11:13 PM

Thanks for letting us know. What version is that driver?

avatar image Strachu Nov 13 '14 at 08:54 AM

It's Mesa 10.3.0 coming from "Intel(R) Graphics Installer".
Previously it was Mesa 10.2.2, also from intel's installer.

This bug from Mesa bugtracker seems to be related to this: https://bugs.freedesktop.org/show_bug.cgi?id=78716 it's listed on 10.3.0 release notes.

I have attached the output of a glxinfo command in case more info is needed.

[1]: /storage/temp/20991-glxinfo.txt

glxinfo.txt (17.7 kB)
avatar image SalahAdDin Sep 07 '15 at 03:52 PM

I have a similar problem with Ubuntu, but, my problem is that Editor's Viewport showme a black screen, when i do play for reproduce the game, showme all good.

Can anyone help me with this?

I'm using the latest oficial repository drive man, and the latest mesa drivers.

avatar image Doug E ♦♦ STAFF Oct 05 '15 at 06:56 PM

Hey SalahAdDin-

Are you still having issues with the editor viewport appearing black? Is the viewport black when creating a new First Person Template project? Let me know if you think of any additional information that may help me reproduce this on my end.

avatar image SalahAdDin Oct 06 '15 at 03:42 AM

Yes, i'm having this issues again, in the 4.9 version. This happen when i put -opengl4 in the launching command. Isn't matter the project's type, ever put a black screen viewportt's editor. I solved this partialy with the fix that say me, but i think that for the next release will be better fix this problems and optimize the Linux performance( memory and graphic, i don't know why but FPS see poor than TP).

Yes, i'm having this issues again, in the 4.9 version. This happen when i put -opengl4 in the launching command. Isn't matter the project's type, ever put a black screen viewportt's editor. I solved this partialy with the fix that say me, but i think that for the next release will be better fix this problems and optimize the Linux performance( memory and graphic, i don't know why but FPS see poor than TP). alt text

alt text

alt text

alt text

avatar image SalahAdDin Oct 06 '15 at 03:57 AM

Can you see in the next image a few problems with FPS? The cross-air is wrong, isn't in front of the weapon and the bullets, is a bouncy ball, doesn't shot in the cross-air direction exactly, but, i think that the reason is because a bouncy ball.

The other problem is that the boxes haven't colider boxes, the balls pass through the boxes, but when i shoot to the group of boxes, this groups break out and the boxes shoot out, it's freak. alt text

alt text

alt text

alt text

avatar image Doug E ♦♦ STAFF Oct 06 '15 at 02:25 PM

Hey SalahAdDin-

Thank you for the additional information. Actually the -opengl4 command is a known issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question