x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UV Movie module, cant randomize my frame rate

Hi there,

So in my emitter which has a SubUV texture (2x2 frames), i,m attempting to have random starting frame (set to 0), and a random frame rate setting the distribution to uniform values, yet whathever i do it just starts flickering the frames fast and flickery even if i set values like max 1 min 0, it just goes super fast still not going for the values i enter.

Also tried to have a curve, they the rate of the frames wont change through time, they play the animation repeatedly and repetitively no matter what values i play with in the curve.

here is my current curve setting for example alt text

Is this possible? are this features working properly?

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Oct 15 '14 at 07:38 PM in Bug Reports

avatar image

Bruno_G
51 14 26 30

avatar image Bruno_G Oct 15 '14 at 08:14 PM

Also just realized that setting 0 as starting frame wont randomize the animation starting frame either :(!

avatar image Lovecraft_K ♦♦ STAFF Oct 15 '14 at 08:52 PM

Hey Bruno_G -

In your Material replace the Particle Sub UV with a normal Texture Sample using the same SubUV texture. This will solve the problem.

Thank You

Eric Ketchum

avatar image Bruno_G Oct 15 '14 at 10:15 PM

It does not :(

I did that exact thing you told me, now frames dont blend into each other, nor display random starting frame. I cant go for uniform frame rate still, they do the same issue i had when they just flicker fast. And random starting frame by setting it to 0 like it says does not work either. Under requirements, under the SubUv options i went for Random Blend...not luck either. i mean the most obvious features which describe what i want to achieve dont work and mess up one or other thing :(, frustrating....for such simple endeavor like this :(.

here is the effect along with the issues i,m having if you wanna try:

https://answers.unrealengine.com/questions/117450/need-advice-for-an-example-particle-i-have-here.html

avatar image [Epic]homeRye STAFF Oct 20 '14 at 07:05 PM

You want to use a uniformDistribution with the min set to your start frame, 0 and max set to your end frame, 3. Make sure you are using a particleSubUVTextureSampler and not a standard texture sampler node in your material network.

avatar image Bruno_G Oct 21 '14 at 08:42 PM

I am using a Sub Uv texture Sampler.

Eric Ketchum told me to replace the Particle Sub UV with a normal Texture Sample using the same SubUV texture....didnt work.

This is my material screen http://i.imgur.com/XkToeD7.png

Plus setting it to uniform within the UV movie module wont blend them either

avatar image Lovecraft_K ♦♦ STAFF Oct 22 '14 at 08:18 PM

Hey Bruno_G -

Still working on your example setup, but this particular issue is working. I believe your problem is the sampling size of your frames and their similarity. I have attached a modified version of your effect with an exaggerated example of the Sub UV Movie module working.

link text

Thank You

Eric Ketchum

avatar image Bruno_G Oct 22 '14 at 11:22 PM

Ok lets see what i can rescue from this response:

I checked your example effect, the random initial frame seems to work, not the blending, therefore this isn't entirely helpful for my case.

How did you got that random initial frame working? I,m not sure, your input was: 'I believe your problem is the sampling size of your frames and their similarity' which does not help me acknowledge much. Whats wrong with the size? Whats wrong with the frame's similarity? they are meant to look similar but they are NOT the same they are meant to blend from one frame to the next so it doesn't look jerky.

Eric what i,m trying to achieve is the BLEND, so random textures...fine, but they would need to blend from one frame to the next otherwise its looks poppy and bad. Blending only seems to work within the Linear Blend setting yet i need a RANDOM setting but WITH blend, so i though it would be Random Blend but this one wont blend the frames into the next but just pop the next one in.

The reason why i,m using 2x2 SubUv textures is because i want to use small simple SubUv textures that can just loop with blend and still look good. But anyhow, no matter how simple the texture would be and the few frames it would have, the overdraw issue is MELTING our tester's fps at the moment. This is all within CPU particles since GPU don't seem to have UV settings.

avatar image Bruno_G Oct 23 '14 at 12:10 AM

So in the case of a lingering smoke with the setting you sent, it wont work because even if they show randomly the smoke animation will not blend the frames to the next one so it will look bad and it will flicker. So smoke can never look good like that, and dust/smoke animation will look terrible without blend and with few frames like in this case, and this is supposed to be a next gen engine.

How is my problem withing the 'size' of my texture? whats wrong with it?

Problem with similarity? SubUv textures must have similar size frames. In the case of my texture the smoke puff frames look similar but they are not, they are suppose to loop from one frame to the next ij order too look like they are lingering.

Again, the blending is not there Eric. Again i,m gonna go ahead and just say this feature does not work currently? Or at least I still don't have a simple comfortable way to set this up, and i,m gonna ask: Why do you have a "Random BLEND" feature at all if its not gonna blend the frames at all like in the Linear Blend option?

I still don't have a clear response nor solution. This seems very unintuitive and features don't work as its said to work so how many users will find this frustration?

Sorry to sound kinda harsh but i,m starting to get really worried about my project's FX :( , i feel so stagnated with all these complications :(

Hope you could understand, hopefully all of this can be improved in the next Cascade iterations.

avatar image Bruno_G Oct 15 '14 at 10:13 PM

It does not :(

I did that exact thing you told me, now frames dont blend into each other, nor display random starting frame. I cant go for uniform frame rate still, they do the same issue i had when they just flicker fast. And random starting frame by setting it to 0 like it says does not work either. Under requirements, under the SubUv options i went for Random Blend...not luck either. i mean the most obvious features which describe what i want to achieve dont work and mess up one or other thing :(, frustrating....for such simple endeavor like this :(.

here is the effect along with the issues i,m having if you wanna try:

https://answers.unrealengine.com/questions/117450/need-advice-for-an-example-particle-i-have-here.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Bruno_G -

Remove the SubUV Movie from your Module list and add a SubUV Index module and set to a Uniform Distribution of Min 0 Max 3. (Takes care of the random start location) In the Required Module >> SubUV change the Interpolation Method Mode to Random Blend and change the Random Image Changes to 4. (Should address the random play blending you are after).

Eric Ketchum

more ▼

answered Oct 23 '14 at 03:45 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image Bruno_G Nov 08 '14 at 03:23 PM

It wont work with gpu particles :(, Random nor random Blend Interpolation method :(.

I need it to be gpu since its flying debris, so i,m looking to have collition (wtich only works withing gpu particles) and display random patricle textures through a Uv flipbook.

Will this be addressed in the next iteration of Cascade?

Thanks

avatar image Lovecraft_K ♦♦ STAFF Nov 10 '14 at 02:54 PM

Hey Bruno_G -

I've put in a request for our engineers to look into a way to implement this feature, for reference it is UE-5219. I will keep you informed as we investigate this feature

Thank You

Eric Ketchum

avatar image Bruno_G Nov 10 '14 at 04:55 PM

Oh fantastic thanks Eric! yeah it will be very useful for debris, sparks and other natural phenomena. Also in general it will be great to be able to manage this more easily in the future.

I wrote a request list with all my stubborn hindrances i,m having with Cascade:

https://answers.unrealengine.com/questions/130962/requests-for-next-iteration-of-cascade.html

Hope it can improve in the future, I've heard you guys are developing something like Cascade 2.0 or Niagara?

Thanks again, cheers

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question