x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Main menu on shooter demo not visible

Hello,

I am using 4.5 on a mac, downloaded the shooter demo and opened the "ShooterEntry" map. and the menu is not visible, I downloaded this project on older versions of the editor and I remember there used to be a menu where the player could select play, join, host game, etc.

Why is this no longer working ?

This is what I see when I run the "ShooterEntry" map:

alt text

Product Version: Not Selected
Tags:
more ▼

asked Oct 16 '14 at 08:55 AM in Using UE4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Jun 02 '15 at 02:15 PM by Ben Halliday for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

Hey Titirez5,

If you package the game and play the resulting .exe, the menu will show up. That menu doesn't show up when Launching through the Editor. I checked in 4.3 and 4.4 as well as 4.5, and it seems that's always been the case. Were you seeing something different in earlier versions? If so, what method were you using to play the game?

more ▼

answered Oct 16 '14 at 07:53 PM

avatar image blueshifted Oct 16 '14 at 08:08 PM

IIRC you couldn't see a menu there in older versions, I think I tried once.

When you open the ShooterGame solution with Visual Studio there's actually a "ShooterMainMenu.cpp" and "ShooterMainMenu.h".

I think they did the menu in C++.

To create a Visual Studio file of the ShooterGame Example, navigate to your UnrealProjects folder, right click the uproject file and click "Generate Visual Studio project files". Then open the ShooterGame.sln.

avatar image disabled_Titirez_5 Oct 17 '14 at 09:15 AM

You might be right, maybe it was a build I saw this in, and not the editor, it was a while ago... This makes it even more difficult to follow the multiplayer logic from this demo. While running the project from the IDE you could at least add some logs and put some breakpoints.

avatar image marksatt-pitbull STAFF Oct 17 '14 at 01:58 PM

Titirez5, in Xcode, go to the project selection drop down and open it. Select ShooterGameEditor. Then re-open the same drop down and go all the way to the bottom and select Edit Scheme... Then select Run > Arguments & add an extra argument to the list: -game Then build & run. The editor will run from Xcode in 'game' mode and allow you to debug the menu flow.

avatar image Heoki Dec 04 '14 at 02:30 AM

Does anyone know what steps need to be taken in order to fix this to work in the editor?

avatar image Ben Halliday STAFF Dec 04 '14 at 08:11 PM

Hi Heoki,

The steps listed above should let you debug the menu flow. Have you tried that yet?

avatar image Heoki Dec 05 '14 at 02:16 AM

I'm not sure, I am using visual studio so those exact steps wont work but I can load up the game to test the menu flow but it would be more convenient if I could do it by just loading up the level in the editor.

avatar image Ben Halliday STAFF Dec 16 '14 at 10:56 PM

Hey Heoki,

Being a C++ project, ShooterGame is going to have some things that are not conveniently tested in the editor. When debugging through VisualStudio or Xcode, you'll be able to test the menu flow.

avatar image Deni35 Apr 16 '15 at 04:07 PM

I also have this problem on v4.7.5. Why does EpicGames still not fix this bug? This is strange.

avatar image HuntaKiller Jun 02 '15 at 10:17 AM

I agree, I'm having the same problem of not being able to see the menu. I just want to follow the logic for how the gamemode, gamestate, and hosting/joining work, as well as some menu features. It's a shame you need to track down tutorials to get the tutorials to work

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question