Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Media Player: packaged project only working on packaging machine?


Seems the media player only support absolute path, cause copy the packaged project to another machine the media player won't work, only see a blank black....

How to fix this?


Product Version: Not Selected
more ▼

asked Oct 16 '14 at 09:10 AM in Bug Reports

avatar image

106 9 15 22

avatar image [Epic] Gribbs ♦♦ STAFF Oct 16 '14 at 04:47 PM

Howdy alonezhby,

Thank you for reporting this issue. Can you please attach your DXdiag and your project log files to this post? Also, would there be a step by step way that I may be able to reproduce this issue internally?

Any information would be greatly appreciated.

Thanks and have a great day!

avatar image alonezhby Oct 17 '14 at 04:15 PM

Hi Sean Gribbin,

Thank you.

The step is: 1. Use the "Import" button in CB to import a video(seems only .wmv file can work), then add it to level UMG UI or a mesh, it can play in editor, but packaged the project, it won't work. 2. Use windows explore to drag and drop a video to CB, then add it to level UMG UI or a mesh, it can be played in editor, packaged the project , it will work too, but when you copy it to another machine, it won't work again.

Here is the logs: link text

btw, I seems found another bug: if you reimport the same video from another folder into CB, the previously created Media Texture won't update anymore, you have to select the Media Player recreate it...

Thanks and have a great day!

avatar image SpdPoland Oct 08 '15 at 10:04 AM

I resolved this problem on my project. open Media Player asset and in Source> File or URL path, check do you have ONLY ONE DOT at the beginning. like example "./Movies/examplemovie.mp4". Hope this helps. Works on 4.9.1

avatar image TorQueMoD May 26 '16 at 09:10 PM

If I try to change the path inside the media player it does not let you. It always adds an absolute path. How did you change yours?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

I have solved it for me, first i converted my movies to mpeg4 (not mp4 ore wmv) then i put them in the map Movies if you dont have a videomap just make one in content. then open the level bleuprint,make a variable mediaplayer reference then compile,then in the details of the variable choos your mediaplayer asset that you made in the moviefolder,insert the variable to the event graph (Get) and then drag of from the variable and type in play then connect it to event begin play and your done it wil cook now with your game.

I hope this will help it did for me Sry for the bad english.

more ▼

answered Feb 14 '16 at 01:02 PM

avatar image

46 1 1 2

avatar image AndrewHurley Feb 16 '16 at 02:26 PM

Thanks for the info 2forallgames,

Could you provide us with some screenshots accompanying your steps to better help users visualize and understand your process.


Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Howdy alonezhby,

So I have dug deeper into this issue and have found that at this is currently not a bug. It just has not been implemented into the Engine yet. Here is a link to he forum post of where I found this information: https://forums.unrealengine.com/showthread.php?46879-Media-Framework-Documentation-for-4-5-Preview.

In the first post on this thread, in the very last section, this should clear up any issues that you may be seeing.

Thanks and have a great day!

more ▼

answered Oct 17 '14 at 06:34 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Did you put your media files into the /Content/Movies directory? If they're not in there, the game won't package correctly and require absolute paths. I've managed to package a game with video files without problems when the videos were contained in the correct directory! :)

more ▼

answered Feb 15 '15 at 10:23 PM

avatar image

212 5 9 18

avatar image alonezhby Feb 16 '15 at 08:48 AM

Yes, I did. Did the packaged game work well on another computer?

But, seems it require absolute path.

avatar image Sephern Feb 27 '15 at 10:54 PM

I've had the same problem. It is an absolute path even in 4.7.1. Hopefully we will get a fix for this soon.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello all,

I was looking into this issue not long ago for some other users as well, and created a bug report. Have a look over the post to see if there is some additional information you might be able to pull from there as well.

I have created a bug report that is related to this issue of Relative and Absolute paths in a packaged project.

Media Asset Post


We are working to have this issue resolved in upcoming versions of the Engine. We appreciate your patience with this issue as it is a fairly new feature and is still being improved.


Andrew Hurley

more ▼

answered Mar 05 '15 at 11:39 PM

avatar image Sephern Mar 09 '15 at 03:46 AM

It works in 4.7.2! Thank you!

avatar image Pyronious May 22 '15 at 11:20 PM

We're still having trouble in 4.7.5 - works in editor but not in cooked standalone. Are you using relative or absolute path? What movie format? Any details appreciated. Thanks!

avatar image dmx Nov 19 '15 at 10:51 PM

After a million years UE still not working with media texture, when exactly you will be able to make this thing working? UE cant import a damn movie and play it. Will there be any solution soon?

avatar image AndrewHurley Nov 20 '15 at 03:50 PM

What type of media file are you using?

avatar image TorQueMoD May 26 '16 at 08:59 PM

I'm having the same issue. I ad originally imported my media files to a folder named "Videos" I since used the move command to move them into "movies" along with my start up videos that work fine and they still won't show on another system.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I discovered a work around to fix the paths. Firstly make sure your video is 1280x720p mp4 video encoded with .h264. Any other format will not work properly.

Add the video to your Movies list under project settings.You will see a warning in the bottom right that says "Processing source file changes". This will import the video to the Movies folder (and create the folder for you) and you will see a Media Player file with the same name as your video inside the content browser.
alt text

Next click on the down arrow to the right of the newly added movie and choose delete - the reason for this is it will play as a startup video when you launch the game if you don't delete it.

Now open Windows Explorer and copy and paste the mp4 into your newly created Movies folder in the Content directory. Example C:\MyDocuments\Unreal Projects\YourProjectName\Content\Movies Make sure you do not rename the video otherwise the file linking won't work.

After manually copying the video into the Movies directory, you can double click on the Media Player file in the Content Browser and you should see that the file name now looks like "./Movies/NameOfYourVideo.mp4"

Your video will now show up when you build your project and will play correctly on every computer.

more ▼

answered May 26 '16 at 10:27 PM

avatar image

1.2k 86 116 146

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question