x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

The "Hollow" BSP ability breaks my geometry

Trying to develop a series of rings, I create cylinders with the "Hollow" geometry setting checked. The below images are the results: alt text

More importantly, any other BSP that intersects these rings get corrupted with faces missing and even after deleting the rings, the BSP remains corrupted. After turning "Hollow" off and rebuilding geometry, my engine crashed.

Product Version: Not Selected
Tags:
ringbug.jpg (752.3 kB)
more ▼

asked Oct 16 '14 at 04:20 PM in Using UE4

avatar image

Liforce
6 5 7 10

avatar image Liforce Oct 16 '14 at 04:23 PM

Another strange bug: After restarting the editor, Unreal asked if I wanted to restore the unsaved level. I hit "Yes" but got an error message that Unreal couldn't load it. What it did load, was the level minus all the bugs.

avatar image Jonathan Dorman STAFF Oct 17 '14 at 09:56 PM

I'm not seeing this behavior when creating Hollow geometry in 4.4.3 or 4.5. To be clear, these are the steps I'm taking:

  1. Drop two additive cylinders from the BSP menu into the level.

  2. Select both cylinders.

  3. Click the 'hollow' checkbox in the Details panel.

Are you doing something different?

avatar image Liforce Oct 17 '14 at 11:53 PM

It's not the hollowing, but unhollowing that causes issues.

  1. Add two additive cylinders from BSP menu into the level

  2. Select both cylinders

  3. Click hollow

  4. Build Geometry

  5. Click unhollow

  6. Build Geometry

avatar image Jonathan Dorman STAFF Oct 21 '14 at 06:16 PM

I'm still having no luck reproducing this issue (tried in 4.4.3, 4.5) by following your steps precisely.

What version of the editor are you using?

avatar image Liforce Oct 21 '14 at 07:21 PM

Version 4.4.3

avatar image Jonathan Dorman STAFF Oct 21 '14 at 08:01 PM

Do you have any other ideas about what might be causing the problem? I've tried following your steps in 4.4.3, with Update BSP Automatically on, and then with it off, and neither caused anything out of the ordinary.

avatar image Liforce Oct 21 '14 at 08:05 PM

I've been following the same steps to repeat my issue. Maybe there is a hardware difference where my computer can't process the geometry?

avatar image Jonathan Dorman STAFF Oct 21 '14 at 08:17 PM

That's possible. Do you find this same thing happens in a new project?

If you wouldn't mind, send me your dxdiag, as well.

avatar image Liforce Oct 21 '14 at 08:27 PM

I can't get the issue to duplicate consistently in new projects. How do I upload the Unreal dxdiag?

avatar image Jonathan Dorman STAFF Oct 21 '14 at 08:50 PM

The dxdiag is a windows utility, not something related to Unreal. On Windows 7, you can just type 'dxdiag' in the Start menu and run it, then Save All Information.

avatar image Jonathan Dorman STAFF Nov 04 '14 at 06:57 PM

Are you still having trouble with this, Liforce?

avatar image Liforce Nov 04 '14 at 07:03 PM

I can no longer duplicate the issue.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Since the issue is not reappearing, I'm marking this question as Resolved. Let me know if the issue reappears and we'll investigate it further.

Thanks,

Jonathan

more ▼

answered Nov 04 '14 at 07:11 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question