x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Ragdolling replication broke for me in 4.5

Hi! I ported our game from 4.3 to 4.5 and a few things broke that were fairly easy to fix, however i cannot wrap my head around why ragdolling broke the way it did for me. Whenever we ragdoll the client cannot see other players ragdoll where they are but instead see them teleport to 0,0,0 to ragdoll there. However the server sees both itself and the clients ragdoll just fine. here is a screenshot of what im talking about. This worked fine for me in 4.3

alt text

Thanks in Advance!

Product Version: Not Selected
Tags:
more ▼

asked Oct 17 '14 at 08:57 AM in Bug Reports

avatar image

DwunkyPengy
171 5 9 12

avatar image TJ V ♦♦ STAFF Oct 17 '14 at 07:17 PM

Hi DwunkyPengy,

I attempted to reproduce your issue but I can't get your results. Can you reproduce this in a template or one of our projects like Shooter Game?

I'm going to reference another user with this issue here as well.
https://answers.unrealengine.com/questions/117608/45-client-side-physics.html

avatar image TJ V ♦♦ STAFF Oct 27 '14 at 04:51 PM

Hi DwunkyPengy,

We haven't heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you're still experiencing this issue, please feel free to post back here with additional information.

Thanks,

TJ

avatar image zgjames Oct 29 '14 at 10:04 PM

I am having the same precise issue. The owning client and server display the ragdoll properly but any others teleport the ragdoll to the 0 point of the map (and it doesn't seem possible to move it away from this point via a blueprint.

Ive also noticed that if I just disconnect a skeletalmeshcomponent with a detach from parent node the same behavior occurs where it becomes stuck at the 0 point on non owning clients.

avatar image DwunkyPengy Oct 29 '14 at 10:08 PM

ya i'm piggy backing on https://answers.unrealengine.com/questions/117608/45-client-side-physics.html , hopefully we can figure out a fix :O

avatar image zgjames Oct 29 '14 at 10:28 PM

I just tried to reproduce in a new third person template project and I couldn't even though my current project (where the bug does occur) initially started as a third person template and isn't that different. I'm trying to find any differences between the two but no luck yet.

avatar image greynz Oct 31 '14 at 07:11 AM

Not sure if it helps, but I'm having this issue too. I had other problems when I updated to 4.5 (couldn't package) so I made a fresh 4.5 project and ported my assets over to it. The ragdoll problem still persists in the fresh project. I'm going to attempt to rip out the old ragdoll code and reimpliment it exactly, i'll let you know if that fixes it.

avatar image greynz Oct 31 '14 at 07:46 AM

Ok so after some tests, I still haven't found anything useful, but here are some things I tried (none of them yielding results)

  • New mesh / skeleton / physics asset I reimported an fbx fresh and setup a quick physics asset for it, everything was the same.

  • New blueprint system I tried ripping out my old blueprints that caused the ragdolling and it didn't work

  • Different character I made a fresh character blueprint and implemented new blueprints to make it ragdoll, still no results..

keep in mind that this was all done within a fresh 4.5 project with assets that were migrated over.

Tomorrow I think I might try implementing a function in C++ that ragdolls and will see if that works. If not, i'm at a loss here.

avatar image zgjames Oct 31 '14 at 05:11 PM

I haven't found anything either even though I completely changed my ragdoll code (for a separate reason). It would really be nice to get some feedback from Epic here so we at least now the issue is being looked at.

avatar image Nesjett Nov 19 '14 at 08:04 PM

I found some kind of fix, you have to set the mesh component to replicated, I do that on the constructor script of the actor, this way atleast the mesh doesnt move to 0,0,0, but it still has problems

avatar image TJ V ♦♦ STAFF Nov 24 '14 at 05:53 PM

Hi everyone,

Have you tried this in the 4.6 preview yet to see if it is still an issue for you?

avatar image DwunkyPengy Nov 24 '14 at 07:58 PM

I'm actually completely rebuilding our project in 4.6, so once I get to ragdolling I'll let you know ;P

avatar image Sahkan Nov 25 '14 at 08:00 PM

Is there anything new about it ? I'm having the same issue. I'v found that if i make the blueprint like in this picture, the character will turn into ragdoll where it should, however it will be glitchy as hell and it will shake and rotate and w/e like he is suffering or something lol. alt text

capture.jpg (50.6 kB)
avatar image TJ V ♦♦ STAFF Dec 01 '14 at 09:01 PM

Hi everyone,

We are still looking into this, I just need to take a quick poll. For everyone that is having this issue, is your Ragdoll Replication being done in code or through blueprints?

avatar image DwunkyPengy Dec 01 '14 at 09:09 PM

Blueprint for us :D

avatar image Sahkan Dec 02 '14 at 04:45 AM

Blueprint!

avatar image Rama Dec 02 '14 at 05:06 AM

I've done both C++ and blueprints

The issue is universally present!

It must be a lower level issue.

I gave you a utterly simple C++ repro project here where I reproduce the issue quite easily.

https://answers.unrealengine.com/questions/128514/451-i-had-to-revert-to-43-again-set-simulate-skel.html

avatar image TJ V ♦♦ STAFF Dec 02 '14 at 04:00 PM

Hi everyone,

I just wanted to let you all know that we have created JIRA UE-6128 and our developers are looking into this issue. We will post back here as soon as we have something.

Cheers,

TJ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'v solved it !!! All you need to do is to destroy the movement component and disable replication before starting the physics simulation. all the clients will see the ragdoll and you too and it will works great ! I'm so proud of myself :") alt text

more ▼

answered Dec 04 '14 at 03:08 PM

avatar image

Sahkan
224 10 19 25

avatar image TJ V ♦♦ STAFF Dec 04 '14 at 05:15 PM

Hi everyone,

I just tested Sahkan's workaround and it does correct the issue. In the meantime our developers will be looking into this further and we will post back here when we have something.

Cheers,

TJ

avatar image zeroexception STAFF Dec 05 '14 at 09:09 PM

I just submitted a code fix, CL 2378178.

There is network smoothing code in CharacterMovement that sets the relative location of the mesh each update. I think this broke when the mesh is detached (when simulating physics), so that relative location now becomes a global location, usually close to the world origin.

A simpler workaround than the proposed one (though that helped me narrow it down, so thanks for that!) is to just SetComponentTickEnabled(false) on CharacterMovement before the ragdoll (this disables the code in question). Or if you have C++ code you can override UCharacterMovementComponent::SmoothClientPosition() with my new code, which basically does nothing if the mesh is simulating physics.

-Zak

avatar image Bluarchon Dec 15 '14 at 08:05 PM

How would one disable the movement component tick via Blueprints?

avatar image fanzypantz Mar 14 '15 at 10:36 PM

this has to be run at the server right? because I have tried doing all the workarounds and I can't get it replicated. Is it broke again?

avatar image TJ V ♦♦ STAFF Mar 16 '15 at 01:57 PM

Hi fanzypantz,

I just tested this in 4.7.2 with this setup and it is working:

alt text

Give it a try and let me know if it works for you or not.

Cheers,

TJ

ragdollrep.jpg (60.7 kB)
avatar image Samuelb Jul 27 '17 at 11:24 AM

Holy crap TJ!!

This just fixed alot of my issues i was having thank you so much! You Rock

-SamuelB

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question