x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lighting not rebuilding '[Interface:OpenJob] Error: A 32 bit processes cannot access modules of a 64 bit process.'

Similar to this problem (in fact, the logs are identical);

https://answers.unrealengine.com/questions/61591/lighting-not-rebuilding-swarm-error-a-32-bit-proce.html

Just moved over from UDK, where Swarm Agent worked, but If I re-call, I had to run UDK in 32-bit mode in order for it to work with Swarm Agent (I can't remember, UDK is still on my machine so If there's anything I need to check there, I can.) My machine is 64-bit however.

Here's the SwarmAgent logs;

 2:28:13 PM: Starting up SwarmAgent ...
 2:28:13 PM:  ... registering SwarmAgent with remoting service
 2:28:13 PM:  ... registering SwarmAgent network channels
 2:28:14 PM:  ... initializing SwarmAgent
 2:28:14 PM:  ......... certificate check has failed
 2:28:14 PM:  ...... initializing cache
 2:28:14 PM:  ......... using cache folder 'C:/Users/Mark/AppData/Local/UnrealEngine/4.5/Saved/Swarm\SwarmCache'
 2:28:14 PM:  ......... recreating SwarmAgent cache staging area
 2:28:14 PM:  ...... initializing connection to SwarmCoordinator
 2:28:14 PM:  ......... using SwarmCoordinator on RENDER-01
 2:28:17 PM:  ......... SwarmCoordinator failed to be initialized
 2:28:17 PM:  ...... initializing local performance monitoring subsystem
 2:28:19 PM:  ... initialization successful, SwarmAgent now running
 2:28:25 PM: [Interface:TryOpenConnection] Local connection established
 2:28:25 PM: [Interface:OpenJob] Error: A 32 bit processes cannot access modules of a 64 bit process.
 

It's a clean install of UE4, I only installed it yesterday and have begun working on a quick project to test it out, and thus this has occurred.

Any help would be appreciated, I'm at a real loss what to do here!

Edit: Just providing some more information to see If it can help.

Here's my .NET Framework version, as shown in CP. alt text

Here's my DxDiag output;

link text

Product Version: Not Selected
Tags:
dxdiag.txt (38.6 kB)
more ▼

asked Oct 18 '14 at 01:34 PM in Bug Reports

avatar image

MarkyUK
1 2 4 6

avatar image Lovecraft_K ♦♦ STAFF Oct 24 '14 at 07:22 PM

Hey MartyUK -

A couple of other thigns to try out:

1 - Increase your virtual memory allocated to windows. (http://windows.microsoft.com/en-us/windows/change-virtual-memory-size#1TC=windows-7)

2 - If that doesn't work you may also want to try deleting (or making - both have worked for different users) teh Swarm Cache folder which is in the \Unreal Engine\4.5\Engine\Binaries\DotNET\Swarmcache

I am talking with some of our engineers now to try to debug this issue.

Thank You

Eric Ketchum

avatar image MarkyUK Oct 25 '14 at 12:30 PM

Still not working, did both.

I didn't have a Swarmcache folder, so have created one.

Still getting this error;

 1:28:31 PM: [Connection] Detected new local connection from same process ID as an existing one, closing the old one
 1:28:31 PM: [CloseConnection] Closing connection 107B7ED5 using handle 107B7ED5
 1:28:31 PM: [CloseConnection] Connection confirmed for disconnection 107B7ED5
 1:28:31 PM: [CloseConnection] Closing orphaned Job ()
 1:28:31 PM: [CloseConnection] Connection disconnected 107B7ED5
 1:28:31 PM: [Interface:TryOpenConnection] Local connection established
 1:28:31 PM: [GetMessage] Safely returning to 107B7ED5 with no message
 1:28:32 PM: [Interface:OpenJob] Error: A 32 bit processes cannot access modules of a 64 bit process.
 1:28:32 PM: [MaintainConnections] Local connection has closed (107B7ED5)
 1:28:32 PM: [MaintainConnections] Removed connection 107B7ED5
 
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey MartyUK -

My apologizes for not getting back to you sooner. Let me run through a few different options to try to get you back up and running again. Try each of these separately and in order and please if you still have an issue or you find a particular step helped you fix it let me know -

1 - Go to your Swarm Cache Folder Location (there are possible two) and delete them:

Location One: C:\Users[UserName]\AppData\Local\UnrealEngine[VersionNumber]\Saved\Swarm\SwamCache

Location Two: [Unreal Install Directory]\[version number]\Engine\Binaries\DotNET\SwamCache

Your engine will rebuild these directories on the next launch and hopefully solve your problems.

2 - Temporarily Disable any Antivirus Software that may be running.

3 - Does your CPU have a Name which begins with a number, if so rename to have at least one letter at the beginning.

4 - Does your Windows Folder Paths (like those referenced above) contain any non-Latin Characters? If so change them to remove those characters.

5 - Increase the Virtual Memory allocated to your machine from Windows.

Thank You

Eric Ketchum

more ▼

answered Oct 30 '14 at 06:26 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 735

avatar image MarkyUK Oct 30 '14 at 08:16 PM

1 - Failed, same error. It didn't recreate the folder in Location One (it did exist before hand). Note: My UE4 installation isn't on my C drive, but my G drive (my 2nd partition).

2 - I don't use any apart from the standard Microsoft stuff to scan for viruses (it's not enabled permanently anyway).

3 - Sorry you've lost me. My CPU is an Intel i5-2500k, I don't quite know how I 'name' it.

4 - None at all, just that UE4 isn't installed on C;

5 - I did that last time, and I did it on both C and G (my 2nd partition) to no avail.

Can include full logs if you feel they would be helpful (from the SwarmLogs).

avatar image Lovecraft_K ♦♦ STAFF Oct 30 '14 at 08:59 PM

Hey -

The CPU name is the actual name of your workstation not your CPU chip. Please do include your full logs as well as your engine logs from the project you were trying to build

Thank You

Eric Ketchum

avatar image MarkyUK Oct 30 '14 at 09:27 PM

In which case, I should be fine as my PC's name is 'Mark-PC'.

Here's both of the logs you asked for;

link text

link text

Thanks for the speedy responses.

avatar image MarkyUK Nov 06 '14 at 09:53 PM

The updates seem to be slowing again, are you still able to diagnose the problem with your engineers?

I am able to provide any log files from any program you need, just guide me through it!

It's a real pain not being able to utilize this Engine to it's full potential, and it'd be a shame to pick an alternative so early on.

Thanks.

avatar image Jarek STAFF Nov 07 '14 at 07:15 AM

Hi Marky, we'll definitely fix it, but for now we can't reproduce it as it happens in some special circumstances for just a few users.

The exception definitely is catched here UE4\Engine\Source\Editor\SwarmInterface\DotNET\SwarmInterface.cs in line Log(EVerbosityLevel.Critical, ELogColour.Red, "[Interface:OpenJob] Error: " + Ex.Message);. It would be great if you could change this line to Log(EVerbosityLevel.Critical, ELogColour.Red, "[Interface:OpenJob] Error: " + Ex.Message + "\n" + Ex.StackTrace);, rebuild the UE4\Engine\Source\Editor\SwarmInterface\DotNET\SwarmInterface.sln solution and resend the log after reproducing the bug. This will tell us more.

Thanks, Jarek

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey MartyUK -

Lets start with the most probably cause which is an error in the Swarm Agent's setup and or the DotNET setup. To clear up any possibly confusion make sure that the Swarm Agent from UDK is not started, not in the StartUp folder and not assigned to any Coordinator. Preferably uninstalled. Next you will want to do a clean install of the DotNET Framework. Here is the Microsoft website on how to do that, http://support.microsoft.com/kb/2698555

After you uninstall and then reinstall the latest version of DotNET, try building lighting again and let me know the outcome.

Thank You

Eric Ketchum

more ▼

answered Oct 21 '14 at 03:44 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 735

avatar image MarkyUK Oct 23 '14 at 03:34 PM

Hi Eric,

Same error-- UDK is still on my system but can't be interfering as it isn't launched or in any startup programs.

Reinstalled DotNET completely and even downgraded it to 4.5 offline version.

avatar image MarkyUK Oct 28 '14 at 02:17 PM

Could I get an update Eric?

I'm not able to do a great deal when I can't build my levels.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We've finally found it. The fix for this issue should be in 4.7 release. Hopefully it will work for you all.

Thanks, Jarek

more ▼

answered Dec 17 '14 at 08:10 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question