x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Line tracing and collision

Hey all,

Not sure if I put this in the right section, but I'm assuming this issue has to do with me being unfamiliar with the tools. Anyways, I have two actors, we'll call them A and B.

---- A has a sphereComponent on it, of which I'm trying to use as a trigger by setting it in the blueprint "collision" section, as well as using the "Generate Overlapping Events" property.

---- B is a camera that is always multi line tracing between two points using the ECC_Camera channel and returning all of the overlapping objects in it's hitResults. This part is in C++.

The issue: My sphereComponenet on A is returning in this trace, and I do not want it to. I want this trigger to be used for characters. How do I do this? I thought I simply set the collision information on this specific sphereComponent to ignore Camera and overlap everything else?

Thanks a bunch everyone. I hope you all understand what I'm trying to accomplish.

  • Austin

Product Version: Not Selected
Tags:
more ▼

asked Oct 19 '14 at 12:35 AM in Using UE4

avatar image

AustinK
215 22 18 28

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Try setting the sphere collision to ignore tracing and set its property to something like world dynamic, the set the camera collision to ignore world dynamic.

more ▼

answered Oct 19 '14 at 07:22 AM

avatar image

Alan Webster
860 50 34 81

avatar image AustinK Oct 19 '14 at 05:16 PM

I thought of that last night as I was going to bed! I'm glad you confirmed my thinking... It works.

Just in case others were thinking like me: My issue was I was under the impression that my A collision settings were telling B to ignore A. But both settings have to be set individually for each collision response. Settings for A only tell A how to handle collision events... settings for B don't care about A's settings, it only care's about it's own.

Thanks Alan.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question