x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Weird UMG Bug [4.5]

Hi, I guess I have a bug with UMG: I created a button and placed it. Now when I set an image in the style tab (any state normal/hovered/etc.), the thumbnail only gets the background color of the image and on the hud, it is broken (weird deformation).

All other buttons (added before 4.5) work properly. It is the Button itself, because every texture gets broken on it, and all textures work on the other buttons.

I made 2 pictures of 1 working and 1 broken button:

http://www.pic-upload.de/view-24976689/Screenshot-2014-10-19-11.00.12.png.html

http://www.pic-upload.de/view-24976690/Screenshot-2014-10-19-11.02.14.png.html

Product Version: Not Selected
Tags:
more ▼

asked Oct 19 '14 at 09:06 AM in Using UE4

avatar image

birdfreeyahoo
880 46 45 80

avatar image birdfreeyahoo Oct 19 '14 at 12:02 PM

I think I have the reason: When I scale the button down to 64*64, I see nothing When I scale it up to 128*128 like the image, I see the correct image.

avatar image birdfreeyahoo Oct 19 '14 at 12:35 PM

This is definitely a bug, because when I copy a "working" button, and paste it in my widget blueprint, then it works. Only creating new ones makes them broken.

avatar image birdfreeyahoo Oct 20 '14 at 09:08 AM

Can some developer tell me if this is a known bug?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I have the solution:

I compared the two Strings in my Clipboard and found that there is something missing:

Margin=(Left=0.000000,Top=0.000000,Right=0.000000,Bottom=0.000000)

is missing in the WidgetStyle section. Adding this works. Can it be fixed?

more ▼

answered Nov 10 '14 at 01:52 AM

avatar image

birdfreeyahoo
880 46 45 80

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question