x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Physics problem: Simulated actors go through others when they are nearer than 300 units aprox

Hi, I have set some physics simulated actors in scene and when they have little separation (less than 200-400 unreal units) between them they undesiredly go through other actors, even with BlockAll collision, Use CCD and other physics accuracy properties set up.

I thought it was velocity but after some tests with diferent start velocities it seems it's a distance issue.

Do you know how to avoid that simulated actors go through others when they are close at the start of the simulation?

Product Version: Not Selected
Tags:
more ▼

asked Oct 19 '14 at 04:17 PM in Using UE4

avatar image

Albert Espín
967 80 97 358

avatar image Albert Espín Oct 19 '14 at 05:55 PM

It's weird because now I've set them to go at a very fast start velocity and still go through one another if they are very close when the simulation starts; the going through seems to depend on distance and not on velocity.

Any ideas?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Solved: these actors used to be simulated with the click of a button so not at start up. If at the construction script of the actors they are set to be simulated and in a major gameplay blueprint like the gamemode they are set not to simulate 0.2 seconds after Begin Play the going through doesn't happen anymore once the simulate button makes them simulate, weird as it sounds.

This might be because of some sort of engine error, so I think Epic should check it out if they consider it could be that, although this hypothetical error might be difficult to locate.

more ▼

answered Oct 19 '14 at 09:39 PM

avatar image

Albert Espín
967 80 97 358

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question