x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Applying skeletal mesh to particle system in blueprint

Hello UE4-community!

I am working on my graduationwork for college, where I must make a real time seasonal system (4 seasons in 2 minutes). Now I am putting everything into 1 blueprint.

The problem that I am having, is that I can't apply a skeletal mesh to a particle system in my blueprint (while I CAN do it in my normal editor). If I select the skeletal mesh actor in the blueprint, it just doesnt do anything at all... (see picture below) ![alt text][1] This is a really big problem, since now I can't spawn leaves in my blueprint, or grass, or anything that needs a skeletal mesh...

Any help with this would be very welcome! [1]: /storage/temp/18388-problem.png

Product Version: Not Selected
Tags:
problem.png (1.3 MB)
more ▼

asked Oct 20 '14 at 09:27 AM in Blueprint Scripting

avatar image

Philty Dragonbreath
19 4 5 13

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hey Philty -

I did the exact same thing when I was learning how to set this behavior up, but you are over thinking it. The Blueprint itself is the actor of which the Skeletal Mesh is just a component. So for the Actor Parameter you will want to set the Blueprint as the Param Target. In order to do that you will want to Get a Reference to Self and plug it in just as you have in your first picture, like this:

alt text

Thank You

Eric Ketchum

bpselfrefernce.jpg (39.9 kB)
more ▼

answered Oct 22 '14 at 01:37 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 701 254 733

avatar image Philty Dragonbreath Oct 22 '14 at 01:53 PM

Oh, it works now! Another thing learned about UE4.

Thank you very much!

(comments are locked)
10|2000 characters needed characters left

Hey Philty -

You will need to use the Construction Script to Set Actor Parameter and have the target reference Self. (the actual Blueprint) as the skeletal mesh in the Blueprint is a component and not an actor but referencing the BP actor and assuming you have the correct skeletal Template in the Particle System it will work.

Thank You

Eric Ketchum

more ▼

answered Oct 21 '14 at 09:23 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 701 254 733

avatar image Philty Dragonbreath Oct 22 '14 at 09:25 AM

I tried to do it like you said, but he just won't accept the skeletal mesh...

alt text

untitled.png (60.5 kB)
avatar image Philty Dragonbreath Oct 22 '14 at 10:36 AM

Did it like this now, but still no go!

alt text

untitled2.png (247.8 kB)
(comments are locked)
10|2000 characters needed characters left

I have same problem

more ▼

answered Nov 27 '17 at 08:58 AM

avatar image

fool04
1 1

avatar image magnus.larsson Feb 04 '19 at 12:58 PM

I am also curious about this, specially if I have 2 or more skeletal meshes in my blueprint, how can I set a the particle system to only spawn from one of them ?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question