x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.5.1 Serious rendering issue

4.5.1 Serious rendering issue

Now i have a major problem ongoing, Ive updated all the test scene's to UE4 4.5.1 and can't go backwards but when i open my maps with 4.5.1 the following is what i get, It's all Kinds of messed up!.

When loading my old landscape scene's to update for my asset pack which was to sent of to Epic UK today (not going to happen now!) this is the problem i get. Should add the Epic landscape example is also doing the same thing.

Video of the graphic problems.

https://www.youtube.com/watch?v=XLIgskavAAk

Also 80% of my main terrains have no terrain texture applied, If you try to edit or add another the Editor locks up on me with the harddisk thrashing away and all memory in sight being consumed. Editor will not even allow you to close it, you have to go into task manager to force the application to stop but even then i wouldnt release the memory used. Had to restart windows.

Product Version: Not Selected
Tags:
more ▼

asked Oct 20 '14 at 05:01 PM in Rendering

avatar image

KingBadger3D
21 1 4 6

avatar image as3ef2th1 Oct 21 '14 at 03:41 PM

Same issues with the Landscape mountains example, and I'm still unable to fix it. Any idea where it comes from ?

avatar image Adam Davis STAFF Oct 21 '14 at 05:00 PM

Hi KingBadger3D,

Can you post a copy of your dxdiag here so I can take a look? Additionally, what scalability settings are you currently using and are you using heightmaps or have you created your terrain in editor?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi KingBadger3d,

We have not heard from you in quite some time. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please comment with the information Tim requested. Thank you.

more ▼

answered Oct 27 '14 at 08:31 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Adam,

Cheers for the help.

Dxdiag 32bit

Dxdiag 64bit

Yes im using height maps within the ditor terrain tool. Imported at 4096x4096 (well not exactly but the epic specified size close to 4096 but cant remember the number off the top of my head).

It does it for me even when loading the epic terrain example map as standard, so looks to me directly related to the terrain tool / terrain material system. In other scene's ive tested without terrain (using static mesh's for terrain i get no issues). Please get this sorted ASAP, I was supposed to be sending off my terrain assets for the market place on Monday, I need to make sales on this before the 14 November or i cant pay rent or bills and ill be evicted by 14th december. Been 4-5 months since i was contacted by Epic to sell these but it's been trouble non stop due to file size. Finally had this all ready to go and now all the terrain scene's are broken and can't be reverted backwards. GRRRR

Cheers J

dxdiag_32bit.txt (25.6 kB)
dxdiag_64bit.txt (37.4 kB)
more ▼

answered Oct 21 '14 at 08:38 PM

avatar image

KingBadger3D
21 1 4 6

avatar image Adam Davis STAFF Oct 21 '14 at 09:04 PM

Hi KingBadger3D,

Your PC is below minimum recommended specs, which can explain the graphical glitches you are currently seeing. You can find information about our recommended hardware here: https://docs.unrealengine.com/latest/INT/GettingStarted/RecommendedSpecifications/index.html

If you would like, you can private message me on the forums a sample asset that is producing this behavior and I would be happy to see if it reproduces on my end. If it does not then the assets will probably work on most machines.

avatar image as3ef2th1 Oct 21 '14 at 09:46 PM

As I said I've the same glitches with Epic Landscape mountains since 4.5.0 update, and my hardware is above recommended settings:

link text

I am running another project with a persistent world using heightmaps (conversion from 4.4), which run juste fine, and I was unable to reproduce the glitches no matter which settings I switched on or off, and that include the scalability settings from low to epic.

My two cents, if it can be of any help.

dxdiag.txt (93.5 kB)
avatar image KingBadger3D Oct 22 '14 at 12:26 AM

@as3ef2th1 , Cheers for backing me up. Adam this is a problem others have posted on the main forums. Also others are getting the same texture issues with the racer example from epic and the terrain example from epic.

I find it very hard to believe this is a minimum spec issue, especially after looking through the dxdiag of as3ef2th1 above.

I should also add ive got scene's working that have far higher poly counts and texture stress working that DONT use the terrain tool and just static mesh's and it still doesn't have these issues ive shown.

Im going to bite the bullet and try building one of the asset scene's i HAD working in older builds from scratch in 4.5.1. If works ill just have to redo all 12 examples from scratch (which is a massive pain in the ...) as trying to upload examples just for the point of no resolution is a waste of time.

Try to look deeper for the real answer Adam.

Cheers J

avatar image Tim Hobson ♦♦ STAFF Oct 22 '14 at 03:50 AM

I'm linking in the post from the Forums here as well.

@kingbadger3d: can you verify if you tried any of the suggestions I made on the forums? You never did respond if any of that helped solve your issue which appears to be similar to the issue I linked there.

You can also find that issue here on the AH at this link.

You mention you updated assets to 4.5.1. I can see in your Scene Outliner that you have the BP_Bird from the Mountains Landscape Demo. If you upgrade that particular asset you would have the issues you're seeing with the graphics glitch because this asset was adjusted in it's material. You would need to download the Mountains demo again as version 4.5 or you would need to follow the link above and follow the steps to update the material to meet the new one that works with 4.5+.

Tim

avatar image KingBadger3D Oct 28 '14 at 02:44 AM

Thanks Adam & Tim for taking the time to help. Yeah the weird flashing oddness issue was related to that blueprint. But the other issue i was pointing out is the flashing sections on the terrain as you fly in and out at a vertical angle.

Weird thing is it only really pops up when at fully vertical, pull up even a couple degrees and it seems to go away mostly and only seems an issue at terrain boundaries. This also happens even when not using lightmass lighting.

The streaming seems to have an issue at perfect world Z angles around the terrain edges. Still happens even in the 4.5.1 hotfix but not as bad. If you need me to test this further im willing, just let me know. Cheers James

avatar image Adam Davis STAFF Oct 28 '14 at 02:32 PM

Hi KingBadger3D,

Does the flashing occur if you take a landscape and manually adjust the surface with the in editor landscaping tools? I am curious to see if this is limited to Heightmaps or heightmaps from a specific program or if it occurs to any landscape.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question