x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Why DM scaled down after export from PhysX Lab

I have a .fbx mesh that im trying to convert to an .apb destructible mesh with PhysX Lab.

After importing my mesh into PhysX Lab it is scaled down and the pivot is shifted to the center. I´m using the centimeter units and default export settings in Maya, i tried using other units but no change...even if i scale the mesh in Maya there´s no change.

Here you can see the .fbx and the .apd in front.

https://www.dropbox.com/s/2eia7z94b0mlqbl/screen_object_scale.png?dl=0

Product Version: Not Selected
Tags:
more ▼

asked Oct 20 '14 at 05:29 PM in Everything Else

avatar image

Shaft
1 1 4

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

All of this should be handled in the modeling program, and nothing should need to be changed in PhysX Lab. If you need a check, make sure your FBX file imports in the correct scale; if not, then your model was exported incorrectly. This doesn't matter too much really, and as long as it's importing in a uniform scale you can just tell UE to up the scale when you import the APB file and all the collisions will work just as well.

My import method for DM FBX files:

  1. Maya 2016- Unit Scale set to Meters. If you made the model in the centimeter scale (default) you will need to scale it up by 100x after you set your Unit Scale to Meters (if your model looks tiny on your grid it's still sized wrong). Set model center and pivot point to 0,0,0 and export as FBX.

  2. Apex 1.3.2 PhysX Lab 3.3- No settings changes, import FBX, stuff and things, export APB.

  3. Unreal Engine 4.12 & 13- Import APB.

more ▼

answered Sep 09 '16 at 01:41 AM

avatar image

ErrinMiller
439 15 6 21

(comments are locked)
10|2000 characters needed characters left

Hi Shaft,

PhysX Labs uses a different scale than what UE4 uses as the default.

While UE4 uses CM and you've probably setup Maya to build your assets and export in Centimeters you'll find that PhysX is using inches.

Nvidia's documentation shows that there is a scale setting when exporting the asset ( at least there used to be ), but I do not believe this to be in their publicly released version. You can see this in their documentation by going to Help > PhysXLab Help > Search > Scale > Asset Authoring with PhysXLab

alt text

Since this won't help us you'll need to get your asset to the scale you'd in Centimeters then scale it up by 2.54 in the XYZ before importing into PhysX Lab if you want to keep your scale correctly set.

Thanks!

Tim

physxscale.png (38.6 kB)
more ▼

answered Oct 21 '14 at 05:30 PM

avatar image

Tim Hobson ♦♦ STAFF
48.9k 887 101 876

avatar image Shaft Oct 21 '14 at 06:44 PM

Thank you very much for the response!

I tried scaling the mesh up but it doesnt effect it in any way... No matter how much i scale it up it has always the same size in physxlab!

Are there any specific export settings i have to make in Maya?

Right now im using the default settings except fot centimeter units and the .fbx 2013 format.

(comments are locked)
10|2000 characters needed characters left

Maybe i´m stupid or PhysX is....

I start PhysX -> import my mesh -> mesh has wrong scale!

BUT if i start PhysX -> import Destruction Sample "Wall" -> import my mesh -> mesh has the right scale!

I still don´t know what i did wrong but it works that way!

more ▼

answered Oct 22 '14 at 02:51 AM

avatar image

Shaft
1 1 4

(comments are locked)
10|2000 characters needed characters left

I had a same problem, but I did fix it by exporting mesh as .obj and scaled it x100 in Blender and then import mesh in PhysX Lab.

more ▼

answered Sep 02 '16 at 08:21 AM

avatar image

ArthurSpark
1 1 3

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question